Out of the loop for a while, need a kind soul to help me get up to date

Discussion in '3DS - Flashcards & Custom Firmwares' started by Shady Guy Jose, Jan 17, 2016.

  1. Shady Guy Jose
    OP

    Shady Guy Jose GBAtemp Fan

    Member
    321
    107
    Sep 14, 2008
    Portugal
    Right, so I've got 2 3DSs. One is on 10.3 with no hacks whatsoever, and I'd like to keep it that way. The other one is on 4.5 with Gateway 3.7 and EmuNAND 10.3 running through the original MSET entry point. However, I've seen a bunch of new stuff pop up, including a method that supposedly allows you to coldboot straight into Gateway Mode, for newer firmwares. This would bring two advantages: the comfort of not having to go into the DS profile every single time, which would even eliminate the time window in which I'm running 4.5 and risking an automatic update download, and the ability to play my newer original games on this 3DS without screwing up my saves.

    My questions are:
    - Is this possible (i.e. am I not misunderstanding anything)?
    - What firmware should I update to (and what is the best method)?
    - Are there any drawbacks (needing specific games for stuff like NinjHax, needing an internet connection for stuff like BrowserHax, losing Blue Gateway compatibility - I believe this is fixable, but asking nonetheless)?

    It's way too much information to navigate, so I'm looking for someone who knows if one of the many currently available entrypoints allows me to do this
     
  2. driverdis

    driverdis I am Justice

    Member
    2,345
    886
    Sep 21, 2011
    United States
    1.048596β
    Use 9.2 with MSET downgrade. All the other methods except maybe the web browser exploit seem unstable to me as they do not have a near 100% boot rate and require up to a few times of rebooting to get it into homebrew. However, using Homemenuhax has a cool benefit for people with linked EmuNAND's. I found that the wrapping bug and some DSi games being put outside their folder and back onto the home screen bug do not occur with homemenuhax as it takes control early enough to prevent these from occuring.
     
    Shady Guy Jose likes this.
  3. Shady Guy Jose
    OP

    Shady Guy Jose GBAtemp Fan

    Member
    321
    107
    Sep 14, 2008
    Portugal
    So I would basically retain the exact same method/features with a 9.2 sysNAND? And how would I go about updating specifically to 9.2 and then downgrading MSET? No coldboot options then? Thanks in advance
     
  4. Aroth

    Aroth GBAtemp Addict

    Member
    2,066
    745
    Apr 14, 2015
    United States
    If you are only planning to use GW then do not bother downgrading MSET after the upgrade. GW does not support the DS Profile exploit on the O3DS/2DS for systems with a downgraded MSET.

    If you want to coldboot (which requires menuhax, you WILL need to update to at least 9.0). The best way I know of to do this is to use rxtools 2.6 and boot into devmode, then use sysupdater to update to 9.0 using an update package from that iso site. Do not attempt this in rxmode or in gw mode, or you WILL brick your system. If you do not mind the browser and other network features being out of date (which means no browserhax) then you can just find a game cart with 9.0 or 9.2 on it and update that way. Again do NOT do this in GW mode with a rom, or you will brick.

    If you are going to update with sysupdater I strongly suggest you use rxtools 2.6 and not the 3.0 nightlies as I believe the new version of devmode (called pastaMode) was broken in a recent nighly, no idea if it was fixed yet or not)

    If you decide to do this, you can then set up menuhax and ctrbootmanger to load gateway via the new gw.3dsx file that is included with the newer versions of Gateway's software.

    @driverdis That may be the case that it loads before the wrapping bug can happen, but it also can cause problems for people on linked systems because it tries to load right back into menuhax upon loading the emunand home menu. Not to mention if I remember correctly if you had linked nands and were using menuhax you can't use any purchased themes.

    — Posts automatically merged - Please don't double post! —

    In regards to these specific questions:

    Yes it is possible, and you should update to 9.0 or 9.2. I have heard reports that menuhax is more stable on 9.2, but have not been able to confirm it myself.

    You will need a way to launch *hax. This can be OoT if you have a way to inject the save (use gw's menu before updating the console if you own the game), Cubic Ninja, or just an internet connection. Cubic Ninja and OoT will work as long as you are on 9.0 or 9.2, regardless of the state of your browser. Browserhax will require that you have an exploitable browser and I am unsure if 4.5 has one or not. (I think as long as you HAVE a browser you can use browserhax, but don't quote me on that >_> )

    You WILL lose compatibility with the Blue Cart (as well as most other flash cards), but this is fixable. You can install a title called "flashcardtimewarp.cia" which is basically a v0 revision of the DS Cart Whitelist that has been spoofed to the most recent revision. This will let the Blue Cart work again. If you want more complete flashcart compatibility, since you are on the O3DS you can also downgrade the twl_firm to undo the changes they made there that blocked several carts. If you plan to do this I strongly suggest you use flashcardtimewarp and NOT the bluecardfix that is included with the GW software. Bluecardfix.cia is nothing more than a v0 of the Whitelist, and starting with 9.7 (i think) the system will prompt you to update if it sees that title is out of date.
     
    Shady Guy Jose likes this.
  5. Shady Guy Jose
    OP

    Shady Guy Jose GBAtemp Fan

    Member
    321
    107
    Sep 14, 2008
    Portugal
    Thanks, I believe this has most of the stuff I need, or at least enough for me to sort out the details on my own. Just to be sure: this will always allow me to restore a 4.5 NAND dump if I need to, right?