OTPHelper - APP(0) is in unmapped area after 2.1 downgrade

Discussion in '3DS - Flashcards & Custom Firmwares' started by pwnerstorm, Jul 3, 2016.

  1. pwnerstorm
    OP

    pwnerstorm Newbie

    Newcomer
    5
    0
    Jul 3, 2016
    United States
    Downgrading N3DS XL to 2.1.0 to get OTP for install of a9lh. (Pialect guide, part 4, section IV, step 15).

    Every run of OTPHelper after a successful downgrade with PlaiSys fails the One Click validation check. Always with "app(0) is in unmapped area", and always for the same title (0004009B00013302).

    The troubleshooting guide just says "restore both NANDs and try again". I've tried this at least 10 times, but it doesn't appear to be making any difference. There are some other instructions about what to do for TMD errors, but nothing for these APP errors.

    How can I clear this error to make it safe to flash the RedNAND to SysNAND? The full log from OTPHelper is below.

    Warning: Spoilers inside!
     
  2. yacepi15

    yacepi15 GBAtemp Advanced Fan

    Member
    890
    178
    Aug 15, 2015
    Antarctica
    Do not restore NANDs. Start from scratch. Try another SD card or format the actual one with SDFormatter.
    And... Did you update your RedNAND to 11.0 before downgrading? Do not skip steps or you will have a paperweight.
     
  3. pwnerstorm
    OP

    pwnerstorm Newbie

    Newcomer
    5
    0
    Jul 3, 2016
    United States
    I have restarted completely from scratch 3 times now, on 2 different microSDs from different manufactuers, both of which were formatted with SDFormatter beforehand. I get exactly the same result, it bombs out on the same title every time.
     
  4. yacepi15

    yacepi15 GBAtemp Advanced Fan

    Member
    890
    178
    Aug 15, 2015
    Antarctica
    Did you update RedNAND to 11.0 before downgrading? Did you check the checksums of the DGPack? Do you have installed DsiWare (remove it) or TWL patches? (Bluecardfix.cia doesnt count)
     
  5. SomeGamer

    SomeGamer GBAtemp Guru

    Member
    5,753
    2,703
    Dec 19, 2014
    Hungary
    Is that really necessary? I did the whole thing on 10.7 with rxTools 3.0.
     
  6. pwnerstorm
    OP

    pwnerstorm Newbie

    Newcomer
    5
    0
    Jul 3, 2016
    United States
    Yep, RedNAND was 11.0, upgraded OTA via System Settings. The checksum for the downgrade files are good, as well as the MD5 checks done by PlaiSys on the CIAs - all pass. Did a factory reset on SysNAND before starting the whole guide, so there shouldn't be anything else installed on it, no patches etc.
     
  7. Quantumcat

    Quantumcat Dead and alive

    Member
    10,539
    5,566
    Nov 23, 2014
    Australia
    Canberra, Australia
    I think maybe the format doesn't restore TWL and AGB titles. Where would it get the data from? I think you should try sourcing the original titles and install them. I am only guessing though.
     
  8. EmperorOfCanada

    EmperorOfCanada GBAtemp Maniac

    Member
    1,479
    96
    Aug 4, 2008
    Canada
    Canada
    @Plailect any ideas, or just keep trying?
     
  9. yacepi15

    yacepi15 GBAtemp Advanced Fan

    Member
    890
    178
    Aug 15, 2015
    Antarctica
    The problem is with 9.X. 10.X doesnt have that issue.

    — Posts automatically merged - Please don't double post! —

    Some "non-legit" dsiware didnt uninstall with a system format in my case. Go to system settings and check it.

    — Posts automatically merged - Please don't double post! —

    @pwnerstorm And... I wont take any responsability but... The "0004009B00013302" title, for the USA region is the EULA. Can you try reinstalling the one from 11.0 (download it with 3DNUS) and reinstall it on the 11.X rednand and retry?
     
    SomeGamer likes this.
  10. pwnerstorm
    OP

    pwnerstorm Newbie

    Newcomer
    5
    0
    Jul 3, 2016
    United States
    I downloaded the 11.0.0-33U 0004009B00013302 title as a cia, and installed it to the RedNAND v11 via FBI. Restarted to RedNAND via HBL for good measure, came right up, then kicked off PlaiSys again to downgrade to 2.1.

    The downgrade reported success, but OTPHelper still isn't happy.

    That actually cleared the APP(0) error for 0004009B00013302, but now there are tons of TMD errors for lots of different titles, and I have a new APP(0) error for something else. I restored emunand_formatted, and now it just fails on the original title again.
     
  11. pwnerstorm
    OP

    pwnerstorm Newbie

    Newcomer
    5
    0
    Jul 3, 2016
    United States
    Thanks for all the help guys. I ended up fixing this by batch installing the entire 2.1 updates folder into RedNAND via FBI instead of PlaiSys, deleting the offending app(0) title via FBI in RedNAND, and then reinstalling just that specific CIA file again (all on the same boot). Rebooted to HBL, ran OTPHelper, all errors now gone. Finished the rest of the a9lh guide without a hitch after that.
     
    Last edited by pwnerstorm, Jul 5, 2016
  12. EmperorOfCanada

    EmperorOfCanada GBAtemp Maniac

    Member
    1,479
    96
    Aug 4, 2008
    Canada
    Canada
    Kinda an odd situation you ran into, but glad you got through it!