Orange light flashing, no charge, changed battery, fuses OK, now what?

Discussion in 'NDS - Console and Game Discussions' started by AlexBE, Jan 6, 2012.

  1. AlexBE
    OP

    AlexBE Newbie

    Newcomer
    9
    1
    Jan 20, 2011
    Belgium
    Hi all

    I seem to have a quite regular issue. Suddenly my DS lite won't charge or power on.

    I bought a new battery, checked voltage with multimeter, says 3.5V and still won't charge or power on.

    I bought a new charger, absolutely no difference.

    I opened the DS and checked both fuses with multimeter, and they are fine.

    I tried plugging into different outlets, etc.

    What can I try to fix it now please ?
     
  2. AlexBE
    OP

    AlexBE Newbie

    Newcomer
    9
    1
    Jan 20, 2011
    Belgium
    up :)
     
  3. Sicklyboy

    Sicklyboy Resident Mechanical Keyboard Addict

    Global Moderator
    5,690
    4,599
    Jul 15, 2009
    United States
    [̲̅$̲̅(̲̅ ͡° ͜ʖ ͡°̲̅)̲̅$̲̅]
    Check and see if any of the SLOT-1 pins are bent, and as a result touching. Has the system suffered any sort of water damage?

    Open it, make sure that all of the ZIF cables for the screen are properly inserted. There's 3 - Top screen connects to the mobo, touch layer connects to the bottom LCD which then connects to the mobo too.
     
  4. Mariosegafreak

    Mariosegafreak AKA ZeroTheSavior

    Member
    313
    32
    Aug 7, 2011
    United States
    Gensokyo
    If you haven't charged your ds in 6 months, it pretty much dies. So, don't lose your ds...
     
  5. AlexBE
    OP

    AlexBE Newbie

    Newcomer
    9
    1
    Jan 20, 2011
    Belgium
    no water damage, it just spent about 3 month without being used, then when I tried to power it up, this issue came up.

    What do you mean Mariosegafreak ? A new battery should do the trick if it's just the old one that dies if not used ...


    I'm gonna try checking connections again, but the DS was in a pouch and didnt fall or anything during that time...
     
  6. will1987

    will1987 Advanced Member

    Newcomer
    57
    2
    May 20, 2011
    Brazil
    Tangamandapio
    Man the same thing happened with me, I tried to fix this problem, but I never succed.

    After the up screen burned, and my DSlite didn't turn on anymore, I changed the screen, the DSlite turned it on again, and the problem continued.

    One guy told me that the problem is the board temperature, I used to let it all the time in my bag, and maybe this was the possibility to get damaged!

    So I bought a DSI XL(with a protection sure)
     
  7. AceWarhead

    AceWarhead "Must Construct Additional Pylons"

    Member
    1,276
    358
    Apr 9, 2011
    United States
    Perhaps leaving it in the pouch so long tasted it? I've heard and seen that kinda stuff happen. You shouldn't keep it in a bag for so long, as the temperature increases.