OpenWii Updates

Discussion in 'Wii - Hacking' started by kai445, Mar 17, 2007.

Mar 17, 2007

OpenWii Updates by kai445 at 5:16 PM (3,520 Views / 0 Likes) 32 replies

  1. kai445
    OP

    Member kai445 GBAtemp Fan

    Joined:
    Oct 16, 2006
    Messages:
    325
    Country:
    United States
    Sites
    OpenWii (http://openwii.org/)
    EFnet #openwii-dev

    Latest Updates
    v2.1 - GPL Release! Code rewritten and more portable, and now patches the DVD drive directly.
    v2.0 - (Beta): Region Free Wii/GC support, and Setup Disc capability.
    v1.3 - Final released, no added features.
    v1.3 - (Beta) Added DVD±R and DVD±RW support, proper Speed Fix, supports +R/RW with or without (-ROM) bitsetting
    v1.2 - Added 6x DVD Read Support
    v1.1 - Added GC Backup/Homebrew Support

    Features
    100% Original and Open Source Code
    Full DMS / D2A / D2B Chipset Support
    Boots Wii originals and backups from all regions
    Boots GameCube originals and backups from all regions
    Boots GameCube homebrew
    6x DVD Read Speed (adjustable via Setup Disc)
    DVD±R & DVD±RW media fully supported
    DVD+R/RW Bitsetting (DVD-ROM) also supported

    Coming Soon
    Audiofix should be coming soon. ("Audio Fix next" -rhcp)

    Installation
    New Install Diagrams: http://www.openwii.org/forums/viewtopic.php?t=64
    Old Install Diagrams: http://www.openwii.org/forums/viewtopic.php?p=125

    Releases
    OpenWii 2.0 Firmware (Beta)
    OpenWii 1.3 Firmware
    OpenWii 1.3 Firmware (Beta)
    OpenWii 1.2 Firmware
    OpenWii 1.1 Firmware
    OpenWii 1.0 Firmware

    Alternate Platforms
    Atmel AVR/Atmega: http://openwii.org/forums/viewtopic.php?t=20
    TI (MSP430) : http://openwii.org/forums/viewtopic.php?t=33
    Microchip PIC (675 / 629) : http://openwii.org/forums/viewtopic.php?t=34
    Microchip PIC (509a) : http://openwii.org/forums/viewtopic.php?t=11 (not yet released)
    Atmel ATtiny : http://www.openwii.org/forums/viewtopic.php?t=17

    Hardware
    Chiip! (~$20) - http://chiip.descrambler.de/index.php/Tools_Supplies
    Wiip! ($20) - https://www.tcniso.net/shop/product.php?pro...41&cat=6&page=1
     


  2. RougeRat

    Newcomer RougeRat Newbie

    Joined:
    Mar 1, 2007
    Messages:
    6
    Country:
    United States
    What parameters do I use to flash this to an atmega8l that I've been using for chiip? I'm using avrdude. Also, I assume, that they use the same contact points inside the wii for this installation, but do I use the same legs on the chip? The picture in the thread linked says i use other legs, but the same points. Just trying to confirm. I'll be flashing this probably tomorrow.
     
  3. atka

    Newcomer atka Newbie

    Joined:
    Feb 28, 2007
    Messages:
    9
    Country:
    Canada
    Just flash the Chiip all the fuse bits are the same and the pin out is the same.
     
  4. anitabill

    Newcomer anitabill Member

    Joined:
    Feb 28, 2007
    Messages:
    24
    Country:
    United States
    Where did you find the correct Hex file?
     
  5. RobertsD

    Member RobertsD GBAtemp Regular

    Joined:
    Mar 6, 2006
    Messages:
    179
    Country:
    United States
    In the first post, under releases, select OpenWii 1.2, then download that file. Open it up, then open openwii>umod>chiip. You need openwii.hex.

    Flash it with this command.

    avrdude -p m8 -c sp12 -U flash:w:openwii.hex -U lfuse:w:0xE3:m -v
     
  6. anitabill

    Newcomer anitabill Member

    Joined:
    Feb 28, 2007
    Messages:
    24
    Country:
    United States

    Thank you kindly RobertsD.

    The tar extention through me off [​IMG]

    I'm good now.
     
  7. RobertsD

    Member RobertsD GBAtemp Regular

    Joined:
    Mar 6, 2006
    Messages:
    179
    Country:
    United States
    The 6x read speed is working great [​IMG]

    I'll stick to the chiip firmware until this supports DVD+R's though.
     
  8. anitabill

    Newcomer anitabill Member

    Joined:
    Feb 28, 2007
    Messages:
    24
    Country:
    United States
    I guess I’m lucky, all of my back-ups are on DVD-R's. I would love to stick with the chiip firmware. But I’m sick of hearing my wife say the video stuttering is annoying. As soon as the Chiip firmware has the DVD speed feature I’m switching back. Hopefully soon.
     
  9. anitabill

    Newcomer anitabill Member

    Joined:
    Feb 28, 2007
    Messages:
    24
    Country:
    United States
    Well that didn’t work at all. I flashed the new firmware and the Chiip was blinking when put in the Wii. but no disks would boot at all. reflashed with the Chiip firmware and all is well. I guess I’ll just wait for the chiip firmware to get updated. Thanks for your help.

    Bill
     
  10. Hogmeister

    Member Hogmeister GBAtemp Regular

    Joined:
    Nov 26, 2005
    Messages:
    144
    Country:
    United States
    awaiting it to be released for PIC's so i can flash it onto some of these 12f629's i've got here. sounds like a big improvement in my book [​IMG]
     
  11. atka

    Newcomer atka Newbie

    Joined:
    Feb 28, 2007
    Messages:
    9
    Country:
    Canada
    Do you have a Pal Wii? On their forums it seems like Pal users are having trouble with this firmware.
     
  12. anitabill

    Newcomer anitabill Member

    Joined:
    Feb 28, 2007
    Messages:
    24
    Country:
    United States
    No i have NTSC. But i am using a ATMEGA8L-8PU chip. Do you think it requires 16?
     
  13. WII20

    Newcomer WII20 Member

    Joined:
    Mar 14, 2007
    Messages:
    22
    Country:
    United States
    Anitabill, I don't think this is gonna work on the atmels that we have for chiip. Firstly, the points that we installed to on the wii for chiip are different than the ones for open wii; If you look at the diagram again, instead of soldering to where #8 is , we soldered to that shiny pad between "m" and "d". Also the points you need to solder to on the atmel open wii lists are way different than the points that we soldered to for chiip on top of that fact that we're using 28 pin atmels as opposed to a 20 pin.
     
  14. anitabill

    Newcomer anitabill Member

    Joined:
    Feb 28, 2007
    Messages:
    24
    Country:
    United States

    Thanks for explaining WII20,

    I'm still happy with my Chiip. The stuttering fix would have been nice; it’s all a matter of time until the Chiip firmware supports it as well.

    Bill
     
  15. RobertsD

    Member RobertsD GBAtemp Regular

    Joined:
    Mar 6, 2006
    Messages:
    179
    Country:
    United States
    I flashed this to my ATMEGA8L-8PU built(and wired) for chiip. I did not have to rewire anything, it worked exactly as it was. He has a version specifically for those with Chiip installs.

    It works exactly as it says it should. My LED flasheds constantly, but it reads all backups on DVD-R perfectly fine.

    There is obviously something not quite right with what anitabill did, since mine is working perfectly.
     
  16. WII20

    Newcomer WII20 Member

    Joined:
    Mar 14, 2007
    Messages:
    22
    Country:
    United States
    You're right RobertsD, but apparently there is a patch out to make it work. Anitabill, take a look here Chiip Patch . This should help you getting it to work on the Chiip Atmels. Tell us what happens [​IMG]
     
  17. atka

    Newcomer atka Newbie

    Joined:
    Feb 28, 2007
    Messages:
    9
    Country:
    Canada
    Don't use the Chiip patch that was for previous firmware versions. The Openwii 1.2 works on the Chiip exactly as is if you use the Chiip firmware on it.
    Also if you check their site I compiled a firmware to stop the flashing LED once its synced.
     
  18. RobertsD

    Member RobertsD GBAtemp Regular

    Joined:
    Mar 6, 2006
    Messages:
    179
    Country:
    United States
    Yes, like atka said, there is a chiip version included with the 1.2 release. That patch you linked to is for a older version.
     
  19. Smack

    Member Smack GBAtemp Regular

    Joined:
    Jun 13, 2006
    Messages:
    263
    Location:
    Vancouver, BC
    Country:
    Canada
    I tried your firmware but now it won't read discs. I have been trying to get on the OpenWii forums to relay this info but I am yet to receive a confirmation e-mail. I'll have to wait and see if RobertD has the same issue.

    I am running an NTSC-U D2A chipset burnt at 2.4x on BenQ 8x +R media and the following happens.

    Boot up Wii, LED flashes continually. (seems like the break between flashes is longer than usual)
    Insert Wii backup(s) and it does not read the disc.

    So I am back to 1.2 and Chiip beta5 for now.
     
  20. anitabill

    Newcomer anitabill Member

    Joined:
    Feb 28, 2007
    Messages:
    24
    Country:
    United States
    Smack that is exactly my issue.


    I'm just wondering if this firmware has issues with some DVD-R's. All of my back-up are on the same brand DVD-R's.
     

Share This Page