One Piece: Unlimited Adventure problem?

Discussion in 'Wii - Backup Loaders' started by SS4, May 11, 2011.

May 11, 2011
  1. SS4
    OP

    Member SS4 GBAtemp Fan

    Joined:
    Jan 13, 2010
    Messages:
    352
    Location:
    In front of my Computer
    Country:
    Canada
    I'm using the customizable USB loader installed by ModMii. Now everytime i run the game if i watch the first cutscene it freezes at the part where Luffy picks up that blue crystal ball he fished.

    I can skip the cutscene and play the game just fine though, and I havent played alot so i dunno if other cutscenes have issues as well.

    Now did I just get a bad torrent or is this a know issue with the game coz I went through the game issue database I found on this website but there is no mention of any problem with the game liste under: One Piece: Unlimited Adventure (NTSC).

    http://wiki.gbatemp.net/wiki/USB_Game_Compatibility_Table/O
    or
    http://wiki.gbatemp.net/wiki/USB_Game_Compatibility_Table
    for the whole list.

    I wonder if that list is out of date coz some games are listed as having issues but they work fine on my end...
     
  2. WiiPower

    Member WiiPower GBAtemp Guru

    Joined:
    Oct 17, 2008
    Messages:
    8,165
    Country:
    Germany
    Bad rip, seems to be reported to be the only issue with it.
     
  3. Ryoku83

    Member Ryoku83 GBAtemp Fan

    Joined:
    Apr 14, 2011
    Messages:
    324
    Country:
    Canada
    Push the + button and skip the video. I had the same issue with the rip I have, so I just skipped the video and everything has been fine so far. Im around 20 hours into the game atm

    One Piece: Unlimited Adventure [Wii] [NTSC] [PROPER] is the rip Im using
     
  4. Cyan

    Global Moderator Cyan GBATemp's lurking knight

    Joined:
    Oct 27, 2002
    Messages:
    16,402
    Location:
    Engine room, learning
    Country:
    France
    Unlimited Adventure intro hangs on all PAL Wiis (at the boat scene).
    just skip it, that's the only problem. I completed the game without any other freeze.

    Unlimited Adventure doesn't contain PAL signal at all, and needed the video signal patched manually (with WiiGenericPatcher or video Mode Changer).
    But with USBLoaders it's not needed anymore, just force to PAL if the video is not working (green screen at launch).
     
  5. WiiPower

    Member WiiPower GBAtemp Guru

    Joined:
    Oct 17, 2008
    Messages:
    8,165
    Country:
    Germany
    You still don't understand how the video mode stuff works, do you? If the game doesn't contain PAL video mode, then forcing the game to run in PAL is exactly what will result in a green screen freeze. Just run the game with disc video mode on all Wiis, and it will work, and it's the same for almost if not all games. If you get color issues with that, and only then, forcing PAL(your tv's region) in combination with some sort of video mode patch is worth mentioning.
     
  6. Slimmmmmm

    Member Slimmmmmm GBAtemp MoNkEeE

    Joined:
    Nov 1, 2007
    Messages:
    1,687
    Location:
    the land of lol
    Country:
    United Kingdom
    There were some bad dumps of One Piece: Unlimited Adventure (NTSC) that had the intro video problem. However there was a fixed dump released that 100% works.

    The only way to fix this problem is get a proper 1:1 release of the game...sorry I don't remember the release group that released the fixed version or it might have been a site specific release. As long as it's 1:1.
     
  7. Cyan

    Global Moderator Cyan GBATemp's lurking knight

    Joined:
    Oct 27, 2002
    Messages:
    16,402
    Location:
    Engine room, learning
    Country:
    France
    You are right, I guess I mixed things.
    I thought forcing the video was also adding missing signal like when using video mode patcher.
    And I also thought that One piece needed the PAL signal to actually work on PAL Wiis, and that it didn't launch if PAL wasn't included.

    But that was only because that NTSC game launched from Disc Channel didn't have a PAL mode listed in the available signal that it didn't work, and USBloaders just use listed video signal now.
    (When I actually played it, I used the disc Channel).


    And the fact is I already know that, I was just confused because of the manual patch I did on that disc ages ago.
    When Dimok set the video mode to "console default" on GX2.0 a lot of users had the blackscreen at launch with imported games, and I often recommended to users to put "game default" back in the main settings.

    Sorry for misunderstanding and confusing the users [​IMG]
     
  8. WiiPower

    Member WiiPower GBAtemp Guru

    Joined:
    Oct 17, 2008
    Messages:
    8,165
    Country:
    Germany
    No problem. "Forcing" a video mode in a loader is nothing else than just switching to that video mode before booting the game. And the disc channel always uses the wii's region video mode, which is the reason why lots of import games do not work in the disc channel*. I can't tell this often enough, >95% of games work on all regions without any special settings, they just need to be booted in the video mode of the game's region. As far as i can see it, PAL and US Wiis do not have any different hardware, the region is only a software thing. Korean Wiis are something else, because of the different common key, but i don't care much about them.


    *Maybe my knowledge is years behind in this, but last time i checked there wasn't any priiloader hack to load games with the correct video mode.
     
  9. SS4
    OP

    Member SS4 GBAtemp Fan

    Joined:
    Jan 13, 2010
    Messages:
    352
    Location:
    In front of my Computer
    Country:
    Canada
    Sory for not replying in a while but yah, i did like Slimmmmm said and got a different NTSC copy and now it doesnt freeze anymore.

    And regarding the NTSC vs PAL problem its not the hardware (well the Wii are same but not the TVs [​IMG]) its the signal to the TV which use a different refresh rate. Dunno why they use 50 instead of 60, thats so stupid in this day an age with HD and high FPS games to display on 60 instead of 120hz.... now 50 is just weird imo ^^
     
  10. WiiPower

    Member WiiPower GBAtemp Guru

    Joined:
    Oct 17, 2008
    Messages:
    8,165
    Country:
    Germany
    I just love that HD sports events here in germany use 1080i50...
     

Share This Page