OMG!! PSO Episode I & II working on DIOS MIOS.

Discussion in 'Wii - Hacking' started by portugeek, Apr 27, 2013.

Apr 27, 2013
  1. portugeek
    OP

    Member portugeek GBAtemp Fan

    Joined:
    Apr 6, 2013
    Messages:
    345
    Country:
    United States
    Alright so I'm super excited about this right now!! I've been trying for probably 3 weeks straight and still nothing. Granted some of the methods I was trying would get me deviated from the main goal, and I'd start experimenting with other wii mods along the way, so that's why it took me longer. But anywho.. on to the good stuff!!

    Things you'll need: - Numbers/Text in BOLD are important!! So make sure to take note.
    -DIOS MIOS 2.2
    -Phantasy Star Online Episode I & II (v1.01)
    -GCReEX (I'm using v0.3)
    -USB Loader GX (I'm using ver3.0 r1213)
    -USB Drive formatted Fat32 with 32KB clusters with the drive set to Active and the partition set to Primary.

    I'll start off by posting my sysCheck... that way you know exactly which IOS's I'm using.
    Code:
    sysCheck v2.1.0b19 by Double_A and R2-D2199, Nano
    ...runs on IOS58 (rev 6176).
     
    Region: NTSC-U
    System Menu 4.1U (v449)
    Priiloader installed
    Drive date: 2007.02.13
    Homebrew Channel 1.1.0 running on IOS58
    HomebrewFilter ist nicht installiert
    Hollywood v0x11
    Console ID: XXXXXXXXX
    Boot2 v3
    Found 136 titles.
    Found 53 IOS on this console. 3 of them are stub.
     
    IOS4 (rev 65280): Stub
    IOS9 (rev 54321): Trucha Bug8
    IOS10 (rev 768): Stub
    IOS11 (rev 54321): Trucha Bug
    IOS12 (rev 526): No Patches
    IOS13 (rev 1032): No Patches
    IOS14 (rev 1032): No Patches
    IOS15 (rev 1032): No Patches
    IOS16 (rev 54321): Trucha Bug, ES Identify, Flash Access, NAND Access
    IOS17 (rev 1032): No Patches
    IOS20 (rev 54321): Trucha Bug
    IOS21 (rev 1039): No Patches
    IOS22 (rev 1294): No Patches
    IOS28 (rev 1807): No Patches
    IOS30 (rev 54321): Trucha Bug
    IOS31 (rev 3608): No Patches
    IOS33 (rev 3608): No Patches
    IOS34 (rev 3608): No Patches
    IOS35 (rev 3608): No Patches
    IOS36 (rev 54321): Trucha Bug, ES Identify, NAND Access
    IOS37 (rev 5663): No Patches
    IOS38 (rev 4124): No Patches
    IOS41 (rev 3607): No Patches
    IOS43 (rev 3607): No Patches
    IOS45 (rev 3607): No Patches
    IOS46 (rev 3607): No Patches
    IOS48 (rev 4124): No Patches
    IOS50 (rev 54321): Trucha Bug
    IOS51 (rev 4864): Stub
    IOS53 (rev 5663): No Patches
    IOS55 (rev 5663): No Patches
    IOS56 (rev 5662): No Patches
    IOS57 (rev 5919): No Patches
    IOS58 (rev 6176): USB 2.0
    IOS60 (rev 54321): Trucha Bug
    IOS61 (rev 5662): No Patches
    IOS62 (rev 6430): No Patches
    IOS70 (rev 54321): Trucha Bug
    IOS80 (rev 54321): Trucha Bug
    IOS90 (rev 54321): Trucha Bug
    IOS202[60] (rev 65535, Info: hermesrodries-v6): Trucha Bug, NAND Access, USB 2.0
    IOS222[38] (rev 4, Info: hermes-v4): Trucha Bug, ES Identify, NAND Access, USB 2.0
    IOS223[38+37] (rev 4, Info: hermes-v4): Trucha Bug, ES Identify, NAND Access, USB 2.0
    IOS224[57] (rev 65535, Info: hermesrodries-v6): Trucha Bug, NAND Access, USB 2.0
    IOS236 (rev 54321): Trucha Bug, ES Identify, NAND Access
    IOS245[37] (rev 21008, Info: d2x-v8final): Trucha Bug, NAND Access, USB 2.0
    IOS246[38] (rev 21008, Info: d2x-v8final): Trucha Bug, ES Identify, NAND Access
    IOS247[53] (rev 21008, Info: d2x-v8final): Trucha Bug, NAND Access, USB 2.0
    IOS248[55] (rev 21008, Info: d2x-v8final): Trucha Bug, NAND Access, USB 2.0
    IOS249[56] (rev 21008, Info: d2x-v8final): Trucha Bug, NAND Access, USB 2.0
    IOS250[57] (rev 21008, Info: d2x-v8final): Trucha Bug, NAND Access, USB 2.0
    IOS251[58] (rev 21008, Info: d2x-v8final): Trucha Bug, NAND Access, USB 2.0
    IOS254 (rev 65281): BootMii
    BC v5
    MIOS v10 (DIOS MIOS 2.2.2+)
     
    Report generated on 2013/04/26.
    PC stuff:
    If you don't already have it, you'll need to find Phantasy Star Online Episode I and II (v1.01) It has to be that version specifically. You may have to do some searching for it but it shouldn't be hard too hard find.

    Once you have the correct game ISO, you'll need to run it through GCReEx. (If you already know this stuff, skip past the part with the blue text.)

    GCReEx is going to require some knowledge of Command Prompt. To make the process simpler, extract the GCReEx.rar into the same folder that contains your game ISO.

    Start up Command Prompt and direct it to your folder containing both the game iso and GCReEx.

    (If you don't know how to do that)
    Basic Command Prompt stuff: - If you type...
    cd.. - it will back you out of a folder.
    cd dir - it will show you the contents of the folder you're currently on.
    cd [name of folder] - will open up that specific folder that you typed the name of.

    Command Prompt usually starts you on the C: drive. If the game iso and GCReEx are on a folder in a different drive, then just type the corresponding drive letter followed by a colon to place you on the correct drive. (example: if your files are on drive G, then you'd type G: )

    Alright, so once you make your way to the folder containing your files (game.iso and gcreex.exe) you'll want to type... GCReEx.exe -x game.iso and hit enter. That will extract the game iso into it's own folder named after it's [GameID].

    Once you have your extracted game folder it should have two folders inside. (named "root" and "sys") Move the [gameID] folder, and it's contents, over to the games folder on your USB Drive.


    Wii stuff:
    Make sure you start off by having DIOS MIOS 2.2 installed on your system. It's a wad file, so you should be able to install it using your favorite wad manager. I used Waninkoko's Wad Manager v1.7 and I ran it on IOS 236.

    Start up USB Loader GX, if you've done everything correct, and placed the folder in the right place, you should see that Phantasy Star Online Episode I and II is now in your GameCube games list. If you don't see it you may need to go to your USB Loader GX folder, that's inside your Apps folder, and delete the titles_cache file.

    Click on the game and go to settings>game load (this is how I have my settings set, I only listed the ones I thought were important.)
    -GameCube Mode = MIOS (Default and Custom Mios)
    -DML Progressive Patch = OFF
    -DML NMM Mode = OFF
    -DML PAD Hook = OFF
    -DML No Disc+ = OFF

    When you're done, click Save. Back out, and before you start your game, make sure you have a dummy disc in the drive. It doesn't matter what kind of disc it is. (I use an old GameCube disc that doesn't work anymore.)

    The game should load up, and when it does, it'll prompt you to set the clock. Make sure you select NO. Selecting NO will make the game start up with whatever default time is on your Wii. The game is only giving you the option to change it because the time currently set on your Wii may be different from the REAL time, and having the correct time was important for when purchasing a Hunter's License. It doesn't matter anymore.

    Also, I've heard that the game won't work if you have anything plugged into GameCube memory card slot B. I don't, so I never experienced that issue. But in case you do, you may want to remove whatever it is.


    Hope this works for you guys! Happy Hunting!! :yay:

    EDIT: I just went and started it back up. The pause time between the DIOS MIOS splash screen and when the game actually loads up is dramatically long. I was almost like.. Dafuh?? But it worked!! :D
     
    Slimmmmmm and scooby74029 like this.


  2. scooby74029

    Member scooby74029 "fake coder"

    Joined:
    May 7, 2010
    Messages:
    1,174
    Location:
    oklahoma, USA
    Country:
    United States
    damn look at you now just the wii - nerd huh glad everything is working for you
     
    MassiveRican and portugeek like this.
  3. duffmmann

    Member duffmmann GBAtemp Addict

    Joined:
    Mar 11, 2009
    Messages:
    2,430
    Country:
    United States
    Hasn't PSO been working on DIOS MIOS for a while now?
     
  4. portugeek
    OP

    Member portugeek GBAtemp Fan

    Joined:
    Apr 6, 2013
    Messages:
    345
    Country:
    United States
    :P You know the whole time you were walking me through UNEEK, it was cuz of this damn game! LOL I tried so much stuff man. Most of which was so I could avoid downgrading to DM 2.2.

    Earlier I tried downloading DM-xNEEK-DI. Hoping that I could change the BC executable in emuNAND so that I could avoid the BC from auto booting back to real nand and running of the real nand's MIOS. I couldn't get it to work though.. I'm not sure which MIOS should be installed in emuNAND for it work. I'm assuming the same ver. of DM as the ver. of DM-xNEEK-DI that I downloaded. Which was 2.2.

    What I was hoping was that I could have specific games run inside emuNAND on DM 2.2, and others run in the real nand with DM 2.9. I ended up learning that it was all for nothing because I run 95% of my GC games through Devolution, and the other 5% through DM. And of those 5%, none of them have issues with DM 2.2 so downgrading was the best thing for me to do because it actually gave me MORE compatibility by allow PSO to run properly.


    It only works on 2.2 although the compatibility list says that there's a version of PSO that runs on 2.4. But I'm relatively new to DM and I've never been able to get PSO to work on DM 2.8 or 2.9. I guess my stubbornness kept trying to get it to work on those versions, or via different methods.
     
  5. macmanhigh

    Banned macmanhigh THC = Truly High Caliber

    Joined:
    Mar 29, 2012
    Messages:
    699
    Location:
    BuddsVille,CA
    Country:
    United States
    Cant remember how many hours i put into this on Dreamcast....Gonna check it out :)
     
  6. Rydian

    Member Rydian Resident Furvertâ„¢

    Joined:
    Feb 4, 2010
    Messages:
    27,883
    Location:
    Cave Entrance, Watching Cyan Write Letters
    Country:
    United States
    There's also private servers for the PC version, which includes Episode 4 as well.
     
  7. portugeek
    OP

    Member portugeek GBAtemp Fan

    Joined:
    Apr 6, 2013
    Messages:
    345
    Country:
    United States
    So I've been messing with converting AR codes to Wiird codes so that I could use them with this game. Well I'm getting the codes to convert but I can't seem to get the codes to work. Anywho, in the process of trial and error I found out a cool little trick using the Master Code, and I have no idea why it works, but it does.

    If you turn on the Master Code cheat for this specific version of the game (v1.01). DIOS MIOS 2.2 will actually run the game without the need of a dummy disc. Not ground breaking, but still cool I thought. :P

    Code:
    GPOE8P
    Phantasy Star Online I & II v1.01
     
    Master Code
    20010BE0 4E800020
    E2000001 80008000
    206C79BC 7FC803A6
    E2000001 80008000
    20434F30 6F736520
    E2000001 80008000
    If you wanna test this out, copy the above text in to notepad and save it as GPOE8P.txt... Then drop it in your codes folder. Go to Ocarina and make sure the code is ON. And make sure to remove the dummy disc. It actually hangs at the black screen if you leave the dummy disc in.
     
    scooby74029 likes this.
  8. portugeek
    OP

    Member portugeek GBAtemp Fan

    Joined:
    Apr 6, 2013
    Messages:
    345
    Country:
    United States
    DIOS MIOS 2.10 has been recently released. And with this new release of DM, PSO Episode I & II v1.01 now works without Ocarina being turned on, and without the need of a dummy disc. So for those of you still using DIOS MIOS 2.2, specifically for this game, you can finally upgrade! :)
    -EDIT: I just tested it using the game.iso and it also works! So it no longer needs to be in GCReEX format to work.

    I tried testing to see if PSO Episode I & II Plus v1.2 would work, and I had no luck. Although I did find something interesting. If you start the game with the Ocarina setting turned ON (.gct file not required, just press continue), and without a disc in the drive, you'll get the message...

    "The Disc Cover is open.
    If you want to continue the game,
    please close the Disc Cover."

    Then after putting a random GameCube disc in the drive, you'll get the message...

    "This is not
    the PSO Episode 1&2 Plus Game Disc.
    Please insert
    the PSO Episode 1&2 Plus Game Disc."

    I've never seen this message in previous versions of DIOS MIOS. It makes me wonder if this game could possibly work if someone tried inserting a backup disc of this game in the drive instead of just a random GC disc. If nobody tries it I may test it out eventually.
     
  9. Nuxx

    Newcomer Nuxx Newbie

    Joined:
    Jun 4, 2013
    Messages:
    1
    Country:
    United Kingdom
    Did you get the AR working i have GPOP8P PSO ep 1 and 2 on retail disk tried searching for a gct but cant find one D: tried making one.. no luck did you find a fix for your gpoe8p?
     
  10. portugeek
    OP

    Member portugeek GBAtemp Fan

    Joined:
    Apr 6, 2013
    Messages:
    345
    Country:
    United States
    I don't have an Action Replay so I had to go through the process of converting AR codes to WiiRD. Plus this game has had issues running on earlier versions of DIOS MIOS, when anything is plugged into memory card slot B. So converting the codes to WiiRD was more of a necessity. DM 2.10 has been recently released, but I'm not sure if the Slot B issues have been resolved or not.

    Even after I had converted the codes, I couldn't seem to get them to work. The only time I noticed the code doing anything, was when I left the Master Code turned on and it allowed me to play the game, on DIOS MIOS 2.2, without the need of a dummy disc.

    It's also worth noting that there are 3 different versions of GPOE8P. With different AR codes for each version. So for anyone trying to use AR codes, with their US copy of PSO, make sure you're using codes intended for your specific version. I know that for me personally, finding reliable AR codes for my specific version of the game was a chore. And it's possible, that the reason the codes haven't been working for me, is because I've been testing with codes that are not specific to my version. But I don't think that's the case.

    I noticed you mentioned having the PAL version of this game. I'm not sure how many versions of this game were released in PAL territories. But after doing some quick searching I seem to only have found one.

    I just recently bought a retail PSO disc at a 2nd hand store on Saturday. But it's in pretty bad shape. Once I get it resurfaced, I'll rip it and try to verify it on Devolution. If that works, I'll see if I can get the codes working while the game's running on Devolution. The place I go to to resurface my games isn't in my city, so I probably won't have any results to post until next week.

    ==========
    For those of you curious about which version of PSO you might have. Flip your game over and look at the underside of your retail disc. You'll find small text on the silvery ring that's just inside data area of the disc. You may need to reflect light off of it in just a way that allows you to see the small text. For me, it worked best when I tilted it so that the reflection looked rainbow-y. (Yes I just made up that word. lol)

    These are the different US versions...
    DOL-GPOE-0-00 USA = V1.0
    DOL-GPOE-0-01 USA = V1.1
    DOL-GPOE-0-02 USA = V1.2 (V1.2 is the PLUS version of the game, and easily the simplest to identify because you'll see the word PLUS written on the disc art just to the right of the title text.)

    I'm not too sure about how the PAL version/s looks. The info I found didn't seem very straight forward. Here's some of the possibilities it could be...
    DOL-GPOE-PAL
    DOL-GPOP-0-00
    DOL-GPOP-0-00 JPN
    ==========

    If anyone finds out, or knows exactly, what the info for the PAL version looks like, please post it here. :)
     
  11. Smash Br0

    Member Smash Br0 GBAtemp Advanced Fan

    Joined:
    Jun 6, 2009
    Messages:
    504
    Country:
    United States
    Does PSO I & II Plus work too?
     
  12. portugeek
    OP

    Member portugeek GBAtemp Fan

    Joined:
    Apr 6, 2013
    Messages:
    345
    Country:
    United States
    It still doesn't work on DIOS MIOS as of yet.

    I don't have the retail version of PSO I & II Plus, so I don't know if it works on Devolution or not. Although, I've heard in the past, that all versions of PSO work with Devolution.
     
  13. sanoblue

    Member sanoblue The Fuzzy Blue Woof!

    Joined:
    Aug 4, 2007
    Messages:
    747
    Location:
    North Carolina
    Country:
    United States
    i have a retail version if anyone wants me to do some testing let me know ^_^
    on second look its not plus version >.< sorry lol
     
  14. drakorex

    Member drakorex GBAtemp Advanced Maniac

    Joined:
    Jan 19, 2011
    Messages:
    1,881
    Country:
    United States
    It'd be nice if dm supported ar codes, or had the option to boot up ar first. then when it prompts to insert given disc, we could do it via the disc 2 method.
     
  15. Sorogoli

    Newcomer Sorogoli Newbie

    Joined:
    Jan 26, 2014
    Messages:
    8
    Country:
    Brazil
    So guys, in case someone still have problems with making PSO1&2 or PSO1&2+ working on dios mios, after some research and some testing, i finally made both work without fail, here is what oyu have to do.
    1. Open the Gamecube Iso Tool
    2. Go on Preferences, select the tab Iso
    3. At the alignment option, select 32k and click ok
    4. Select extract with the GCReEx format
    5. Put the folder on your usb drive
    6. At your usb loader, disable the padhook option DM video mode on Auto (both gotta be done or you get error screen or black screen
    7. Enjoy your game
     
  16. portugeek
    OP

    Member portugeek GBAtemp Fan

    Joined:
    Apr 6, 2013
    Messages:
    345
    Country:
    United States
    I tried your method, and PSO1&2-Plus still isn't working for me.

    - Which version of Dios Mios are you using?
    - Which Loader are you using?
    - Do you have any Ocarina cheats on?
    - Did you have a disc in the drive?
    - Lastly, Are you sure that it's PSO1&2-Plus?

    I'm only questioning about the Plus version because, to date, I've been able to get both version 1.00 and 1.01 working (a variety of different ways) but I still haven't been able to get version 1.02 to work.


    If you're not sure exactly which version you have, compare these against your original ISO using HashCalc.

    Ver 1.00
    MD5 = 478bf75c63d6ff30315c9b34cee288ab
    SHA1 = d6b591ddc34e689d6792fa5190feda88e969c041
    CRC32 = 25b0368b

    Ver 1.01
    MD5 = 81724d71a2143a4fccf49020737d3add
    SHA1 = 2b7eda3e2f7bdc7479f803684a590992377a4617
    CRC32 = 98e98759

    Ver 1.02 (Plus)
    MD5 = 36a7f90ad904975b745df9294a06baea
    SHA1 = 0ff155311f4cc57951c03baeb1a8cc15de5fe1cd
    CRC32 = cdc9bc9a
     
  17. kongsnutz

    Member kongsnutz QuickTimeEvent

    Joined:
    Jul 19, 2008
    Messages:
    1,443
    Country:
    Australia
    Just wish online worked with Dios Mios, can't get my scratched discs to work with Devo. Bought at thrift store, badly scratched haha
     
  18. portugeek
    OP

    Member portugeek GBAtemp Fan

    Joined:
    Apr 6, 2013
    Messages:
    345
    Country:
    United States
    I've been wanting to play online too. I even looked into playing the ISO on Dolphin with NetPlay, so that a friend and I could play w/o split screen. But I don't think NetPlay works that way. I might just get my fix by playing Blue Burst.
     
  19. Sorogoli

    Newcomer Sorogoli Newbie

    Joined:
    Jan 26, 2014
    Messages:
    8
    Country:
    Brazil
    im using dios mios 2.10, with usb loader gx r1218, no ocarina on, dios mios video mode on auto, padhook off, a wii disc on drive, MD5:36a7f90ad904975b745df9294a06baea (matches pso+) , CRC32: cdc9bc9a (matches), Sha1: 0ff155311f4cc57951c03baeb1a8cc15de5fe1cd (matches), the printscreen show that im not lying. the problem is that you gotta process the iso the exact way i said, or won't work, and don't use shrunk iso, won't work, also, i just remember thar my usb drive setting is the recomended one, with the fat32 partition first and the wbfs at second, with the fat partition having 32k cluster size, this all must be present in order to make it work ( yes, pso + is a bitch to work)
     

    Attached Files:

    • pso+.jpg
      pso+.jpg
      File size:
      357.2 KB
      Views:
      231
  20. portugeek
    OP

    Member portugeek GBAtemp Fan

    Joined:
    Apr 6, 2013
    Messages:
    345
    Country:
    United States
    I've done everything exactly how you mentioned it and I still can't get it to work. Would you mind posting a syscheck so I could compare to see if I'm missing anything?
     

Share This Page