Old Wii at 2.0u want to upgrade

Discussion in 'Wii - Hacking' started by zipperdoyle, Jun 7, 2009.

Jun 7, 2009
  1. zipperdoyle
    OP

    Newcomer zipperdoyle Member

    Joined:
    Jun 7, 2009
    Messages:
    14
    Country:
    United States
    I have a US Wii that is currently at firmware 2.0u. I did the twilight hack installed the homebrew channel and cIOS36_rev10. I've been able to play Wii games through the USB Loader on a hard drive and a few of the NES Wad channels. I'm unable to get the USB forwarder working and any of the new Wiiware games working. When I install the channels they just load up a black screen and I have to reset the Wii. What do you guys recommend to get the USB forwarder and Wiiware games working? I'm assuming I need to upgrade the firmware and was thinking about using Waninkoko updater 4.0 or one of his older updaters to get the system to 3.2u. Let me know what you think.

    ZD
     
  2. s3phir0th115

    Member s3phir0th115 GBAtemp Advanced Fan

    Joined:
    Dec 31, 2008
    Messages:
    700
    Country:
    United States
    I would personally advise that you go to wiibrew and get NUS Downloader, then use it to generate a System Menu 3.2 wad. That way you can install 3.2 on your Wii with Wad Manager, and you only need the network once.

    That's just me though. I prefer to have offline installs whenever possible.
     
  3. wiiztec

    Member wiiztec GBAtemp Fan

    Joined:
    Apr 3, 2009
    Messages:
    332
    Country:
    United States
    Use Waninkoko's 4.0 updater
     
  4. vergilite

    Member vergilite GBATemps Regular Clown

    Joined:
    Apr 14, 2009
    Messages:
    737
    Location:
    Liv-Liv-Liverpool YEAH!
    Country:
    United Kingdom
    i recommend 4.0 as it comes with all the most recent ios's but be sure to
    A. install bootmii and make a backup just incase something goes wrong
    B. make sure you have everything you need to install installed while on a lower firmware before you upgrade
    i did it and have never looked back

    p.s i would first upgrade to 3.2 and make a backup of your wii on that firmware (3.2 i mean) so you can always just reset your wii to 3.2 if any problems arise with the 4.0 e.g. lack of certain homebrew compatibility etc so if you make a backup of both your 3.2 and 4.0 and store both nand backups somewhere safe on your computer then you can switch between firmwares whenever but always remember to backup your recent saves before restoring your nand backup or you will be stuck with the saves you had at the time of backup
    hope this helped cos it took me ages to write [​IMG]
     
  5. techboy

    Member techboy GBAtemp Advanced Maniac

    Joined:
    Mar 15, 2009
    Messages:
    1,720
    Location:
    Pennsylvania
    Country:
    United States
    First things first, install bootmii as boot2. (If you're wii can't handle it as boot2, then you're not going to have any Anti-Brick software during upgrades).

    If you do what s3phir0th115 says, make sure you get IOS30 v1040 as well, or you'll brick your wii.

    Since you have cIOS installed, make a NAND backup with bootmii, then use cIOS downgrader to install 3.2U (yes, it can upgrade too!). After that, it depends if you want 4.0 or not.

    If you do want 4.0, make another backup with bootmii, then use this guide - http://www.gbatemp.net/index.php?showtopic=144835 - No need to install cIOS rev13 if you have cIOS rev10. Rev10 is more stable IMO. I used this guide when cIOS rev10 was latest and it worked fine. Just be sure you install preloader afterwards, especially if you couldn't install Bootmii as boot2.

    If you do not want 4.0 make another backup with bootmii and use this: http://wiibrew.org/wiki/WiiSCU - if offered to update IOS16 say NO. (i forget if this app asks, someone told me...but i installed 4.0, so no experience here)
     
  6. s3phir0th115

    Member s3phir0th115 GBAtemp Advanced Fan

    Joined:
    Dec 31, 2008
    Messages:
    700
    Country:
    United States
    Are you sure you need to get that IOS as well techboy? Because I have installed my own System Menu 3.2 wad despite being on a waninkoko updated system and went back to 3.2 just fine. I have also used it and then had to reinstall cIOScorp, so that would indicate to me that it comes with all of the IOS's for it as well.
     
  7. zipperdoyle
    OP

    Newcomer zipperdoyle Member

    Joined:
    Jun 7, 2009
    Messages:
    14
    Country:
    United States
    So I installed Bootmii and backed up at both 2.0u and 3.2u. I used the CIOS downgrader to update the firmware. I'm still running in to the issue where all of the WAD channels (Wiiware games, forwarder) are simply resetting the Wii. It used to completely lock the system up in a black screen at 2.0u but it is now resetting the Wii at 3.2u. Any recommendations on how to resolve this? I'm experiencing the same scenario as this guy:

    http://gbatemp.net/index.php?showtopic=149...p;#entry1918221

    Thanks again,

    ZD
     
  8. squirrel420

    Newcomer squirrel420 Member

    Joined:
    Mar 2, 2009
    Messages:
    27
    Country:
    United States

    i'm on 3.2U and have found that most recent wiiware/vc titles require that i use GeckoOS 1.9.1 to launch them, otherwise i just get a wii reboot. works fine with gecko however, perhaps give that a try? just tell gecko to launch the channel.
     
  9. techboy

    Member techboy GBAtemp Advanced Maniac

    Joined:
    Mar 15, 2009
    Messages:
    1,720
    Location:
    Pennsylvania
    Country:
    United States
    @s3phir0th115:

    Yes i'm sure. He needs the IOS30 v1040 because he's on 2.0. IOS30 came with v3.0 & up. Had he updated with a wad without installing the IOS, he'd brick his wii.

    Also the reason i recommended cIOS downgrader, as it takes care of all the components needed by a certain level firmware, including Sysmenu, IOS for sysmenu, MIOS, etc.

    In addition, installing the IOS for a menu when you install the menu is just good habit. It ensures its there. By doing what you did, you assumed IOS30 v1040 was there. Had it not been, or been updated/replaced with a stub, you'd have a shiny white paperweight right now.

    EDIT: forgot to answer question about wiiware...
    The IOS for the title you ran is probably missing. You need IOS38, IOS53, and IOS55, the latter two of which are used by wiiware. IOS38 currently is for Animal Crossing City Folk.

    Updating to 4.0 with waninkoko's updater will install these, or get a wad of these IOSes off the net or make them with NUS Downloader, then install them.
     
  10. s3phir0th115

    Member s3phir0th115 GBAtemp Advanced Fan

    Joined:
    Dec 31, 2008
    Messages:
    700
    Country:
    United States
    I thought installing the system menu wad causing cIOScorp to disappear would have meant that the wad covers all IOS requirements. But if it does not, then I suppose I'll get the IOS the system menu depends on when I make my wads from now on.
    If me reinstalling the system menu wad causes cIOScorp to stop working and it didn't install IOS30 which it needs, then what did it do to require me to install it again?
     
  11. techboy

    Member techboy GBAtemp Advanced Maniac

    Joined:
    Mar 15, 2009
    Messages:
    1,720
    Location:
    Pennsylvania
    Country:
    United States
    I'm not sure why cIOSCORP stops working, i don't use it (have USB loader). Anyway, the system menu wad does not contain any IOS whatsoever. If you get your wads from NUS Downloader, that is always the case.

    The only exception i know of to this rule is the RestoreMii wad, a special system menu wad that DOES have the IOS inside.
     
  12. manias

    Member manias GBAtemp Maniac

    Joined:
    Aug 7, 2007
    Messages:
    1,258
    Country:
    Netherlands
    or, after bootmii and cios249, you update with nintendo to 4.0?
     

Share This Page