Old 3DSXL giving me an error with CIA install

Discussion in '3DS - Homebrew Development and Emulators' started by Deletr753, Dec 26, 2015.

  1. Deletr753
    OP

    Deletr753 GBAtemp Regular

    Member
    110
    17
    Oct 14, 2013
    Guatemala
    Hello Everyone,

    I have an old 3dsxl on Systemnand ver. 7.1.0-14U and Emunand ver.10.3.0-28U. I had a 64gb sd card in it with some CIA games install on my Emunand but the sd card was stolen so I purchase a new 32gb sd card. When I try to re-install all my CIA games I keep getting an error. I formatted my 3dsxl system memory and the emunand but I got the error again. I try installing the CIA games in RXTools and Gateway mods with no luck. Here is the error I keep getting. I hope some can help me fix this problem.

    Import failed. File: sdmc : / FBI.cia
    level: LEVEL_PERMANENT (-5)
    Summary: SUMMARY_WRONG_ARGUMENT(8)
    Module: MODULE_NN_FS(17)
    Desc: <unknown> (393)

    Thank you in advance
     

    Attached Files:

  2. squee666

    squee666 Advanced Tech Pleb

    Member
    1,592
    897
    Sep 17, 2010
    Belfast
    try injecting FBI into emunand using RXtools Menu.

    Or install the FBI CIA to sysnand then create emunand so its already Installed in Emunand when it copies over.


    The problem you are having is a known thing where you can install cias to emunand via HBL because it fails 100% thats why guides tell you to do the above
     
  3. Deletr753
    OP

    Deletr753 GBAtemp Regular

    Member
    110
    17
    Oct 14, 2013
    Guatemala
    Thank you for your reply. I install the FBI CIA in the Emunand with RXtools but it give me the same error. I'll try installing it to the sysnand and hope it works. If both of the methods do not work is there anything else I can try?
     
  4. Ammako

    Ammako GBAtemp Guru

    Member
    6,424
    3,547
    Dec 22, 2009
    Canada
    It's DevMenu/BBM in the picture which can't be run from HBL. :P

    Not entirely sure why it does fail though and googling the error doesn't seem to bring up anything. :/


    You're getting the exact same error in FBI? Or are you saying you get the error while trying to install the FBI.cia?
    If FBI gave you problems once installed as .cia on emunand then at least you'd be able to post on FBI's thread for help but can't really do that with DevMenu.

    Keep in mind, FBI inject via rxTools is not the same as just installing FBI.cia

    Could try what was suggested and install it to sysnand then create a new emunand, see if you still get the same error.
     
    Last edited by Ammako, Dec 26, 2015
  5. Deletr753
    OP

    Deletr753 GBAtemp Regular

    Member
    110
    17
    Oct 14, 2013
    Guatemala
    I'm getting the error while in FBI. The BigBlueMenu and Devmenu I can only access them via Gateway red card and they both give me the same error.
     
  6. Ammako

    Ammako GBAtemp Guru

    Member
    6,424
    3,547
    Dec 22, 2009
    Canada
    One last thing, does the error message look identical on FBI than it does on DevMenu?
    If you could post a picture of the FBI error, or a transcription, that would help with trying to find causes/solutions online.

    Otherwise I'm at a loss, and your best bet would probably be to report your problem here and see if someone knows what the problem is and how to fix it.

    One last idea, you created title.db and import.db in a dbs folder, yeah? (Well, if you hadn't, you would be getting a databases missing error so I think we can rule that out.)
    And if so, did you repair them by going into data management and letting the 3DS repair the files?
     
    Last edited by Ammako, Dec 26, 2015
  7. squee666

    squee666 Advanced Tech Pleb

    Member
    1,592
    897
    Sep 17, 2010
    Belfast

    So you have been trying to run Devmenu/BBM via gateway card on emunand?

    Also are you running FBI via HBL in Emunand or is it installed as a System Title you can run straight from the menu.

    Need to be specific for this



    what we mean by installing FBI to sysnand and copying to emunand is this.


    1: Install FBI.CIA to sysnand
    2: Create a new Emunand fresh install
    3: Boot Emunand, FBI should be a system title
     
    Last edited by squee666, Dec 26, 2015
    Ammako likes this.
  8. Deletr753
    OP

    Deletr753 GBAtemp Regular

    Member
    110
    17
    Oct 14, 2013
    Guatemala
    FIX!!! so I forgot to enter the data management and when I did so in the Sysnand and Emunand and rest the date it fix my error. Thank you Pingouin7 and sque666 for helping. I hope if some else has this issue this will help them fix it.