Hacking Official SX OS v3.0.4 Beta is available

MomZo

Well-Known Member
OP
Newcomer
Joined
Jul 17, 2020
Messages
96
Trophies
0
Age
36
XP
254
Country
France
Hey guys,

TX just released official SX OS v3.0.4 Beta which is supposed to be fully operational with FW 10.1.0.

Here is the changelog communicated on TX forum:
  • Support for Switch firmware 10.1.0
    SX OS is now fully compatible with the latest Switch Firmware 10.1.0.
  • Bug fixed in 'genuine boot' functionality.
    Last update we introduced 'genuine boot' for SX Core/Lite users. We were made aware some users had trouble using this while a microSD card was inserted, this has been fixed!
  • Minor stability improvements
    You know the drill! Under the hood we're always changing things, to increase both stability and performance of your beloved SX OS.
Let us know if you installed the latest version and if it corrected all the issues which were happening with FW 10.1.0 with SX OS 3.0.3 (crashes, games won't launch, NSP cannot be installed...)
 

Reecey

Mario 64 (favorite game of all time)
Member
Joined
Mar 7, 2010
Messages
5,866
Trophies
0
Location
At Home :)
XP
3,545
Country
Not sure why mods decided to keep this one open and shut the other for a start sxos has always been in the back up loader section why because sxos is mainly a backup loader cfw and now relates to the new sx modchip so your obviously dump or want to be fussy.
 
Last edited by Reecey,

socialbacon

Well-Known Member
Newcomer
Joined
Jan 3, 2016
Messages
69
Trophies
0
XP
861
Country
Canada
Installed SX OS 3.04, updated firmware to 10.1.0 using ChoiDujourNX and now my Switch won't boot. It doesn't do anything. I can't even get it to go into the SX boot menu. Any ideas?
 

MomZo

Well-Known Member
OP
Newcomer
Joined
Jul 17, 2020
Messages
96
Trophies
0
Age
36
XP
254
Country
France
Did you update SX Core/Lite firmware to v1.3 before any update? If not, that's the reason it is not booting (your Switch is bricked)
The solution is to update the modchip via the debugging USB port and a computer. Then, you should be able to boot again your Switch.
 
  • Like
Reactions: hartleyshc

socialbacon

Well-Known Member
Newcomer
Joined
Jan 3, 2016
Messages
69
Trophies
0
XP
861
Country
Canada
Did you update SX Core/Lite firmware to v1.3 before any update? If not, that's the reason it is not booting (your Switch is bricked)
The solution is to update the modchip via the debugging USB port and a computer. Then, you should be able to boot again your Switch.
I don't have SX Core/Lite, I'm using the SX Pro dongle.
 
General chit-chat
Help Users
    kenenthk @ kenenthk: You mean fanjob