Official CFG Loader Forwarder

Discussion in 'Wii - Backup Loaders' started by FIX94, Jan 20, 2011.

  1. FIX94
    OP

    FIX94 Global Moderator

    Global Moderator
    21
    Dec 3, 2009
    Germany
    ???
    Thanks for testing the dol first, I only tested a very old version some months ago, good to know that this one still work! I don't think you can directly go to wiimc, maybe you can configure it in the priiloader menu with the return to: option and press the home button in cfg-loader.
    @Bloodlust:
    Another version would take a while, do you have a wad with the design you want? [​IMG]
     
  2. 9apples

    9apples Member

    Newcomer
    1
    Sep 4, 2009
    Hi everyone,

    I have installed the forwarder and it now comes up on system menu, but when I go into it, it just resets the wii back to system menu.

    Any ideas how I can fix that?

    Edit* I can load the usbloader from homebrew channel but i'd rather load it from the system menu.

    Thanks for the help, it's greatly appreciated!
     
  3. FIX94
    OP

    FIX94 Global Moderator

    Global Moderator
    21
    Dec 3, 2009
    Germany
    ???
    You need IOS58:
    http://wiibrew.org/wiki/IOS58_Installer
    Install it and the forwarder should work, I totally forgot to add it to the first post, sorry!
     
  4. Eskeletor

    Eskeletor Member

    Newcomer
    1
    Dec 15, 2009
    I had a similar problem with the Wii for my niece this weekend, the other thing happens to me is that the wii crash with the WiiMC forwarder, and from the HBC says that there is some ios damaged or something, so I imagine it will be a matter of reinstalling some ios to solve the problem. I have not done so because she wanted was to play and when he did not care to go every time the HBC.
     
  5. 9apples

    9apples Member

    Newcomer
    1
    Sep 4, 2009
    Cheers pal, thanks a million!
     
  6. jesquinas

    jesquinas GBAtemp Regular

    Member
    1
    Apr 14, 2010
    I think that must be configurable like Homebrew Channel (HBC) for example.In HBC if you press '1' you obtain a menu where its possible to choose the device for apps loading (SD or USB).
    And I think ,like I said you in another post,that channel title id could be configurable too like extra protection measure.If your channel becomes famous Nintendo will follow your steps :-)

    Greetings.
     
  7. Bloodlust

    Bloodlust GBAtemp Maniac

    Member
    4
    May 25, 2006
    Hong Kong
    Something that can go with the dark wii theme would be nice. No hurry mate, thanks for your work! [​IMG]
     
  8. Eskeletor

    Eskeletor Member

    Newcomer
    1
    Dec 15, 2009
    Hi FIX94, I bothering you again, if not too much trouble could you make a .dol file for priiloader also boot from USB first.

    Thank you very much.
     
  9. FIX94
    OP

    FIX94 Global Moderator

    Global Moderator
    21
    Dec 3, 2009
    Germany
    ???
    Try this one:
    http://www.mediafire.com/?yqnv61mk9u9d9bz
    Oh, and if you are now trying things out could you please try this:
    http://www.mediafire.com/?pixdn8171fzrfma
    It's a universal homebrew channel loader for preloader and priiloader, I simply want to know if it's booting the latest homebrew channel without problems.
     
  10. Eskeletor

    Eskeletor Member

    Newcomer
    1
    Dec 15, 2009
    Thank you very much,

    First I tried the universal homebrew channel and loaded without problems HBC 1.08

    and then I tried the USB and it worked perfect, thank you very much mains to.

    Greetings.
     
  11. bewitched

    bewitched GBAtemp Regular

    Member
    2
    Mar 11, 2008
    Netherlands
    Europe
    When loading v8, i get a stack dump, any ideas?
    Loading cfg v65 through HBC works fine ...
    Thanx
    nvm. using v8b and the problem is gone [​IMG]

    edit:
    Unfortunately still there, it seems to occur randomly with v8 and v8b...

    I start CFG v65 through CFG loader v8b, it works fine, then exit CFG loader and return to Wii with option "return_to_channel = UCXF".
    Then start CFG loader again and i get the stack dump.

    In short this happens all the time: first start = fine, 2nd start after exiting: stack dump.

    See picture.

    [​IMG]

    This is my xml:
    CODE

    Configurable USB Loader
    65 (release)
    20110125000000
    oggzee, usptactical, gannon, Clipper, ...
    Play from USB drive

    Play Wii Backups from USB harddrive
    Waninkoko cIOS 249 is supported.
    Hermes cIOS 222/223 is supported.
    USE AT YOUR OWN RISK!


    intro = 1


    Edit: btw i tried this on 2 different Wii's.
     
  12. FIX94
    OP

    FIX94 Global Moderator

    Global Moderator
    21
    Dec 3, 2009
    Germany
    ???
    How often do you have a stack dump? Do you have a meta.xml file in your apps/usbloader folder?
     
  13. FIX94
    OP

    FIX94 Global Moderator

    Global Moderator
    21
    Dec 3, 2009
    Germany
    ???
    This stack dump is from cfg-loader, no forwarder stack dump. I'm 99% sure the forwarder video code is making a problem in cfg-loader. This should fix it:
    USBLoaderCFG - UCXF - IOS58 v9 Beta.wad
    USBLoaderCFG - UCXF - IOS58 v9 Beta Alternative.wad
    Please report if it works!
     
  14. bewitched

    bewitched GBAtemp Regular

    Member
    2
    Mar 11, 2008
    Netherlands
    Europe
    ok thanx, i'm off to work now [​IMG]

    So i'll test it as soon as i'm back.
    Edit:

    Just tested this, goin' in and out of CFG loader multiple times, and it works [​IMG] No more stack dumps.
    Thanx [​IMG]
     
  15. FIX94
    OP

    FIX94 Global Moderator

    Global Moderator
    21
    Dec 3, 2009
    Germany
    ???
  16. bewitched

    bewitched GBAtemp Regular

    Member
    2
    Mar 11, 2008
    Netherlands
    Europe
    Just tested those latest wads you posted, and they don't work.

    It doesn't give a stack dump, but after exiting cfg and trying to load again with this loader the system freezes with a black screen.
    So, first time you can start cfg, then exit cfg, then click loader again >>> black screen.
    Sometimes you can start cfg twice with this loader but i couldnt get cfg to load more than that.

    Tried both wads, multiple times.

    Reverted back to "USBLoaderCFG - UCXF - IOS58 v9 Beta Alternative.wad" and everything is ok again [​IMG]
     
  17. FIX94
    OP

    FIX94 Global Moderator

    Global Moderator
    21
    Dec 3, 2009
    Germany
    ???
    Thanks for testing, I will use the original code part if it works better.
     
  18. Bloodlust

    Bloodlust GBAtemp Maniac

    Member
    4
    May 25, 2006
    Hong Kong
    Hi FIX94, I was wondering if you have any idea why when I launch CFG with your forwarder on a HDD which uses a FAT32 filesystem it works fine as in when CFG is launched it automatically detects the correct partition as in FAT1.

    But when I use it on NTFS, CFG always prompts to select partition because it's always not found every time I launch it...
     
  19. slicer74

    slicer74 GBAtemp Regular

    Member
    1
    Apr 29, 2009
    Canada
    Somewhere
    Does this happen if you launch CFG from the HBC, if so, then, it's the config file of the CFG that has to be change.
     
  20. x4mer

    x4mer Member

    Newcomer
    1
    Apr 17, 2010
    Canada
    There's a problem with the forwarder, with certain things connected to the 2nd USB port. On my Wii, I have a small stick USB hub in the 2nd port, into which I connect my mic & network adapter.

    I finally tried the forwarder, and it just kept kicking back to the system menu. I tried V8 instead of 8b, and no change. Wondering if it had to do with the 2nd USB port, I pulled the hub, and then the forwarder worked fine.

    Plugging in just the mic, or just the net adapter, or even just the hub, the forwarder works fine. As soon as I use the hub with either of the devices plugged into it, the forwarder fails back to the system menu.

    Any chance for a fix?
     
Loading...