NX firmware Update to 5.1.0

Discussion in 'Switch - Exploits, Custom Firmwares & Soft Mods' started by DoubleX, Sep 22, 2018.

  1. DoubleX
    OP

    DoubleX Member

    Newcomer
    1
    Sep 22, 2018
    France
    Can any1 tell me how to upgrade for 2.3 ofw to 5.1.0 ofw?
     
  2. Kubas_inko

    Kubas_inko "Something funny goes here."

    Member
    13
    Feb 3, 2017
    Czech Republic
    I gues on earth.
    mesakagi likes this.
  3. Lacius

    Lacius GBAtemp Guru

    Member
    16
    May 11, 2008
    United States
    You can use ChoiDujourNX to update to 5.1.0. You can also use ChoiDujourNX to update to 6.0.0.
     
  4. DoubleX
    OP

    DoubleX Member

    Newcomer
    1
    Sep 22, 2018
    France
    thank both of you, can I use this guide for upgrade to 5.1.0 and then Team Xecutors sx pro solution?
     
  5. Lacius

    Lacius GBAtemp Guru

    Member
    16
    May 11, 2008
    United States
    There is no reason to buy SX OS. ReiNX and Atmosphere can do just everything SX OS can do, but for free.
     
    BlastedGuy9905 and Draxzelex like this.
  6. Ashura66

    Ashura66 GBAtemp Advanced Maniac

    Member
    6
    Feb 1, 2016
    Portugal
    Under my bed
    Absolutely ZERO need for you to spend so much money on it. If you MUST have a dongle, look into the R4 or Atmosphere ones which are not only cheaper but just as good.
     
  7. DoubleX
    OP

    DoubleX Member

    Newcomer
    1
    Sep 22, 2018
    France
    Thank you, is there a guide to install ReiNX from my current 2.3 OFW?
     
  8. Ashura66

    Ashura66 GBAtemp Advanced Maniac

    Member
    6
    Feb 1, 2016
    Portugal
    Under my bed
    https://reinx.guide/
     
    Lacius likes this.
  9. DoubleX
    OP

    DoubleX Member

    Newcomer
    1
    Sep 22, 2018
    France
    Questions:

    1. I have a 128Gb microSD, but when I insert it. It want to upgrade now, to 6.X???
    2. Should I start with "First Time Setup-Up?
     
  10. Lacius

    Lacius GBAtemp Guru

    Member
    16
    May 11, 2008
    United States
    You need to use ChoiDujourNX to install the exFAT driver. You can do this to any system version, not just 6.0.0.

    Alternatively, you could connect to the internet and install 6.0.0 naturally, and you can install the exFAT update that way too.
     
  11. Ashura66

    Ashura66 GBAtemp Advanced Maniac

    Member
    6
    Feb 1, 2016
    Portugal
    Under my bed
    1: Is your card formated as FAT32 or EXFAT? If it's the latter then the update in question is just a patch to add EXFAT support
    2. Yes
     
    DoubleX likes this.
  12. DoubleX
    OP

    DoubleX Member

    Newcomer
    1
    Sep 22, 2018
    France
    If I upgrade to 6.0.0 over the internet, will I still be able to install ReiNX?
     
  13. Ashura66

    Ashura66 GBAtemp Advanced Maniac

    Member
    6
    Feb 1, 2016
    Portugal
    Under my bed
    I wouldn't. ReiNX is still not FULLY compatible with 6.0.0. If anything, use ChoiDujourNX to update to 5.0.1, the EXFAT update also comes with that firmware version
     
  14. Lacius

    Lacius GBAtemp Guru

    Member
    16
    May 11, 2008
    United States
    Yes, you will still be able to use ReiNX, but you will be unable to downgrade in the future. That means if a new exploit is released for a low system version that's more convenient than RCM, you probably won't be able to use it.

    Alternatively, you could use ChoiDujourNX to install 6.0.0 without burning efuses. This will allow you to be able to downgrade in the future, but you will have to keep AutoRCM installed indefinitely.

    I believe the latest nightly version of ReiNX is fully compatible with 6.0.0. tumGER's files are also fully compatible with 6.0.0.
     
    Last edited by Lacius, Sep 22, 2018
  15. Ashura66

    Ashura66 GBAtemp Advanced Maniac

    Member
    6
    Feb 1, 2016
    Portugal
    Under my bed
    The latest nightly version has a small workaround that removed debug menu so it doesn't interfere with sleep mode. Rei is still looking into fully fixing that bug and making it FULLY compatible with 6.0.0. Least that's the latest post i saw from Rei
     
  16. Lacius

    Lacius GBAtemp Guru

    Member
    16
    May 11, 2008
    United States
    It sounds like it's functionally compatible for the end user.
     
  17. Ewwwww

    Ewwwww Member

    Newcomer
    2
    Feb 21, 2018
    United States
    Is it possible to use Nintendo switch online with the unofficial version of 6.0? I don't want to burn my fuses.
     
  18. Lacius

    Lacius GBAtemp Guru

    Member
    16
    May 11, 2008
    United States
    You can use online services after installing 6.0.0 and AutoRCM using ChoiDujourNX, yes.
     
  19. Ewwwww

    Ewwwww Member

    Newcomer
    2
    Feb 21, 2018
    United States
    K, thanks.
     
  20. DoubleX
    OP

    DoubleX Member

    Newcomer
    1
    Sep 22, 2018
    France
Loading...