1. Tommy084

    Tommy084 GBAtemp Regular
    Member

    Joined:
    Feb 24, 2013
    Messages:
    119
    Country:
    Norway
    First I got to say great work on this project :)
    I been useing this sence 0.60 and every nsp game I cleaned with deltas work, but not Lego city undercover.
    It installs fine and starts, but will hang in game or in intro/loading.
    Tried different settings and works best with clean, not clean_ND.
    Also tried different nsp of the same game, and it works fine before I clean it.
    I don’t make xci, just clean nsp
     
  2. JRoad

    OP JRoad Developer
    Developer

    Joined:
    May 18, 2018
    Messages:
    922
    Country:
    Spain
    Yeah the thing is you might've have a previous update installed and the without deltas it stayed in your system giving issues. For nsp it's better to keep the deltas so previous updates don't stay in the system unless you have access to devmenu and delete them or you do a full clean installation.
     
  3. Tommy084

    Tommy084 GBAtemp Regular
    Member

    Joined:
    Feb 24, 2013
    Messages:
    119
    Country:
    Norway
    Thanks for replaying
    I have made sure to delete the old version of NSCB, I even restores my nand several times. Still no go, Lego world and ninjago is fine, just city undercover.
     
  4. isoisoiso

    isoisoiso GBAtemp Regular
    Member

    Joined:
    Jun 16, 2018
    Messages:
    208
    Country:
    Spain
    Theres a typo on the file title after converting an xci to nsp.
    Outlast[nap].nsp
     
  5. JRoad

    OP JRoad Developer
    Developer

    Joined:
    May 18, 2018
    Messages:
    922
    Country:
    Spain
    It's not a typo, it's an inside joke meant to my discord friends actually XD. It means Nsp Alternative Packer, it was the name of a converter\packer i never released in public and the meaning of the joke is meaningfull because a lot of times i'm writing on the mobile app and my phone likes to correct nsp for nap. So then I said i'm going to call my converter\packer nap XD. Either way i'd probably revise the tags soon XD.
    It always surprised me how people don't ask me about it :P
     
    Last edited: Dec 16, 2018
    isoisoiso likes this.
  6. JRoad

    OP JRoad Developer
    Developer

    Joined:
    May 18, 2018
    Messages:
    922
    Country:
    Spain
    white icons and installation problems from embedded installer got fixed on 2.4.1 So SX OS users can stop lowering the keygeneration if they're on 6.2 ;)
    https://team-xecuter.com/sx-os-v2-4-1-beta-announcement/

    Anyway this is me remembering that one of the added options in last releases is to make the RSV and keygeneration prompt to not show. It is on the global configs in the batch configurator (option 0 at the start of manual mode)
     
    18Phoenix, isoisoiso and Saiylem like this.
  7. huma_dawii

    huma_dawii GBAtemp Psycho!
    Member

    Joined:
    Apr 3, 2014
    Messages:
    3,470
    Country:
    United States
    Does the new SX update fixes the white icon
     
  8. isoisoiso

    isoisoiso GBAtemp Regular
    Member

    Joined:
    Jun 16, 2018
    Messages:
    208
    Country:
    Spain
    Finally
    Yeah but now people are reporting that xci loading doesn't work
    Haven't tried it yet tho
    Edit: sorry, apparently only HDD xci loading doesn't work
     
    Last edited: Dec 17, 2018
    huma_dawii likes this.
  9. JRoad

    OP JRoad Developer
    Developer

    Joined:
    May 18, 2018
    Messages:
    922
    Country:
    Spain
    Hmm they worked for me yesterday with my adapter and a pendrive. Well I'll try again when I get home I suppose.
    I tried with the normal loader though SX installer also load the xci in 6.2, it doesn't launch the like in 5.1 though.
     
  10. GDT

    GDT Member
    Newcomer

    Joined:
    Nov 12, 2009
    Messages:
    31
    Country:
    Italy
    I tried to install Super Mario Odyssey, converted from an XCI with your tool but SX Installer said "Invalid NCA". Can you please explain me th "activate unsigned code" thing and what is the konami code?
     
  11. markmcrobie

    markmcrobie GBAtemp Advanced Fan
    Member

    Joined:
    May 24, 2008
    Messages:
    597
    Is it a safe assumption that if the resulting XCI outputted from multi mode still has a revision of 1.0.0 that merging the latest NSP update didn't work? I have a couple that still say 1.0.0 in XCI Explorer/Switch Backup Manager, but other that say 1.1.0 or 1.2.0 etc
     
  12. JRoad

    OP JRoad Developer
    Developer

    Joined:
    May 18, 2018
    Messages:
    922
    Country:
    Spain
    Well it may depend on how xci explorer detect the control nca files, correct way should be scan the content identify the control nca for the updates and show that info. I never looked into how he's doing it though.
    Either way that number is pretty much useless, I know you guys like to see that number but is the same as editor and name, something set by the editor.
    The real update number, "proper by Nintendo standard" is the one that is a multiple of 65536
    so 0 - version 0, 65536 - version 1, 131072 - version 2 ...
    In updates 65536 - patch 1, 131072 - patch 2 ...
    When you get something like Diablo that released like 2.40 something it gets confusing if you try to go by that number. Also Gris's update, for example is 1.0 like the game while in Nintendo standard is patch(1).

    — Posts automatically merged - Please don't double post! —

    If you use dz-tinfoil by blawar or new SX Installer wich is the same you need to activate unsigned code in the installation menu, password is the most famous password in video game history - The Konami Code.
    unknown-1.png unknown-2.png Konami_Code_-_03.jpg

    You really are young if you didn't hear about the konami code.
     
    GDT likes this.
  13. ibbanez

    ibbanez Member
    Newcomer

    Joined:
    Aug 3, 2018
    Messages:
    31
    Country:
    United States
    I too wanted to chime in, I updated from 0.61nk to 0.78nk, and dragging two nsp's onto the NSCB.bat file, no longer works. It only does the main file, and ignores the update. However if I go into manual mode, it will work. I do have to choose option 4 for update. I know above you said it still worked for you, but idk. I double checked the bat file, and its set to multi. I'll post my file contents here. Before I updated, I could always drag the base nsp file and its update, together, and it would auto merge them into xci file, now it does not, unless I go the long manual route. Thanks.

    Code:
    ::--------------------------------------------------------------
    ::SET CUSTOM COLOR FOR THE BATCH FILES
    ::--------------------------------------------------------------
    color 1F
    ::--------------------------------------------------------------
    ::OPTION 1: FOLDERS
    ::--------------------------------------------------------------
    ::work folder
    set "w_folder=NSCB_temp"
    ::output folder
    set "fold_output=NSCB_output"
    ::--------------------------------------------------------------
    ::OPTION 2: PROGRAM ROUTES
    ::--------------------------------------------------------------
    set "nut=ztools\squirrel.py"
    set "xci_lib=ztools\XCI.bat"
    set "nsp_lib=ztools\NSP.bat"
    set "zip=ztools\7za.exe"
    set "hactool=ztools\hactool.exe"
    set "hacbuild=ztools\hacbuild.exe"
    set "listmanager=ztools\listmanager.py"
    set "batconfig=ztools\NSCB_config.bat"
    set "batdepend=ztools\install_dependencies.bat"
    set "advbat=ztools\ADV.bat"
    ::--------------------------------------------------------------
    ::OPTION 3: SQUIRREL OPTIONS
    ::--------------------------------------------------------------
    ::python command
    set "pycommand=py -3"
    ::Buffer for the copy functions. 
    ::Change the number for the number of bytes that works best for you
    ::32768bytes=32kB
    set "buffer=-b 32768"
    ::Copy function with or without deltas
    ::--C_clean -> Copy and remove titlerights. Don't skips deltas
    ::--C_clean_ND-> Copy and remove titlerights skipping deltas
    set "nf_cleaner=--C_clean"
    ::Patch the RequiredSystemVersion so console doesn't ask for updates bigger
    ::than the required FW to decypher the crypto
    ::true -> Patch required system version in the meta nca
    ::false-> Don't patch required system version in the meta nca
    set "patchRSV=-pv false"
    set "capRSV=--RSVcap 268435656"
    ::--------------------------------------------------------------
    ::OPTION 4: IMPORTANT FILES
    ::--------------------------------------------------------------
    ::Route for game_info file 
    set "game_info=zconfig\game_info_preset.ini"
    ::Route for keys.txt 
    set "dec_keys=ztools\keys.txt"
    ::--------------------------------------------------------------
    ::OPTION 5: REPACK OPTIONS
    ::--------------------------------------------------------------
    ::Repack option for auto-mode
    ::nsp->repack as nsp-
    ::xci->repack as xci-
    ::both->repack as both
    set "vrepack=xci"
    ::Type of repack for folders
    ::indiv->repack multiple input files as multiple output file. INDIVIDUAL MODE
    ::multi->repack multiple input files as single output file. MULTI-MODE
    set "fi_rep=multi"
    ::--------------------------------------------------------------
    ::OPTION 6: MANUAL MODE INTRO
    ::--------------------------------------------------------------
    ::Repack mode that is shown first in manual mode
    ::indiv->individual packing of files
    ::multi->multi-pack mode
    ::split->splitter mode
    ::update->update mode
    ::choose->prompt to choose the mode to enter
    set "manual_intro=choose"
    ::--------------------------------------------------------------
    ::OPTION 7: Zip files
    ::--------------------------------------------------------------
    ::ZIP FILES FOR UPCOMING RESTORE MODE
    ::true->zip the needed files
    ::false->don't zip the files
    set "zip_restore=true"
    
    ::--------------------------------------------------------------
    ::OPTION 8: PATCH IF KEYGENERATION IS BIGGER THAN
    ::--------------------------------------------------------------
    :: CHANGE ENCRYPTION TO THE SET KEYGENERATION IN AUTO-MODE
    ::
    :: Don't change encryption -> vkey = false
    :: "1.0.0"			  	   -> vkey = 0
    :: "2.0.0 - 2.3.0"         -> vkey = 1
    :: "3.0.0" 		   	 	   -> vkey = 2
    :: "3.0.1 - 3.0.2" 		   -> vkey = 3
    :: "4.0.0 - 4.1.0"		   -> vkey = 4
    :: "5.0.0 - 5.1.0" 		   -> vkey = 5
    :: "6.0.0-4 - 6.1.0" 	   -> vkey = 6 
    :: "6.2.0" 		  	 	   -> vkey = 7
    
    set "vkey=-kp false"
    
    ::--------------------------------------------------------------
    ::OPTION 10: AUTO-EXIT
    ::--------------------------------------------------------------
    :: If set at true the program will auto-exit in manual mode
    set "va_exit=false"
    
    ::--------------------------------------------------------------
    ::OPTION 11: SKIP RSV AND KEYGENERATION CHANGE PROPMT
    ::--------------------------------------------------------------
    :: Skip RequiredSystemVersion and keygeneration prompts while
    :: in manual mode
    set "skipRSVprompt=false"
    
     
  14. Plunt

    Plunt GBAtemp Regular
    Member

    Joined:
    Nov 21, 2010
    Messages:
    202
    Country:
    Canada
    Place both files into a separate folder then drag said folder over

    I setup all my games like
    Game1/base
    Game1/update
    Game1/dlc

    Game2/base...
    Then setup a macro to drag each folder over after the cmd window closes
     
    Last edited: Dec 18, 2018
  15. ibbanez

    ibbanez Member
    Newcomer

    Joined:
    Aug 3, 2018
    Messages:
    31
    Country:
    United States
    Thanks, that worked. But what changed to where you can't simply drag the two individual files over anymore, I wonder?
     
  16. JRoad

    OP JRoad Developer
    Developer

    Joined:
    May 18, 2018
    Messages:
    922
    Country:
    Spain
    It was never planned to work that way actually.
     
  17. ibbanez

    ibbanez Member
    Newcomer

    Joined:
    Aug 3, 2018
    Messages:
    31
    Country:
    United States
    Really, thats odd. Either way, happy now.:)
     
  18. sergux

    sergux GBAtemp Regular
    Member

    Joined:
    Jul 14, 2018
    Messages:
    102
    Country:
    Afghanistan
    i converted Gris nsp to xci but it shows white icon and it doesnt launch im on 6.2 sx os 2.4.1
    Anyone can help me? i just want to avoid install nsp, its more confortable for me only read xci format.
     
    Last edited: Dec 18, 2018
  19. 18Phoenix

    18Phoenix GBAtemp Advanced Fan
    Member

    Joined:
    Nov 21, 2005
    Messages:
    591
    Country:
    Germany
    I think the opposite: I prefer installing NSPs instead of using XCIs, because it's MUCH MORE comfortable.
    A NSP is started before a XCI is just only mounted.
    I only build XCI for all games over 4GB to start them from USB HDD to save place.
    The disadvantage: loading from USB HDD is slow. But hey, it won't fit without HDD :D
    ALL other games I install in NAND or 400GB microSD.
    Updating the XCI for every single update is hard aswell instead of just installing the update.
     
    Last edited: Dec 18, 2018
    sergux likes this.
  20. JRoad

    OP JRoad Developer
    Developer

    Joined:
    May 18, 2018
    Messages:
    922
    Country:
    Spain
    You probably are missing 6.2 keys and got errors trough the conversion. Gris is a keygeneration7 game.
     
    sergux and FierceDeityLinkMask like this.
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - (Game+updates+dlc, NSC_Builder, Nintendo