ROM Hack RELEASE NSC_Builder. Nintendo Switch Cleaner and Builder. (Game+updates+dlc in a single xci)

  • Thread starter JRoad
  • Start date
  • Views 582,933
  • Replies 2,732
  • Likes 70

Sonics99

Well-Known Member
Newcomer
Joined
May 17, 2018
Messages
56
Trophies
0
Age
41
XP
211
Country
United States
Can i update a game that i already updated? XC2 and Torna both got updates and now i think i have to re download everything to apply the updates T.T

I believe if you read through the thread he mentioned that wasn't working yet. I believe you can patch DLC on after the fact, but you can do an update over a REV version of a game or a custom built xci with an update already applied. It is planned, but does not work currently.

I actually believe XC2 doesn't work period...or maybe it only doesn't work if you apply all of the dlc and the latest update. It is mentioned somewhere in this thread too.
 

huma_dawii

Well-Known Member
Member
Joined
Apr 3, 2014
Messages
3,851
Trophies
1
Age
31
Location
Planet Earth
XP
3,810
Country
United States
I believe if you read through the thread he mentioned that wasn't working yet. I believe you can patch DLC on after the fact, but you can do an update over a REV version of a game or a custom built xci with an update already applied. It is planned, but does not work currently.

I actually believe XC2 doesn't work period...or maybe it only doesn't work if you apply all of the dlc and the latest update. It is mentioned somewhere in this thread too.

Yeah DLC is known for not working with XC2, I'm talking more about the updates!
 

Firemanx

Member
Newcomer
Joined
Nov 4, 2018
Messages
15
Trophies
0
Age
32
XP
815
Country
United States
My understanding is that, as of the current release, no you can not update an already updated package or xci.

You have to start with a v0 base, then add the most recent update.

Keeping up with the thread would indicate that the OP has this on the list to work on, however.
 

18Phoenix

Well-Known Member
Member
Joined
Nov 21, 2005
Messages
832
Trophies
0
XP
2,067
Country
Germany
Can anyone please give an info update for building a XCI for Xenoblade Chronicles 2.
What exactly makes the build broken? All DLCs or one special single one?
Does base + newest UPD v917504 / v2.0.2 work ?
 
Last edited by 18Phoenix,

18Phoenix

Well-Known Member
Member
Joined
Nov 21, 2005
Messages
832
Trophies
0
XP
2,067
Country
Germany
Another game with problems: Rocket League
(not RL Ultimate Edition, that's v1.0.7 + some DLCs, you can split it to its NSP contents with 4NXCI)
Tried to generate a XCI out of base + update v851968 (v1.1.3) + all 19DLCs.
The result is pure trash, absolut unknown, by Switch and by XCI-Explorer :(

Any tips ?
 
Last edited by 18Phoenix,

JRoad

Developer
OP
Developer
Joined
May 18, 2018
Messages
1,005
Trophies
0
XP
1,732
Country
Spain
Could that fix the problems with Xenoblade Chronicles 2 and Rocket League ?
The Xenoblade Chronicles case is a titlerights remove issue with 4 of the dlc.
About Rocket League I'm not aware of issues, tell me what you mean and if you refer to last version that had the meta patching activated by default since it seemed to give errors with some updates in xci form from older games (they worked fine as NSP). I'll need to check the ones I'm aware off actually.
 

18Phoenix

Well-Known Member
Member
Joined
Nov 21, 2005
Messages
832
Trophies
0
XP
2,067
Country
Germany
About Rocket League I'm not aware of issues, tell me what you mean and if you refer to last version that had the meta patching activated by default since it seemed to give errors with some updates in xci form from older games (they worked fine as NSP). I'll need to check the ones I'm aware off actually.
Tried to generate a XCI out of NSP base + NSP update v851968 (v1.1.3) and without any DLC.
The result file is pure trash, absolut unknown, by Switch and by XCI-Explorer.
But the single NSP work fine, with Switch and with XCI-Explorer showing all infos like icon, title ID, game revision etc.
I already build a lot XCI files for huge games over 4GB (around 20). All of them work fine, only this 2 make problems.
 
Last edited by 18Phoenix,

JRoad

Developer
OP
Developer
Joined
May 18, 2018
Messages
1,005
Trophies
0
XP
1,732
Country
Spain
Tried to generate a XCI out of NSP base + NSP update v851968 (v1.1.3) and without any DLC.
The result file is pure trash, absolut unknown, by Switch and by XCI-Explorer.
But the single NSP work fine, with Switch and with XCI-Explorer showing all infos like icon, title ID, game revision etc.
I already build a lot XCI files for huge games over 4GB (around 20). All of them work fine, only this 2 make problems.
Dunno, will need to check though I tried before with the xci wich already has dlcs and updates. Although the unknown stuff seems weird like if your file wasn't finished properly (process interrupted or something) since normally they are recognized by xci explorer even if they are bad.
 

18Phoenix

Well-Known Member
Member
Joined
Nov 21, 2005
Messages
832
Trophies
0
XP
2,067
Country
Germany
Strange, the XCI generation runs without any mistake.
I deleted all cls in the batch and activated the pause to be able to watch all messages together at the end.

--------------------- MERGED ---------------------------

Dunno, will need to check though I tried before with the xci wich already has dlcs and updates.
Ah, you have the Ultimate Edition as XCI. I tried it with that aswell, same result.
Splitting this edition into its NSP parts shows, that it includes the update v458752 (v1.0.7) and 12 DLCs (out of 19).
 
Last edited by 18Phoenix,

atrocious123

Well-Known Member
Newcomer
Joined
Jan 23, 2015
Messages
87
Trophies
0
Age
30
XP
474
Country
Senegal
My understanding is that, as of the current release, no you can not update an already updated package or xci.

You have to start with a v0 base, then add the most recent update.

Keeping up with the thread would indicate that the OP has this on the list to work on, however.

Hi, can i ask if i have game with v0 base, but i have already updated the xci to say rev2. But when i build the xci with the rev3, will it be able to work?
 

JRoad

Developer
OP
Developer
Joined
May 18, 2018
Messages
1,005
Trophies
0
XP
1,732
Country
Spain
Hi, can i ask if i have game with v0 base, but i have already updated the xci to say rev2. But when i build the xci with the rev3, will it be able to work?
You're calling rev to the update number? The new update mode will let you do that, it's not the best implementation of the concept but let's you skip content to copy from the base multicine y file
Basically if you choose to skip updates it'll copy\extract all content except updates from the base file. If you choose dlcs it'll skip dlcs. If you choose both it'll skip both.
A better implementation will come later but this was the faster way to implement and allowed me to put that in this weekend's release.
 

DimensioX

Member
Newcomer
Joined
Nov 7, 2018
Messages
14
Trophies
0
Age
23
XP
380
Country
Madagascar
I'm not sure I understood this, but RequiredSystemVersion patching does this mean I can mix an update from a higher firmware and use them on a lower firmware?
I'm on 6.1, but the latest kirby update and upcoming Smash Bros Ultimate update both require 6.2. If I mix them with the base game in a single xci, will they work on 6.1?
 
Last edited by DimensioX,

thaikhoa

Well-Known Member
Member
Joined
Sep 16, 2008
Messages
2,227
Trophies
0
XP
2,483
Country
Australia
I'm not sure I understood this, but RequiredSystemVersion patching does this mean I can mix an update from a higher firmware and use them on a lower firmware?
I'm on 6.1, but the latest kirby update and upcoming Smash Bros Ultimate update both require 6.2. If I mix them with the base game in a single xci, will they work on 6.1?
100% yes
 
General chit-chat
Help Users
  • No one is chatting at the moment.
    Psionic Roshambo @ Psionic Roshambo: https://imgur.com/t/humor/HMIA6lC