1. 18Phoenix

    18Phoenix GBAtemp Advanced Fan
    Member

    Joined:
    Nov 21, 2005
    Messages:
    794
    Country:
    Germany
    Never had this error:
    Exception: local variable 'masterKeyRev' referenced before assignment
    -----------------------------------------------------------------------------------------------

    Found out myself: It was a bad dump without tik.
     
    Last edited by 18Phoenix, Feb 24, 2021
  2. 18Phoenix

    18Phoenix GBAtemp Advanced Fan
    Member

    Joined:
    Nov 21, 2005
    Messages:
    794
    Country:
    Germany
    A new game is forcing to turn off the flight mode.
    Can that be patched somehow ?

    forcing to turn off flight mode.jpg


    SOLVED
    Ah, got it myself :
    Bad outdated installers are the reason:
    SXOS via album + SXOS Installer
    Good ones:
    Awoo + DBI + Tinfoil​
     
    Last edited by 18Phoenix, Feb 24, 2021
  3. lordelan

    lordelan GBAtemp Psycho!
    Member

    Joined:
    Jan 4, 2015
    Messages:
    4,964
    Country:
    Germany
    + AtmoXL Installer (nice Awoo fork)
     
  4. duckbill007

    duckbill007 GBAtemp Fan
    Member

    Joined:
    May 5, 2011
    Messages:
    316
    Country:
    Russia
    Another reskin? Can all this "forks" add something other than new background?
     
  5. wakabayashy

    wakabayashy GBAtemp Advanced Fan
    Member

    Joined:
    Dec 25, 2014
    Messages:
    645
    Country:
    France
    n
    nobody can help me?
     
  6. jujuassou

    jujuassou Advanced Member
    Newcomer

    Joined:
    Jun 10, 2018
    Messages:
    58
    Country:
    Gabon
    Hello i have Ghost n Goblins, and SX OS 3.1.0 and still on 10.2.0 (game only works on 11.0.0) i can update to 11.0.0 but no, i want try to download to updated required version ! i want try to do it will new futur games (poke snap, mhrise etc)
    i use my keys and the 1.01b but i didn't find the Option "7 - Lower the Required System Version to the actual encryption of the game.".....
    please help
     
  7. 18Phoenix

    18Phoenix GBAtemp Advanced Fan
    Member

    Joined:
    Nov 21, 2005
    Messages:
    794
    Country:
    Germany
    First 1 or 2 (files INDIVIDUALLY or MULTI-PACK)
    Then 1 to start processing
    Now 1 or 2 (nsp or xci)
    Here it comes: Input "1" to "PATCH" the Required System Version
    Choose 11, that's enough for your FW and to avoid any 11.0.1 problems.

    Have fun with GnGR, is very hard and rocks extremly :D
     
    Last edited by 18Phoenix, Feb 27, 2021
    jujuassou and lordelan like this.
  8. jujuassou

    jujuassou Advanced Member
    Newcomer

    Joined:
    Jun 10, 2018
    Messages:
    58
    Country:
    Gabon
    aaaaah ok, like that, so i will do same process when mhrise, newpokesnap etc will come. Thanks !!
    just a question, if i install the game : it works, but if i installe the 1.0.2 update (ask to update the system) so i need to patch wich nsp ? the .nsp game ? the .nsp update ???
    yeah so hard, love it lol
     
  9. 18Phoenix

    18Phoenix GBAtemp Advanced Fan
    Member

    Joined:
    Nov 21, 2005
    Messages:
    794
    Country:
    Germany
    If you just want to install the new update first patch it with option 1 (files INDIVIDUALLY), yes.
     
    jujuassou likes this.
  10. jujuassou

    jujuassou Advanced Member
    Newcomer

    Joined:
    Jun 10, 2018
    Messages:
    58
    Country:
    Gabon
    ok the we can patch the .nsp update too ! ok cool thanks for all
     
    18Phoenix likes this.
  11. 18Phoenix

    18Phoenix GBAtemp Advanced Fan
    Member

    Joined:
    Nov 21, 2005
    Messages:
    794
    Country:
    Germany
    You can check, what FW a file needs:
    4 (FILE-INFO) -> 4 (GAME-INFO and FW requirements)
    If you have a lower FW than needed you have to patch.
     
    Last edited by 18Phoenix, Feb 27, 2021
    jujuassou likes this.
  12. hawkeye91

    hawkeye91 Advanced Member
    Newcomer

    Joined:
    Feb 16, 2015
    Messages:
    59
    Country:
    United States
    Guys, any dumbed down tutorial for converting nsp to a patched xci that can be played on firmware 11.0.0? Thx
     
  13. 18Phoenix

    18Phoenix GBAtemp Advanced Fan
    Member

    Joined:
    Nov 21, 2005
    Messages:
    794
    Country:
    Germany
    Read this page or forget it.
    Man, how %*+§& can someone be.
    If you can't read then why do you ask ??? I can't get it, absolutely.
     
    Last edited by 18Phoenix, Feb 28, 2021
  14. LyuboA

    LyuboA Unknown Entity
    Member

    Joined:
    Jun 1, 2018
    Messages:
    485
    Country:
    Bulgaria
    can NSC Builder rebuild extracted nca ??
     
  15. 18Phoenix

    18Phoenix GBAtemp Advanced Fan
    Member

    Joined:
    Nov 21, 2005
    Messages:
    794
    Country:
    Germany
    I dont' think so. It's just for getting the NCAs.

    Use NCA-NSP-XCI to LayeredFS !!!!
    You are already in this thread so why do you search for worse programs ???
    Be sure to use the newest version 1.6.4, it's in post #140 + include the newest hactool !!!!!!
    Works perfect with ALL files.
     
    Last edited by 18Phoenix, Mar 4, 2021
    lordelan likes this.
  16. LyuboA

    LyuboA Unknown Entity
    Member

    Joined:
    Jun 1, 2018
    Messages:
    485
    Country:
    Bulgaria
    well cause NCA-NSP-XCI to LayeredFS cant rebuild extracted nca file i tried hacpack but it always gives me some stupid errors
     
  17. wakabayashy

    wakabayashy GBAtemp Advanced Fan
    Member

    Joined:
    Dec 25, 2014
    Messages:
    645
    Country:
    France
    up
     
  18. 18Phoenix

    18Phoenix GBAtemp Advanced Fan
    Member

    Joined:
    Nov 21, 2005
    Messages:
    794
    Country:
    Germany
    hacpack-v1.36_r2_GUI is old but still works very good.
    https://gbatemp.net/threads/hacpack-build-and-repack-ncas-and-nsps.519815/

    Errors appear only if used wrong.
    not knowing how it work = not able to use it correct
     
    Last edited by 18Phoenix, Mar 4, 2021
  19. LyuboA

    LyuboA Unknown Entity
    Member

    Joined:
    Jun 1, 2018
    Messages:
    485
    Country:
    Bulgaria
    well even the gui dosnt work i tried the commands always give me max string no clue what that is and even the dev never responds to questions for that error

    and sure if you are a dev you dont need that but if you are making app for users then theres should be atleast some explanations on how to use it when even the gui dosnt work not to mention that if the app is in more then 2 folders gets all crazy
     
  20. smoere

    smoere Member
    Newcomer

    Joined:
    Mar 20, 2019
    Messages:
    32
    Country:
    Germany
    NSC builder CLI is working fine here. Though the web GUI not.
    I let it use the port scanner and it chose to run on port 8001.
    My Chrome gets started by CLI and opens http://localhost:8001/main.html.
    But the page does not load. It seems like the server is down or port not reachable.

    I tried deactivating firewall, but that is not the source of the issue here.
    What can i do to find the root cause?
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - (Game+updates+dlc, NSC_Builder, Nintendo