1. omegakun

    omegakun Member
    Newcomer

    Joined:
    Jan 19, 2018
    Messages:
    12
    Country:
    Brazil
    Hey Guys,
    My Windows 10 goes updated, and i can't run NSC_ and interface. DOS windows gives in loop, and interface not opening anymore, previously it working perfectly.

    aaaaAnotação 2019-12-09 103503.jpg
     
  2. JRoad

    OP JRoad Developer
    Developer

    Joined:
    May 18, 2018
    Messages:
    922
    Country:
    Spain
    It should unless it isn't able to read it for some reason, i mean i didn't touch anything there.
    Yes, there's a masterkey10 and it also burns fuses
    It already compresses to xcz, about custom xcz i'm mostly deciding if i should just allow to make them from xcz and nsz since compression can take a lot of time. It seems more efficient to make them from already compressed files if you want that.
    Anyway i don't think i'll do much work around Christmast in the program, i'll probably add more information to the gui and the new masterkey data since those are done and then resume stuff after the holidays.
     
    JeffS2Duda and 18Phoenix like this.
  3. huma_dawii

    huma_dawii GBAtemp Psycho!
    Member

    Joined:
    Apr 3, 2014
    Messages:
    3,464
    Country:
    United States
    Its not working with AC 4 for some reason... i will test other games.
     
  4. pcwizard7

    pcwizard7 GBAtemp Advanced Fan
    Member

    Joined:
    Aug 2, 2013
    Messages:
    788
    Country:
    Australia
    you have to use lockpick_rcm after every fw update to get the new keys yes

    PS: sxos has been fixed to see the games with the newer key i.e v2.9.3
     
    Last edited: Dec 10, 2019
  5. 18Phoenix

    18Phoenix GBAtemp Advanced Fan
    Member

    Joined:
    Nov 21, 2005
    Messages:
    591
    Country:
    Germany
    Thanks for info, but I know the fixes and how to use Lockpick RCM.
    And NO, there're not always new keys after an update, that's why I just asked before starting LP unnecessarily.
     
  6. pcwizard7

    pcwizard7 GBAtemp Advanced Fan
    Member

    Joined:
    Aug 2, 2013
    Messages:
    788
    Country:
    Australia
    well lockpick_rcm has been updated for 9.1 for new key so I guess there a new key but it's not really needed atm as there no game out using it
     
    18Phoenix likes this.
  7. JRoad

    OP JRoad Developer
    Developer

    Joined:
    May 18, 2018
    Messages:
    922
    Country:
    Spain
    Yes but as a warning the SX autolader doesn't work with fw 9.1.0. The presence of the autoloader folder will prompt the error at booting that makes you reboot in a never-ending loop too so if you're using it is better to update the SX OS version but not the firmware.

    Lastly you'll need a NSCB update to use masterkey10. I will support both terms master_key_10 and master_key_0a btw. I updated the python code in the beta yesterday, I'll try to give you an exe version later.
     
    18Phoenix likes this.
  8. JeffS2Duda

    JeffS2Duda Newbie
    Newcomer

    Joined:
    Dec 8, 2019
    Messages:
    2
    Country:
    Brazil
    Okay Thank's!
    I did not know that the program was already comparing XCI to XCZ. That's really good!
    I currently have all my XCI (Base + Update + DLCs) compressed games so I can use them via USB, so I was expecting a version that would compress it all into a single XCZ to free up more space on my hard drive. For now, I will update my outdated XCI and wait for this XCZ version to compress all my games (not too many hahaha).
    Thanks for the amazing work! Keep it up as long as you can! <3 hahaha.

    Translated by Google Translater
     
  9. kaizhen

    kaizhen Newbie
    Newcomer

    Joined:
    Dec 12, 2019
    Messages:
    2
    Country:
    Philippines
    Tried this with ashen flying around someplace and got file corrupted although peeps say they work on 9.1.0. Is it a new bug or this doesnt work with games with 9.1 support? I really need the game in xci though.
     
    Last edited: Dec 12, 2019
  10. JRoad

    OP JRoad Developer
    Developer

    Joined:
    May 18, 2018
    Messages:
    922
    Country:
    Spain
    There shouldn't be any 9.1 encrypted games, the 9.1 requirement should only be for the RSV which is patchable. Do you have master_key_09 added?
    Then, another thing. When you say corrupted you mean is shown as a white icon or that it doesn't load. The white icon issue was a bug from TX where they were missing the correct keys and you needed to patch the games to keygeneration 9 to see the icon or install them, they claimed they fixed it but i didn't tried yet.
    Ashen data shows it needs masterkey9 (keygeneration 10)
    -------------------------------------------------
    CONTENT ID: 010027b00e40e000
    -------------------------------------------------
    Titleinfo:
    - Name: Ashen
    - Editor: Annapurna Games, LLC
    - Display Version: 1.0.0
    - Meta SDK version: 10.0.0.0
    - Program SDK version: 7.7.0.0
    - Supported Languages: US (eng), JP, FR, DE, LAT (spa), SPA, IT, POR, RU, KOR,
    CH
    - Content type: Base Game or Application
    - Version: 0 -> Application (0)

    Required Firmware:
    - RequiredSystemVersion: 604045312 -> (9.0.1)
    - Encryption (keygeneration): 10 -> (9.0.0 - >9.0.0)
    - Patchable to: 603979776 -> (9.0.0)
     
    kaizhen likes this.
  11. pcwizard7

    pcwizard7 GBAtemp Advanced Fan
    Member

    Joined:
    Aug 2, 2013
    Messages:
    788
    Country:
    Australia
    can the interface exe also detect other chromium browsers? As I use Brave and should work the same as it does in Chrome? it's not detecting brave
     
    Last edited: Dec 12, 2019
  12. kaizhen

    kaizhen Newbie
    Newcomer

    Joined:
    Dec 12, 2019
    Messages:
    2
    Country:
    Philippines
    I see. Was able to successfully make the xci now that I've included maskeykey9. Thankie!
     
  13. JRoad

    OP JRoad Developer
    Developer

    Joined:
    May 18, 2018
    Messages:
    922
    Country:
    Spain
    Need to add a config file for that. Is easy to edit if you use the python version editing lib\Interface.py though.
     
  14. JRoad

    OP JRoad Developer
    Developer

    Joined:
    May 18, 2018
    Messages:
    922
    Country:
    Spain
    Ok, added that option for next release by specifying a path in the interface options file. I can tell you that brave browser works in chrome compatibility mode. Opera otherwise doesn't, seems eel needs them to be pure chromium.
    I'll add as options "auto" (current system), "set your path" and default. Default will launch the system default browser without chrome compatibility mode, that has a worse support in eel but is able to launch it in firefox or opera that way.
     
    pcwizard7 likes this.
  15. 18Phoenix

    18Phoenix GBAtemp Advanced Fan
    Member

    Joined:
    Nov 21, 2005
    Messages:
    591
    Country:
    Germany
    After the new FW update SNES Online forces to update, it doesn't start without.
    But the new update is still not running good.
    Most games just give an information you can skip and continue without, but some force to update.
    So is it possible to cancel the need for update by fixing the nsp somehow ?
     
    Last edited: Dec 12, 2019
  16. JRoad

    OP JRoad Developer
    Developer

    Joined:
    May 18, 2018
    Messages:
    922
    Country:
    Spain
    Update firmware or game version? If it's the firmware itself did you try patching the RequireSystemVersion?
     
  17. pcwizard7

    pcwizard7 GBAtemp Advanced Fan
    Member

    Joined:
    Aug 2, 2013
    Messages:
    788
    Country:
    Australia
    I can confirm the master key fix works in the latest version of sxos. all titles show up and work
     
    18Phoenix likes this.
  18. 18Phoenix

    18Phoenix GBAtemp Advanced Fan
    Member

    Joined:
    Nov 21, 2005
    Messages:
    591
    Country:
    Germany
    Not FW, it wants a game update :(
     
  19. pcwizard7

    pcwizard7 GBAtemp Advanced Fan
    Member

    Joined:
    Aug 2, 2013
    Messages:
    788
    Country:
    Australia
    game update are not required to start so u can just click start software
     
  20. 18Phoenix

    18Phoenix GBAtemp Advanced Fan
    Member

    Joined:
    Nov 21, 2005
    Messages:
    591
    Country:
    Germany
    Sorry, you're wrong, don't spread wrong infos. That applies to many, but not all.
    Some force you and give no option, just update or cancel, no continue.

    update_force2.jpg
     
    Last edited: Dec 14, 2019
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - (Game+updates+dlc, NSC_Builder, Nintendo