1. hippy dave

    hippy dave BBMB
    Member

    Joined:
    Apr 30, 2012
    Messages:
    5,932
    Country:
    United Kingdom
    No sorry, I've never encountered that one. Try a different cable, different USB port?
     
  2. developer_su

    OP developer_su GBAtemp Regular
    Developer

    Joined:
    Feb 18, 2019
    Messages:
    125
    Country:
    Russia

    NS-USBloader v3.0
    Changelog:
    • New windows users can (download and) install drivers from application using button on settings ('Gear') tab. Drivers are libusbK v3.0.7.0 that people used to install over Zadig. Drivers would be installed for both APX (RCM Mode) and 'Homebrew' modes of the NS.
    • Added CLI key for removing all application settings. I don't know why you may need this but maybe in case of some emergency. Read a bit more about CLI

    [​IMG]

    — Posts automatically merged - Please don't double post! —

    @azoreseuropa
    Also, you were right about check-for-updates-error. There were a typo on GitHub site that I made.
    Thanks!
     
  3. Crimsn64

    Crimsn64 Newbie
    Newcomer

    Joined:
    Jul 14, 2020
    Messages:
    1
    Country:
    United States
    I'm trying to install NS-USBloader on Ubuntu Mate, and I can't get it to work, I've downloaded the normal 3.0 JAR file from the github releases page. I marked it as executable, and even tried running it as admin. but it still wont launch (i have Java 8 JDK runtime installed)
     
  4. azoreseuropa

    azoreseuropa GBAtemp Guru
    Member

    Joined:
    Nov 6, 2002
    Messages:
    9,799
    Country:
    Portugal
    Last edited by azoreseuropa, Jul 14, 2020
  5. sudeki300

    sudeki300 GBAtemp Advanced Fan
    Member

    Joined:
    Nov 20, 2004
    Messages:
    599
    Country:
    when i tried this my pc would always give a blue screen sad face when turning off after using this app, also always got usb time error on Awoo installer. ended up uninstalling
     
  6. developer_su

    OP developer_su GBAtemp Regular
    Developer

    Joined:
    Feb 18, 2019
    Messages:
    125
    Country:
    Russia
    What executable? It should be executed as '$ java -jar filename.jar'. There are no +x requirement for jar file.

    Also agree with azoreseuropa, use something newer on Linux. Like OpenJDK11 (because it's LTS) or JDK14. I heard there are some issues with JRE8 on Linux.. But if you try it with JRE8 let me know if it works =)
     
  7. zeomax

    zeomax Member
    Newcomer

    Joined:
    Nov 23, 2005
    Messages:
    22
    Country:
    Gambia, The
    Is this available as a non java version? I am asking because I had always trouble to run java applications. I tired OpenJDK and the original Oracle one, nothing works. I am still using the old goldtree.exe, it is the only one that is available as an normal exe file.
     
  8. developer_su

    OP developer_su GBAtemp Regular
    Developer

    Joined:
    Feb 18, 2019
    Messages:
    125
    Country:
    Russia
    No. For this java application only java's version available.
     
  9. azoreseuropa

    azoreseuropa GBAtemp Guru
    Member

    Joined:
    Nov 6, 2002
    Messages:
    9,799
    Country:
    Portugal
    Here:

     
  10. developer_su

    OP developer_su GBAtemp Regular
    Developer

    Joined:
    Feb 18, 2019
    Messages:
    125
    Country:
    Russia

    NS-USBloader v4.0

    Changelog:
    • Full command line interface support for people who don't have GUI (issue #50). Click to read more
    • Updated Brazilian Portuguese translation by @almircanella. Thank you!
    • Refactored Tinfoil/Awoo NET related code. Installations should work faster now.
    • Update icon for 'Games' tab ;)
    • 'Allow XCI / NSZ / XCZ files selection for Tinfoil' settings option enabled by-default for new installations.
    • GoldLeaf version should be set in options: v0.8 selected by-default. No more discouraging 'Use old GoldLeaf version' checkboxes.
    • A lot of code polishing
     
  11. developer_su

    OP developer_su GBAtemp Regular
    Developer

    Joined:
    Feb 18, 2019
    Messages:
    125
    Country:
    Russia

    NS-USBloader v4.1

    Changelog:
    • Add RCM-payload tool support for Raspberry Pi. Built and tested on 'Raspberry Pi 3 Model B'.
    Notes: For using this application in GUI you have to install 'openjfx' package. For using it in CLI-mode the only requirement is 'default-jdk'. (Package names listed here and in readme file are valid for 'Raspberry Pi OS'.) And thanks to @dreamfalcon ;)
     
    Last edited by developer_su, Jul 23, 2020
  12. Muxi

    Muxi GBAtemp Advanced Fan
    Member

    Joined:
    Jun 1, 2016
    Messages:
    518
    Country:
    Germany
    What could be the reason for extreme fluctuations in the transfer rate, which could also lead to the failure of an installation (under Windows)?
     
    Last edited by Muxi, Jul 24, 2020
  13. developer_su

    OP developer_su GBAtemp Regular
    Developer

    Joined:
    Feb 18, 2019
    Messages:
    125
    Country:
    Russia
    Bad cable, glitchy software, bugs in latest JDK, old/slow sd card. But I guess the most bugs are because of the cable.
     
    Muxi likes this.
  14. developer_su

    OP developer_su GBAtemp Regular
    Developer

    Joined:
    Feb 18, 2019
    Messages:
    125
    Country:
    Russia
    Few minor things..


    NS-USBloader v4.2

    Changelog:

    • Add Czech Translation by @spenaat. Thank you!
    • Add Traditional Chinese translation by @qazrfv1234. Thank you!
    • Minor corrections: language drop-down selector in settings now showing language names (and locale) instead of three-letter abbreviations; preferences option name changed (back end).
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - USBloader, installer, GoldLead