1. mister j-y

    mister j-y Member
    Newcomer

    Joined:
    Aug 19, 2015
    Messages:
    12
    Country:
    No I didn't! Thanks...I'll give it a go maybe with ChoidujourNX >edit< although that doesn't work, so I downgraded with Daybreak, but still no dice...do I need to try going back to AMS 19?

    Now my on/off button doesn't work! Agh! Bricked?
     
    Last edited by mister j-y, Apr 16, 2021
  2. LeMageFro

    LeMageFro GBAtemp Regular
    Member

    Joined:
    Mar 29, 2018
    Messages:
    210
    Country:
    France
    I don't think staying on a lower version of atmos just for NSP forwarders is gonna be very wise in the long run. Especially once most homebrews get updated for atmos 19, I'm not sure they'll keep working for atmos pre 19.
     
    mathew77 likes this.
  3. mister j-y

    mister j-y Member
    Newcomer

    Joined:
    Aug 19, 2015
    Messages:
    12
    Country:
    so...upgrade back to 12 and wait it out?
     
  4. duckbill007

    duckbill007 GBAtemp Fan
    Member

    Joined:
    May 5, 2011
    Messages:
    317
    Country:
    Russia
    Or just fork and fix nro2nsp.
     
  5. HalfScoper

    HalfScoper Member
    Newcomer

    Joined:
    Apr 16, 2021
    Messages:
    34
    Country:
    Germany
    Can confirm that all the latest homebrew updates which already have been pushed didn't work on pre 0.19.0 AMS (tested 0.18.1), so it's a big struggle to wait on an older build not only for forwarders (which I honestly could let go more easily) but generally for unpatched homebrew, or to profit from the latest updates of AMS and homebrew but to let go off your favorite plugin or whatever that has not been updated yet and most likely won't be because it was already abandoned.
     
    LeMageFro likes this.
  6. LeMageFro

    LeMageFro GBAtemp Regular
    Member

    Joined:
    Mar 29, 2018
    Messages:
    210
    Country:
    France
    As long as you can do everything you want on atmos 18 you can keep using HOS 11, I just meant that depending on which homebrews you like to use there may come a time when you have no choice but to use atmos 19 in order to access the latest homebrew updates.
     
  7. mister j-y

    mister j-y Member
    Newcomer

    Joined:
    Aug 19, 2015
    Messages:
    12
    Country:
    ok, just consider me a noob, if I put a lower AMS on my SD will that work, and do I need the appropriate sigpatches or ok to use the current ones? Is it worth it, or just wait til the homebrew is updated (it only came out last week)?
     
  8. HalfScoper

    HalfScoper Member
    Newcomer

    Joined:
    Apr 16, 2021
    Messages:
    34
    Country:
    Germany
    Be sure to study what files/folders are exactly included in Atmosphere and delete them from your SD (except mods or cheats in the contents folder) before you place the new ones just to be sure. You‘d also need appropriate sigpatches if you change versions.
     
  9. mister j-y

    mister j-y Member
    Newcomer

    Joined:
    Aug 19, 2015
    Messages:
    12
    Country:
    Thanks man so I'll delete the diles instead of overwriting***, and I guess I need the appropriate fusee for booting the system into AMS too

    ***and replace em
     
    Last edited by mister j-y, Apr 16, 2021
  10. mister j-y

    mister j-y Member
    Newcomer

    Joined:
    Aug 19, 2015
    Messages:
    12
    Country:
    it worked thank you!!! oh god such relief
     
    HalfScoper likes this.
  11. kodiportalgabe

    Newcomer

    Joined:
    Apr 17, 2021
    Messages:
    8
    Country:
    United States
    I couldn't get any forwarders or retroarch to work on 12.0.0 atmosphere 0.19.1 and the latest retroarch 1.9.1. I downloaded the older retroarch 1.9.0 and can play it out of the HBMENU (applet) but not once its docked (says error). I'm trying to remove applet but all forwarders are not working. :sigh:
     
  12. LyuboA

    LyuboA Unknown Entity
    Member

    Joined:
    Jun 1, 2018
    Messages:
    485
    Country:
    Bulgaria
    just use app override option hold R when starting any game and you will be in HBMENU same as forwarder
     
  13. kodiportalgabe

    Newcomer

    Joined:
    Apr 17, 2021
    Messages:
    8
    Country:
    United States
    Thats one of the problems. The forwarders for HBMENU or roms aren't working.
     
  14. LeMageFro

    LeMageFro GBAtemp Regular
    Member

    Joined:
    Mar 29, 2018
    Messages:
    210
    Country:
    France
    Yes but the app override option works as Lyuboa was saying (it's an option of Atmosphere itself so it will always work). Just hold R when launching a game (anything but a broken forwarder should work) and you'll see that it will start HBmenu with full privileges (ie not in applet mode). From there any homebrew you start will also have access to the full memory and all 4 cores, just like they did when you launched them with a forwarder. It's less convenient for sure but it's a workaround for now.
    And you can use the latest retroarch, the fact that forwarders don't work anymore has nothing to do with retroarch itself.
     
    Last edited by LeMageFro, Apr 18, 2021
  15. kodiportalgabe

    Newcomer

    Joined:
    Apr 17, 2021
    Messages:
    8
    Country:
    United States
    Ohhhhh gotcha, K let me go try

    update: Thank you, it worked! No longer got that blue error atmosphere screen (due to applet mode). I guess this will have to do until they can figure out the forwarder issue.
     
    Last edited by kodiportalgabe, Apr 17, 2021
    LeMageFro likes this.
  16. duckbill007

    duckbill007 GBAtemp Fan
    Member

    Joined:
    May 5, 2011
    Messages:
    317
    Country:
    Russia
    File removed because reported as not working on 12.0.1 emummc + Hekate 5.5.5 + atmos 0.19.1 loaded with primary
     
    Last edited by duckbill007, Apr 22, 2021
    kodiportalgabe, Storm21 and SodaSoba like this.
  17. HalfScoper

    HalfScoper Member
    Newcomer

    Joined:
    Apr 16, 2021
    Messages:
    34
    Country:
    Germany
    The person above was very well able to make their own forwarders, but it seems a HOS 12.0.0/AMS 0.19.0 problem to not be able to launch forwarders at all.

    Edit: I stand corrected.
     
    Last edited by HalfScoper, Apr 20, 2021
  18. duckbill007

    duckbill007 GBAtemp Fan
    Member

    Joined:
    May 5, 2011
    Messages:
    317
    Country:
    Russia
    Forwarder in my post runs on HOS 12.0.0/AMS 0.19.0.

    It's a forwarder issue, not HOS/AMS
     
    HalfScoper, Storm21 and SodaSoba like this.
  19. SodaSoba

    SodaSoba {iconic}
    Member

    Joined:
    May 28, 2018
    Messages:
    397
    Country:
    United Kingdom
    I'm preying you fork nro2nsp :P considering how well DBI works I think you would smash it.
     
    f0li0 likes this.
  20. duckbill007

    duckbill007 GBAtemp Fan
    Member

    Joined:
    May 5, 2011
    Messages:
    317
    Country:
    Russia
    I have no possibility to fork nro2nsp - I have no skills in C# and windows programming. I just get hbloader code and compile forwarder for hbmenu from it and use hacbrewpack to make nsp.
     
    SodaSoba likes this.
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - Forwarders, Retroarch, Nro2Nsp