Noob question (about upgrading/downgrading IOS)

Discussion in 'Wii - Hacking' started by kirokun, Sep 10, 2009.

Sep 10, 2009
  1. kirokun
    OP

    Member kirokun GBAtemp Regular

    Joined:
    Jan 31, 2008
    Messages:
    196
    Country:
    United States
    Hi, I have a few noobish questions that I didn't see, and I did use the search button but I got nothing.

    1# I'm assuming that I need a IOS##.wad and use the wad manager to install/upgrade/downgrade my current IOS. I hope that's how it's done and if you can anyone PM me IOS53 wad please?

    2# Currently I cannot play Muramasa The Demon Blade and Metroid Prime 2 Echoes (From the MP trilogy), however MP1 works great, but when I chose MP2 it says it cannot read the disc... as for muramasa it also says it cannot read the disc. (I'm pretty sure it's not a disc problem btw).

    Oh yea I'm currently on IOS249 and I need to have IOS53 in order to play Muramasa (at least that's what I heard), I have cIOS 38 rev 14 i believe and im running on system 3.2U

    Thanks in advance.
     
  2. nabster92

    Member nabster92 GBAtemp Advanced Maniac

    Joined:
    Apr 16, 2009
    Messages:
    1,631
    Country:
    United States
    You are very misinformed about what IOS's are. You aren't "on" one IOS. You have like 20 IOS's that your system uses, IOS 249 IS what cIOS38 rev14 installs to.

    You are likely just MISSING some IOS's which doesn't mean you have to change your existing IOS's or downgrade anything.

    You just need to figure out what IOS's you're missing and install them. Also you can just run Waninkoko's 4.0 updater and then his 4.1 updater and it should install any missing IOS's you have itself aside from the new IOS56 in GH5 and RB beatles I suppose.

    IOS's 38, 53, and 55 are common IOS's that most recent games need that you probably don't have.

    Read through the trucha bug section of the guide in my sig for more info on what IOS's actually are and then go through the 4.1 updater/dop-IOS section to get everything up to date on your Wii.
     
  3. kirokun
    OP

    Member kirokun GBAtemp Regular

    Joined:
    Jan 31, 2008
    Messages:
    196
    Country:
    United States

    Thanks a lot man, I actually learned a lil bit more about IOS just before you posted XD

    BTW I really don't want to go through the whole updating to 4.1 process, is there a must quicker way to install the missing ios 53 (basically just installing the missing ios 53 while keeping 3.2U)?
     
  4. nabster92

    Member nabster92 GBAtemp Advanced Maniac

    Joined:
    Apr 16, 2009
    Messages:
    1,631
    Country:
    United States
    Staying at 3.2 at this point is really not worth it and just leaves you in a more vulnerable to bricking state. But if you really are against updating even though you lose nothing and get the sd card menu on top of it, you can just use dop-IOSv7 and scroll through your IOS's to see what you are missing or what isn't the latest version and have it install it from there if you need to. You can skip patching in the sig hash check (trucha bug) in them though. You don't really need them in anything other than maybe IOS36 and IOS60. And not even in IOS 60 if you're not updating to 4.0/4.1. It also lets you patch in the ES_Identify patch into IOS36 so you can do that as well.

    So basically you can just run that and skip any system menu IOS's like 30, 50 and 60. (Actually you could install IOS60, having that system menu IOS won't hurt as it is up to date and not a stub.) Also skip 51 as it's just a stub IOS as well. Get IOS61 if you want the shop channel to start working.
     
  5. kirokun
    OP

    Member kirokun GBAtemp Regular

    Joined:
    Jan 31, 2008
    Messages:
    196
    Country:
    United States
    arg.... installing ios53 didnt help...

    I might as well give up and go with 4.1u...

    I will do this but before I do, I have a lot of 3.2U stuff like starfall and a lot of other junk, would it be best to virgin my wii?
     
  6. nabster92

    Member nabster92 GBAtemp Advanced Maniac

    Joined:
    Apr 16, 2009
    Messages:
    1,631
    Country:
    United States
    What are you using to load your games? If it's still the gamma 0.3 loader, you should uninstall that too and use NeoGamma R7 instead.

    Other than that, just get rid of starfall and then just continue from there pretty much doing everything in my guide. Reinstall the HBC from the hackmii installer if you have a version less than 1.0.3, get bootmii while you're there for brick protection infinitely better than starfall (if you can install to boot2), skip the trucha bug restorer step since you already have rev14 installed, then just go on to the 4.1 updating steps and then dop-IOS IOS60. Then install preloader if you want system menu hacks or if you couldn't install bootmii to boot2.
     
  7. kirokun
    OP

    Member kirokun GBAtemp Regular

    Joined:
    Jan 31, 2008
    Messages:
    196
    Country:
    United States
    I changed your instructions into step-by-step, much easier to follow [​IMG]
     
  8. nabster92

    Member nabster92 GBAtemp Advanced Maniac

    Joined:
    Apr 16, 2009
    Messages:
    1,631
    Country:
    United States
    Wait what version of CIOSCORP do you have?

    You might also want to just use dop-IOS first and install normal IOS's over all of that first just in case. You can do that after installing bootmii and making a NAND backup with it though.
     
  9. kirokun
    OP

    Member kirokun GBAtemp Regular

    Joined:
    Jan 31, 2008
    Messages:
    196
    Country:
    United States
    I have the recent cIOSCORP i believe it was 3.4
    Also about the whole reinstall HBC through hackmii, it says in red text that i don't have the IOS to install it with, same goes for DVDx
     
  10. nabster92

    Member nabster92 GBAtemp Advanced Maniac

    Joined:
    Apr 16, 2009
    Messages:
    1,631
    Country:
    United States
    Oh right, yea that's because you have CIOSCORP installed. The hackmii installer doesn't like it. It looks for some sane IOS to use to install everything, but finds everything turned inside out by CIOSCORP and gets confused and just doesn't continue to be safe. So if you did install 3.4, I believe that version actually came with a proper uninstaller as well that should install your official IOS's back to what they should be. Then you can run everything again like normal.
     
  11. kirokun
    OP

    Member kirokun GBAtemp Regular

    Joined:
    Jan 31, 2008
    Messages:
    196
    Country:
    United States
    I'm currently on 3.2U not 3.4U :[
     
  12. nabster92

    Member nabster92 GBAtemp Advanced Maniac

    Joined:
    Apr 16, 2009
    Messages:
    1,631
    Country:
    United States
    I meant cioscorp 3.4 not the system menu, you need to uninstall CIOSCORP. Either use that uninstaller or use dop-IOS.

    Edit: And DO NOT UNINSTALL IT BY DELETING IT'S IOS'S.
     
  13. kirokun
    OP

    Member kirokun GBAtemp Regular

    Joined:
    Jan 31, 2008
    Messages:
    196
    Country:
    United States
    Lol yea i got it XP
     
  14. kirokun
    OP

    Member kirokun GBAtemp Regular

    Joined:
    Jan 31, 2008
    Messages:
    196
    Country:
    United States
    Sorry for double post...

    I had preloader installed already (0.28), once I accessed the preloader menu, the 'UPDATE' option appeared so since there was a 0.29 ver I decided to UPDATE it, however the problem is that it seems the update got stuck...

    "downloading changelog..." it's been like that for 20 minutes. Did I do something wrong?
     

Share This Page