Noob Q - What is the diadvantage of a 1.5 PSP?

Discussion in 'PSP - Hacking & Homebrew' started by Farami9, Apr 8, 2007.

  1. Farami9
    OP

    Farami9 GBAtemp Regular

    Member
    247
    0
    Aug 31, 2003
    United States
    Hi,

    I am going to buy a secondhand 1.5 ver PSP just wondering what are the disadvantages? (if there are any?)

    I heard that some of the newer games need firmware that is higher then 1.5 (what games - is there a list?), so then how could I run these types of games while still be able to have my 1.5 firmware? Or do I just have to miss out on newer games to retain my 1.5 firmware?

    Thanks Heaps

    Happy Easter All
     
  2. 4saken

    4saken Retired Ace Attorney

    Member
    3,358
    3
    Nov 28, 2006
    It has less features than the higher versions. Most other things are advantages (if you plan to use devhook you can emulate the higher firmwares). Alternatively you may upgrade to 3.XX open edition by DarkAlex so you can run homebrew and games and still have all the perks of a high firmware number
     
  3. Azimuth

    Azimuth Chicken Teriyaki Boy!

    Member
    637
    2
    Feb 23, 2006
    Canada
    theres no need to maintain version 1.5, the custom firmwares have made it obsolete.
     
  4. [M]artin

    [M]artin .

    Member
    3,660
    276
    Nov 7, 2006
    United States
    It's easier to upgrade to custom firmware (faster I should say, less steps involved). 1.5 is a good place to start if you're planning on jumping to custom firmware... (aka, The Good Stuff)
     
  5. Farami9
    OP

    Farami9 GBAtemp Regular

    Member
    247
    0
    Aug 31, 2003
    United States
    "custom firmwares"

    What do you mean by this....

    Ok If I can't get a 1.5 ver what other firmware ver should I aim for (keep in mind I really want to use homebrew + emulators not PSP ISOs are they are too big to download)...
     
  6. [M]artin

    [M]artin .

    Member
    3,660
    276
    Nov 7, 2006
    United States
    1.5 is perfectly fine. In order to use homebrew and emulators, Custom Firmware is preferred. You can nab anything BUT NOT FIRMWARE VERSIONS 3.10-3.30!!! These are Sony's official firmware releases and they disable all homebrew and cool stuffs. Once you get your PSP NEVER RUN "NETWORK UPDATE"! NEVER!!! It will update your psp to sony's latest firmware, disabling everything you love. Custom firmware however is what you need, and it's named kind of the same, so don't get mixed up. You need to get to 3.03 OE or 3.10 OE-A (OE stands for Open Edition, it's custom firmware that was hacked so that you can run emu's and stuff, hackers took Sony's official updates and added onto them with new features and the enabling of homebrew and such).

    But enough of that for now...
    1.5 is perfect, you'll just have to upgrade to custom firmware when you get it, no trouble at all. Just remember what types of firmware to stay away from and you'll be fine. If you run into any trouble, just drop me a message.

    Bed is calling my name, night all. [​IMG]
     
  7. spas

    spas GBAtemp Fan

    Member
    389
    0
    Dec 15, 2006
    Also like a friends sister did, do not allow them to run a game and upgrade the firmware. This will do the same bad things as the network update.
     
  8. deathfisaro

    deathfisaro Narcistic Deathfisaro Fan

    Member
    2,053
    0
    Mar 16, 2007
    Canada
    Vancouver, BC
    There aren't much disadvantages of 1.5, opposed to latest firmware (3.40 I believe)
    1.5 , 2.71 and 3.xx OE firmwares are ideal for running homebrews, enhancing your PSP's functionality.
    Well the obvious disadvantage is if you brick your PSP, Sony A/S guys will update it to latest firmware, so you lose 1.5 =P
     
  9. shaffaaf27

    shaffaaf27 GBAtemp Fan

    Member
    310
    0
    Oct 29, 2006
    london, england
    also if you go to the newest custom FW the network update will day there is no need to update your FW, or an unsuspecting familymember or friend wont accudently upgrade the FW while playing a game.
    also some games make you upgrade your FW before you can attempt to play the game....therefore it is best to keep to the newest FW. becuase it wont need to be upgraded to play a game
     
  10. mikeosoft

    mikeosoft GBAtemp Regular

    Member
    210
    0
    Dec 9, 2004
    United States
    bro like the homi above me stated, jist invest in Dark_alex's 3.40 oe a firmware --its the most up to date and man its heaven-sent when you come back to the scene a few days ago to upgrade from 1.50 to this. i mean the features are unbelievable, if someone told me this is where we'd be in 2007, i'd never have believed em.