[No longer maintained] RajNX - starter pack for Nintendo Switch

Discussion in 'Switch - Exploits, Custom Firmwares & Soft Mods' started by rajkosto, Aug 4, 2018.

  1. lordelan

    lordelan GBAtemp Psycho!

    Member
    11
    Jan 4, 2015
    Germany
    There's no real difference. I find this easier to use.
     
    0x64, Lotush and thorasgar like this.
  2. Dothackjhe

    Dothackjhe GBAtemp Fan

    Member
    4
    Dec 29, 2013
    Philippines
    Philippines
    I'm intrigued. I might check this one out sometime.

    Question, though: Why was Tinfoil removed from the latest commit of this CFW?
     
    Last edited by Dothackjhe, Aug 16, 2018
  3. Deathpenaltyx

    Deathpenaltyx Newbie

    Newcomer
    1
    May 2, 2016
    can you run xci files using this please
     
  4. lordelan

    lordelan GBAtemp Psycho!

    Member
    11
    Jan 4, 2015
    Germany
    No and I doubt this will happen anytime soon as NSPs are prefered by the community now.
    Either use SX OS for XCIs or convert them to NSPs or get them as NSPs.
     
    Lotush, 0000ff and thorasgar like this.
  5. Melhisedek

    Melhisedek Advanced Member

    Newcomer
    5
    Jun 7, 2006
    Sorry if this has been asked before, but when I try to load the firmware, I get a loooooong (10-20) seconds black screen, after that I see Switch splash and as soon as I enter A three times it says that I need to download ext driver in order to use sdcard. When I turn it off it takes a while and than gives me some error and finally shuts down.

    I tried both with PreventGCUpdate and without and it is the same. I have 3.0 firmware updated to 5.1.0 using rajkosto guide. Everything works with some other builds but I would like to use this one :)
     
  6. Zumoly

    Zumoly GBATemp Analyst

    Member
    7
    Apr 27, 2018
    Mali
    Yorosso
    You can install them and the icon of the game will show on your home menu.
    But it will require you to install the base game before booting (a cloud icon will show on top just like for updates)
     
    0x64 and thorasgar like this.
  7. rajkosto
    OP

    rajkosto GBAtemp Advanced Fan

    Member
    11
    Apr 6, 2017
    format your microsd as fat32 and then install exFAT version of the firmware youre currently running (via ChoiDujourNX)...
    no clue how you could have "everything working with other builds" if youre using exFAT formatted microSD without having the required firmware for it.
     
    Last edited by rajkosto, Aug 16, 2018
    Lotush and thorasgar like this.
  8. Jalink9406

    Jalink9406 Member

    Newcomer
    2
    Oct 27, 2017
    Mexico
    I just hacked my Switch for the first time and using RajNX everything was a breeze. From the nand backup to setting up CFW autoboot and installing nsps. Thank you!
     
    thorasgar and Mouser X like this.
  9. lordelan

    lordelan GBAtemp Psycho!

    Member
    11
    Jan 4, 2015
    Germany
    @rajkosto I can't get a custom boot image to show up although I'm sure I have it in the correct color mode and resolution.
    Do you plan on adding splash.bin support as well (or is it already supported)?
     
  10. sammycat

    sammycat Newbie

    Newcomer
    1
    Jan 27, 2007
    United States
    Hi, quick Newbie question: I tried to play the Ace Mario Tennis NSP game but it says I need to update the system firmware before running it. My switch is on 4.0.1 right now. Is it ok to just go ahead and update? If not, is it possible to play the game without updating the firmware of the console? Thanks.
     
  11. lordelan

    lordelan GBAtemp Psycho!

    Member
    11
    Jan 4, 2015
    Germany
    I think it requires at least 4.1
    You could update to 5.1 but I recommend using this if you don't wanna go online.
     
    thorasgar likes this.
  12. rajkosto
    OP

    rajkosto GBAtemp Advanced Fan

    Member
    11
    Apr 6, 2017
    don't update to 5.x unless you really have to
    most games still only need 4.1 to work, so update to that, using ChoiDujourNX (as youre already on 4.x you cant burn fuses this way either)
     
  13. lordelan

    lordelan GBAtemp Psycho!

    Member
    11
    Jan 4, 2015
    Germany
    Apart from burning fuses what's the point in not updating to 5.1 to garantee 100 percent compatibility with all games if he's already >3.0.2 anyway?
     
    sammycat likes this.
  14. shchmue

    shchmue GBAtemp Advanced Fan

    Member
    7
    Dec 23, 2013
    United States
    if dealing with AutoRCM is too inconvenient
     
  15. sammycat

    sammycat Newbie

    Newcomer
    1
    Jan 27, 2007
    United States
    Thanks to all of your help. Is it also needed to upgrade to 5.1 so I could have the ExFAT support? I have a Mario Kart game that is over 7GB. Right now I can't copy it to the SD card because my file system is only on FAT. Should I just go ahead and use the CoinDuourNX to upgrade to 5.1? Thanks again.
     
  16. rajkosto
    OP

    rajkosto GBAtemp Advanced Fan

    Member
    11
    Apr 6, 2017
    exFAT is available for any firmware 2.0.0+ just install the (exFAT) version of the firmware you currently have via ChoiDujourNX
     
    mooglazer and sammycat like this.
  17. sammycat

    sammycat Newbie

    Newcomer
    1
    Jan 27, 2007
    United States
    Strange..I have successfully upgraded to 4.1. Thanks to all of your help. However, when I tried to launch Mario Ace Tennis it still says "A system update is required in order to use this software". Any ideas?
     
  18. OperationNT

    OperationNT GBAtemp Regular

    Member
    6
    May 1, 2016
    France
    Mario Tennis works great with LayeredFS over SMO on 4.0.1. I think this solution is often forgotten.
     
  19. sammycat

    sammycat Newbie

    Newcomer
    1
    Jan 27, 2007
    United States
    Thanks! Finally got Mario Ace Tennis working after using your method to upgrade to 5.1. I am now trying to format the card to EXFAT so I could load the Mario Kart game which is greater than 8GB. However, every time I formatted the card using EXFAT the switch would fail to recognize the card. Everything would be fine if I changed it back to FAT32. Can anyone help to resolve this?
     
  20. Serfrost

    Serfrost GBAtemp Fan

    Member
    3
    Jan 7, 2015
    United States
    What PC OS are you using?
     
Loading...