Hardware Nintendo Switch LCD issue?

Subaru-2

New Member
OP
Newbie
Joined
Jul 14, 2020
Messages
1
Trophies
0
Age
22
XP
33
Country
United States
I just recently read a thread in which the community here gave some super valuable advice and was hoping to receive some myself. Recently my Switches screen started acting up out of nowhere. When I power it on or wake it the screen is covered in multicolored horizontal lines with a sort of grid pattern, after about 1-3 seconds the screen will go black with backlighting still present. The digitizer seems to work perfectly as well, and the Switch functions normally when docked. This problem seems to have appeared out of the blue with no forewarning. It seems to have occurred in the span of about 5-10 minutes. I plugged my switch into the charger and left the room for a moment, upon returning the screen was completely covered in the aforementioned lines. I’m not sure if it’s an issue with the lcd or possibly an issue with the motherboard. I opened the switch up and there doesn’t seem to be any issue with the ribbon cables or connection. Any help would be very very much appreciated.
 

Fixyourtechnology

New Member
Newbie
Joined
Sep 1, 2020
Messages
3
Trophies
0
Age
35
XP
20
Country
United Kingdom
I have the exact same problem with two switch's i'm working on, When i find the answer i will let you know,
tried replacing the connector and tried with a known working screen but still just a black screen with back-light,
when screen is unplugged the screens test-point is presenting 1.6v as if the screen is plugged in,
everything else works perfectly,
if anyone knows the ic or diode\cap\resistor causing this issue please let us know.
Thanks in advance
 

Fixyourtechnology

New Member
Newbie
Joined
Sep 1, 2020
Messages
3
Trophies
0
Age
35
XP
20
Country
United Kingdom
Found my problem it was the IC marked "8316 8f40" to the left of the connector, there was slight burn damage and showed the solder point underneath at an angle, totally missed it on first few passes, hope this helps mate
 

yoitsmegabe

Member
Newcomer
Joined
Aug 2, 2019
Messages
6
Trophies
0
Age
37
XP
68
Country
United States
Found my problem it was the IC marked "8316 8f40" to the left of the connector, there was slight burn damage and showed the solder point underneath at an angle, totally missed it on first few passes, hope this helps mate
Sorry for the necro post but there are so few posts regarding this topic on the internet. I recently had the lines across the screen issue after doing a shell/housing swap. I thought maybe It was a loose ribbon cable so I tried to reseat it. Apparently the FPC connector had collapsed pins inside which were bent as a result of me trying to put the ribbon cable in the second time. I successfully replaced the LCD's FPC connector and I'm still getting those lines across the screen. In case its a bad screen, I ordered a new one. Did replacing the 8316 chip solve the problem? I suspect that's what may have happened to me so I have a few of those on order. Preparing myself for all scenarios. Thanks for your tip on which chip to get.
 
General chit-chat
Help Users
  • No one is chatting at the moment.
    Psionic Roshambo @ Psionic Roshambo: "This just in... The pizza also contained Canadian bacon... I can't take it anymore... Canadian...