Ninjhax 2.0 - FBI and PastaCFW not working?

Discussion in '3DS - Flashcards & Custom Firmwares' started by Xeonhawk, Jul 18, 2015.

  1. Xeonhawk
    OP

    Xeonhawk GBAtemp Regular

    Member
    171
    55
    Nov 23, 2014
    United States
    Every time I load up either of the two, the system freezes. does this happen to anyone else?
     
  2. WateredFire19

    WateredFire19 Banned

    Banned
    643
    215
    Aug 23, 2014
    United States
    FACEPALM
     
    Ronhero likes this.
  3. KeepPlanC

    KeepPlanC GBAtemp Regular

    Member
    117
    46
    Jan 8, 2015
    United States
    wow really?
     
  4. WateredFire19

    WateredFire19 Banned

    Banned
    643
    215
    Aug 23, 2014
    United States
    Currently, Ninjhax 2.0 does not have ARM9 access. This will probably change in the future. though
     
  5. caytung07

    caytung07 Member

    Newcomer
    42
    11
    Apr 2, 2015
    FBI can work, but can't install any cias because it lacks services maybe, and Pasta freezes the device
     
  6. Xenon Hacks

    Xenon Hacks GBAtemp Guru

    Member
    7,115
    3,412
    Nov 13, 2014
    United States
    This Guy
     
  7. EmceeKerser

    EmceeKerser GBAtemp Maniac

    Member
    1,374
    503
    Jun 3, 2014
    The fuckin' Blue Mountains brah
    Wow
     
  8. shinyquagsire23

    shinyquagsire23 SALT/Sm4sh Leak Guy

    Member
    1,966
    3,249
    Nov 18, 2012
    United States
    Las Vegas
    Actually aside from the obvious, libkhax is broken on ninjhax 2.0.
     
  9. Gadorach

    Gadorach Electronics Engineering Technologist

    Member
    958
    697
    Jan 22, 2014
    Canada
    Canada
    libkhax should be fixed up though really, 2.0 will benefit users that don't have a browser and are on otherwise exploitable firmwares. Past that, it would be neat to see if FBI can be modified to install legit CIAs at some point on 9.3-9.9. Just depends on if anyone can get the necessary service hooks or not, really.
     
  10. WateredFire19

    WateredFire19 Banned

    Banned
    643
    215
    Aug 23, 2014
    United States
    That's what i've been reading on other threads. Using FBI to install legit CIA's on 9.3+ sysnand using NH 2.0 will probably be doable in the very close future.
     
  11. NakedFaerie

    NakedFaerie GBAtemp Fan

    Member
    380
    55
    Jul 12, 2007
    In the shadows behind you
    I've also noticed PastaCFW and rxtools dont work.
    I also cant find a way to downgrade ninjhax back to 1.1. Anyone have an idea how I can downgrade?
     
  12. Xenon Hacks

    Xenon Hacks GBAtemp Guru

    Member
    7,115
    3,412
    Nov 13, 2014
    United States
    http://smealum.net/ninjhax/
     
  13. EmceeKerser

    EmceeKerser GBAtemp Maniac

    Member
    1,374
    503
    Jun 3, 2014
    The fuckin' Blue Mountains brah
    Were you actually expecting rxtools and Pasta to work?
     
  14. Gadorach

    Gadorach Electronics Engineering Technologist

    Member
    958
    697
    Jan 22, 2014
    Canada
    Canada
    Lmao, smealum.net is getting tortured right now. I can't even connect to it, just times out.

    Yeah, both need to be modified to run on Ninjhax 2.0, and that porting is going to start with Brahma.

    Just thinking about it, but Ninjhax 2.0 is pretty much a replacement for the ARM11 hax (memchunkhax) we needed to set-up firmlaunchhax under <= 9.2. I wonder if 9.3 and 9.4 are fully exploitable now.
     
    Last edited by Gadorach, Jul 18, 2015
  15. Feroz El Mejor

    Feroz El Mejor GBAtemp Fan

    Member
    326
    68
    Jan 26, 2014
    Spain
    Villa RaĆ­z (Hoenn)
    And 9.5.0-22? (Not the -23 version)
     
  16. Gadorach

    Gadorach Electronics Engineering Technologist

    Member
    958
    697
    Jan 22, 2014
    Canada
    Canada
    firmlaunch-hax was fixed in 9.5.0, so that wouldn't be feasible.
     
  17. MRJPGames

    MRJPGames Pretty great guy

    Member
    1,111
    717
    Aug 17, 2013
    Netherlands
    The Netherlands
    Yeah I had to downgrade to ninjhax 1.1b as shame as 2.0 is much faster on N3DS, but I'm just a dirty pirate so I guess I just need Pasta... (installed 2.0 on a cia version so I have both now XD)