Newly purchased 3in1+ SRAM battery seems to be dead

Discussion in 'GBA - Flashing Hardware and Software' started by pcmantinker, Jul 6, 2009.

  1. pcmantinker
    OP

    Newcomer pcmantinker Advanced Member

    Joined:
    May 4, 2009
    Messages:
    73
    Location:
    Greater Atlanta Area
    Country:
    United States
    I recently purchased an EZ Flash 3in1+ from Leetmod and I can't save any gameboy advance games with or without patching. I've used GBATA and the EZ4 client software to patch the roms. I have tried GBAExploader 0.58b, GBAldr .1 modded for 3in1 plus, and the built in loader from YSMenu, but saves do not stay in the SRAM. After doing some more troubleshooting, I decided to check the SRAM battery with a multimeter and it appears as though the battery is dead. Can I replace the original battery with another battery from another cartridge? Or should I order a specific type (in which case I'd probably just get another 3in1 cart)? Would this be something I could pick up from Radioshack and what are the specifications of the battery i.e voltage? I think the voltage may be something around 3-3.3v?

    Other than the SRAM not working currently, everything else works quite well. I am pleased with rumble support, opera browser, and the ability to load GBA games to PSRAM or NOR.
     
  2. how_do_i_do_that

    Member how_do_i_do_that Blue Wizard is about to die.

    Joined:
    May 16, 2008
    Messages:
    4,809
    Country:
    Antarctica
    If your playing pokemon games you HAVE TO RTC patch the game.

    Follow the link in my sig to the 3in1 and scroll down to the links, once there, there are links to every patch for almost every game that you need to get it working.

    If your battery IS dead, they gave you a defective one, according to your last statement this might not be the case. You can also follow the link to the solder free battery replacement guide.
     
  3. pcmantinker
    OP

    Newcomer pcmantinker Advanced Member

    Joined:
    May 4, 2009
    Messages:
    73
    Location:
    Greater Atlanta Area
    Country:
    United States
    Thanks for the help. I replaced the battery with a CR1220 from Radioshack and saves are now working. I think the battery was dead when they shipped the 3in1 to me. Oh well. It's working now.
     

Share This Page