Newly purchaed Acekard 2i goes to black screen with error

Discussion in 'Acekard' started by jbloggs, Jan 4, 2011.

  1. jbloggs
    OP

    jbloggs Member

    Newcomer
    43
    0
    Jul 10, 2008
    I just received a new Acekard 2i which I purchased from Lightake. After setting it up per the instruction in one of the sticky threads, I inserted the card into the DSi and upon turing on the DSi it immediately goes to a black screen with an error

    After reading around, it seems that it could be because my DSi is 1.4U and the Acekard 2i has not been updated as promised by Lightake on their site that it would be ( Last time I buy anything from Lightake.) OR maybe the card is bad. What action can I take next as I don't have the orig DS or the DS Lite? Is there away to find out if its actually a bad card?

    Help would be much appreciated.
     
  2. R A W R

    R A W R Member

    Newcomer
    27
    0
    Jan 4, 2011
    United States
    Its Not The Card Check Your Dsi Firmware If Its 1.4 Or Over Then You Need To Do The Fix You Only Get The Error Because Of Your Firmware Try Buying It From A Seller That Pre-Flashes It For 1.4 And Over
     
  3. jbloggs
    OP

    jbloggs Member

    Newcomer
    43
    0
    Jul 10, 2008
    Thanks. I did buy it from a seller (Lightake) who says that all Acekards 2i they sell from November have been updated to work with 1.4U (and above).
     
  4. R A W R

    R A W R Member

    Newcomer
    27
    0
    Jan 4, 2011
    United States
    Hmmmm What Does It Say On Your Dsi Does It Say Danny Phantom Or Alex Rider?
     
  5. aiRWaLKRe

    aiRWaLKRe GBAtemp Regular

    Member
    260
    3
    Sep 12, 2009
    United States
    Orlando
    If it is up dated try sticking it in the slot and lightly tap the card and it if seems to lose connection, saying no card inserted in ds, you might need to do the paper trick to it, I bought one of the first acekard 2i's and I need to do the paper trick to make the pcb contacts stay snug against the ds. Just search "acekard 2i paper trick"
     
  6. twiztidsinz

    twiztidsinz Taiju Yamada Fan

    Member
    4,981
    6
    Dec 23, 2008
    United States
    Don't have a DSi so I can't say for sure, but I think that error means that the card is blocked.
    You should just be able to update it to 1.4.1 using a DS/DSlite.

    It could also be bricked (it's not unheard of for these places not to test their cards after an update), which could be fixed by running the 1.4.1 "DSl" update from a DS/DSLite on a different card and swapping the in the AK2i when it says to.
     
  7. Fishaman P

    Fishaman P Speedrunner

    Member
    3,243
    507
    Jan 2, 2010
    United States
    Wisconsin
    Yeah. Use a DS Lite (or a DSi running FW 1.3 or below) and update it for the 1.4.1 AP. Then it should work.

    Alternatively, shutdown the DSi, re-insert the AK2i, and try again. Sometimes my legit SoulSilver does that for no reason too.
     
  8. GMTN

    GMTN Member

    Newcomer
    25
    0
    Jul 31, 2010
    Canada
    I'm a new customer there and I had the same problem. It's the translation. What they mean is, it CAN be updated to work, but they didn't do it.

    I also had another from lighttake that didn't work at all. They say they will send a replacement so we'll see.
     
  9. YayMii

    YayMii hi

    Member
    4,915
    423
    Jun 24, 2009
    Canada
    that place
    Does the icon on the DSi menu show the Acekard icon or a THQ game? If it says "Acekard 2i" in the menu, it's not updated. If it has Danny Phantom or Alex Rider in the DSi menu, then there's either a connection problem or the Acekard is dead. If you're using 1.4.1 though, only the Alex Rider Acekards should work.
     
  10. Lightake

    Lightake GBAtemp Regular

    Member
    110
    0
    Dec 23, 2010
    Switzerland
    China
    Acekard team told us new acekard 2i produced after October 2010 is compatible with 1.4.1 , but recently some buyer reported the acekard 2i they got from us needed to upgrade to work on 1.4.1 DSi . I think there are still some old acekard 2i remains in the market and our warehouse ... So OP please just upgrade the ak2i to 1.4.1 with NDS Lite . Sorry for the inconvenience.
     
  11. licit

    licit Newbie

    Newcomer
    1
    0
    Jan 9, 2011
    United States
    I ordered an Acekard2i from Lightake on Dec. 30. Got here today. Came pre-flashed 1.4.1. No problems at all. Everything is working great! Will order from them again.
     
  12. Invghost

    Invghost Advanced Member

    Newcomer
    85
    0
    Apr 10, 2009
    TC said he doesn't have a Lite or Phat.

    The only way to fix it is to rent one from a video store, borrow one from a friend or buy one and then take it back for a refund.
     
  13. KingLord

    KingLord Newbie

    Newcomer
    1
    0
    Jul 18, 2006
    United States
    I didn't purchase from Lightake but I had exactly the same problem. I purchased a "Christmas Edition" Acekard 2i that claimed to be updated to work with 1.4 and over, but when they put it in their DSi it showed an Acekard 2i logo meaning it wasn't updated at all. I don't like how they packaged older Acekards in 2010 Christmas packaging to help move them out, where if I bought a "regular" edition I would have probably got a newer card. No friends with any systems I can update this card on, so I essentially gave a brick for Christmas. Guess I'll have to do the DS Lite purchase/return trick just to get this card to work. :\
     
  14. Lightake

    Lightake GBAtemp Regular

    Member
    110
    0
    Dec 23, 2010
    Switzerland
    China
    Thanks for your feed back . Some acekard 2i in our warehouse are pre-flashed and others are not .