Newest firmware and Supercard DSTWO?

Discussion in '3DS - Flashcards & Custom Firmwares' started by Wombo Combo, Apr 28, 2013.

  1. Wombo Combo
    OP

    Wombo Combo That Ain't Falco

    Member
    731
    136
    Mar 17, 2010
    United States
    I have a 3DS and planning on getting a Supercard DSTWO. (had one when I had a ds lite)

    Will DSTWO work on the most up to date firmware on 3ds and what would be the best place to buy one? Been so long since I bought a flashcard. Also would future 3ds updates be a problem for the dstwo?

    Thanks.
     
  2. GamerzHell9137

    GamerzHell9137 GBAtemp Psycho!

    Member
    3,833
    1,687
    Nov 1, 2011
    Bosnia and Herzegovina
    No, not at all.
    DSTWO can't be blocked by Nintendo, some people say.
    Best place to buy is http://www.nds-card.com/ cause its our sponsor and they update and test it before shipping.
     
  3. metroid maniac

    metroid maniac An idiot with an opinion

    Member
    1,800
    719
    May 16, 2009
    The DSTwo might be blocked. However, out of all flashcarts available, the DSTwo is least likely to be.
     
  4. babyface
    This message by babyface has been removed from public view by Costello, Jun 4, 2013.
    Apr 29, 2013
  5. FireGrey

    FireGrey Undercover Admin

    Member
    3,920
    909
    Apr 13, 2010
    It can be blocked, but all you need to do is install a patch on their site.