New SD card yet none of my games show

Discussion in '3DS - Flashcards & Custom Firmwares' started by bobfacemoo, Nov 15, 2016.

  1. bobfacemoo
    OP

    bobfacemoo GBAtemp Fan

    Member
    350
    62
    Feb 21, 2016
    I moved all my content from a 32GB to a 64GB (formatted as fat32). The DS reads it since I can boot Arm9 payloads, and shows my luma splash screen, yet none of my games are showing on my home menu. Running A9LH with Luma3DS 6.6. Any help?
     
  2. Mikemk

    Mikemk GBAtemp Advanced Maniac

    Member
    1,594
    583
    Mar 26, 2015
    United States
    Did you copy your games from the old card to the new?
     
  3. bobfacemoo
    OP

    bobfacemoo GBAtemp Fan

    Member
    350
    62
    Feb 21, 2016
    I copied literally every single file. It's using up 25GB of my 64GB SD card but none are showing.
     
  4. Essometer

    Essometer GBAtemp Fan

    Member
    315
    221
    Oct 22, 2010
    Germany
    Enger
    Is it showing with your old SD Card?
     
  5. bobfacemoo
    OP

    bobfacemoo GBAtemp Fan

    Member
    350
    62
    Feb 21, 2016
    Yep, it's still perfectly working with my old SD card.
     
  6. xtheman

    xtheman GBAtemp Guru

    Member
    5,847
    5,280
    Jan 28, 2016
    United States
    Are you using emunand? You need to trasfer that too.
     
  7. bobfacemoo
    OP

    bobfacemoo GBAtemp Fan

    Member
    350
    62
    Feb 21, 2016
    Nope, sysNAND.
     
  8. xtheman

    xtheman GBAtemp Guru

    Member
    5,847
    5,280
    Jan 28, 2016
    United States
    Is the sd card formatted to fat32?
     
  9. bobfacemoo
    OP

    bobfacemoo GBAtemp Fan

    Member
    350
    62
    Feb 21, 2016
    I said that in the OP.
     
  10. 0x40

    0x40 GBAtemp Regular

    Member
    234
    65
    Apr 20, 2013
    Does it detect the SD if you go to Settings > Data Settings > 3DS > 3DS Software?
     
  11. bobfacemoo
    OP

    bobfacemoo GBAtemp Fan

    Member
    350
    62
    Feb 21, 2016
    Yep, but it's showing nothing.
     
  12. kurocygnus

    kurocygnus Advanced Member

    Newcomer
    87
    18
    May 22, 2015
    Brazil
    You can't copy directly, because the new sd card will have another ID inside the Nintendo 3DS path. You need to copy the content from SD/Nintendo 3DS/<id>/<id2> to the new one. You'll notice that's a different ID from the old SD card. Don't forget to copy the titleid.db too.
     
  13. bobfacemoo
    OP

    bobfacemoo GBAtemp Fan

    Member
    350
    62
    Feb 21, 2016
    Ahhh makes sense. I'll see if this works. I thought new IDs only occurred on a system format.
     
  14. Redferne

    Redferne GBAtemp Advanced Fan

    Member
    777
    260
    Oct 28, 2015
    Stupid question, but are you trying on the same console?
    No, I did the same as OP and everything went fine.
     
  15. bobfacemoo
    OP

    bobfacemoo GBAtemp Fan

    Member
    350
    62
    Feb 21, 2016
    Yes, I only own one 3DS xD
     
  16. 0x40

    0x40 GBAtemp Regular

    Member
    234
    65
    Apr 20, 2013
    Why would the id change? Unless the system was formatted, it shouldn't be a problem.

    Try replacing title.db and import.db with empty files (back them up first) to test if it regenerates the db.
     
  17. Redferne

    Redferne GBAtemp Advanced Fan

    Member
    777
    260
    Oct 28, 2015
    Like kurocygnus said I thought the path for your ID changed but that should not occur in your case...
    As I said, I did the exact same thing and I had no issue.
     
  18. bobfacemoo
    OP

    bobfacemoo GBAtemp Fan

    Member
    350
    62
    Feb 21, 2016
    I reformatted my SD card (64GB) and it seems it DOES create a new folder ID as ID2 in Nintendo 3DS folder. Going to copy the data into the new folder and see what happens.
     
  19. bobfacemoo
    OP

    bobfacemoo GBAtemp Fan

    Member
    350
    62
    Feb 21, 2016
    Yes, it's fixed now. All I had to do was move everything into the new ID folder and works like a charm. Thanks for everyone's help!
     
    kurocygnus likes this.
  20. kurocygnus

    kurocygnus Advanced Member

    Newcomer
    87
    18
    May 22, 2015
    Brazil
    Good to know it worked! That happened to me last week too XD