New DSTWO runs great, but NDS player not working...

Discussion in 'Supercard' started by hooster, Oct 11, 2014.

  1. hooster
    OP

    hooster Newbie

    Newcomer
    8
    0
    Oct 11, 2014
    United States
    Hi,

    Just got my DSTWO and I'm having a very strange problem where all my major emulators work (GBA, CATSFC, Genesis, etc.), but when running an NDS game, my dual screens just go white.

    I don't know if ROM formats have been updated but these NDS ROMs still work fine on the M3Lite on my DSLite.

    I'm using a SANDISK Ultra 64GB Class 10 SDXC formatted with fat32formatter, on a Super Mario Bros. 25th Anniversary DSi XL unit.

    DSTwo plastic housing also kinda coming apart... yechh...

    Advice? Similar experiences? Should I return it?
     
  2. Digitsie

    Digitsie Advanced Member

    Newcomer
    91
    1
    Sep 15, 2014
    United States
    How up-to-date is the firmware and software? You got the latest versions?
     
  3. hooster
    OP

    hooster Newbie

    Newcomer
    8
    0
    Oct 11, 2014
    United States
    Thanks for asking.

    The DSTWO firmware is v1.25, the latest one, which supports DSi 1.45 and 3DS 8.1.10-19x, and the EOS is the latest v1.11_2012_1212 released on 12-24-2012.

    My Anniversay Edition DSi XL is version 1.4U.
     
  4. Yepi69

    Yepi69 Vivid and busy gamer

    Member
    2,421
    1,018
    Nov 29, 2010
    Portugal
    Behind you
    Are you running the games in Clean mode or Patch mode?
    Do you have cheat codes activated in such games?
    Corrupt NDS save files often tend to prevent the game from opening (happened to me on WarioWare D.I.Y)
     
  5. hooster
    OP

    hooster Newbie

    Newcomer
    8
    0
    Oct 11, 2014
    United States
    Clean mode selected from the DSTWO menu, Cheat codes OFF in the DSTWO menu, Multisave set to 0, save files moved into a seperate directory on the flashcard.

    It still only loads to two white screens when I click on them.

    Another interesting note, my NDS games show up with corrupted icons: http://i.imgur.com/O40Hx6y.jpg
     
  6. Digitsie

    Digitsie Advanced Member

    Newcomer
    91
    1
    Sep 15, 2014
    United States
    Have you given it a shot with a different SD or a newly formatted SD?
     
  7. hooster
    OP

    hooster Newbie

    Newcomer
    8
    0
    Oct 11, 2014
    United States
    Resolved. The NDS files were too "old"; from too long ago. Found new versions of same ones and they worked flawlessly.