Question New 6.0 Games on 4.1.0?

Discussion in 'Switch - Exploits, Custom Firmwares & Soft Mods' started by Marax, Oct 6, 2018.

  1. Marax
    OP

    Marax Member

    Newcomer
    1
    May 19, 2017
    Gambia, The
    Hello,

    I have a Question about the new 6.0 Games.

    I have a NSP from the new M Party.

    My Switch is on 4.1.0

    Tinfoil says that the game requires a newer FW.

    Is there any way to Bypass that ?
     
  2. Kubas_inko

    Kubas_inko "Something funny goes here."

    Member
    13
    Feb 3, 2017
    Czech Republic
    I gues on earth.
    Tinfoil is able to ignore the version, but idk how does that actually works.
     
  3. Sharinflan

    Sharinflan

    Member
    3
    Jan 2, 2016
    Portugal
    I tried it before and it just gave me an error.
    Just update using ChoiDoujourNX and add autoRCM so that you don't burn the fuses. I would advise to update to 5.1.0, since I believe 6.0 still has a few problems here and there.
     
  4. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    18
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Mar 17, 2010
    Norway
    Alola
    Probably not on 4.1 I would guess. I've heard that 6.0 games don't use new encryption keys, but even if they use the encryption keys from 5.x you'd have to update to at least that firmware.
     
  5. Marax
    OP

    Marax Member

    Newcomer
    1
    May 19, 2017
    Gambia, The
    Okay then at least i need to Update for the new Pokemon with ChoiDoujourNX.
     
  6. Taorn

    Taorn GBAtemp Regular

    Member
    3
    May 27, 2017
    United States
    Mario Party does not need 6. 5 is fine. You will need to update your Switch at least to that version.
     
    Last edited by Taorn, Oct 6, 2018
    Erol likes this.
  7. CrAzYLiFe

    CrAzYLiFe Advanced Member

    Newcomer
    3
    Aug 4, 2007
    Australia
    Australia
    Does need 6? Its working fine on 5.0.2 for me..
     
  8. Taorn

    Taorn GBAtemp Regular

    Member
    3
    May 27, 2017
    United States
    Missing a not in that sentence.
     
    CrAzYLiFe likes this.
  9. subcon959

    subcon959 teh retro

    Member
    12
    Dec 24, 2008
    I haven't heard of any games that require 6.0 yet (only the latest updates to older games).
     
  10. Kubas_inko

    Kubas_inko "Something funny goes here."

    Member
    13
    Feb 3, 2017
    Czech Republic
    I gues on earth.
    some updated apparently require 6.0, but no games yet.
     
    x65943 and fr33x74 like this.
  11. chippy

    chippy GBAtemp Regular

    Member
    4
    Dec 21, 2017
    Australia
    The updates your referring to have 6.0 in their xml files for version required but are encrypted by the 5.1 key
    So tinfoil's ignore version Just ignores the xml line for version and try's to decript it with the system keys your system has
     
    thaikhoa and Draxzelex like this.
  12. loon111

    loon111 GBAtemp Regular

    Member
    4
    Feb 4, 2007
    Hi , mine is on 5.1 or something, an i use sx pro, is it safe to update online? Or shall i stay as am u think?

    Regards
     
  13. Ashura66

    Ashura66 GBAtemp Advanced Maniac

    Member
    6
    Feb 1, 2016
    Portugal
    Under my bed
    Depends on what version of SX you're using. If you're using 2.0 then stay as you are
     
  14. Marax
    OP

    Marax Member

    Newcomer
    1
    May 19, 2017
    Gambia, The
    Iam scared to Burn fuses... But for the new Pokemon Games i would use ChoiDujourNX
     
  15. tNz

    tNz Newbie

    Newcomer
    1
    Aug 4, 2018
    Germany
    How is it work? Can I downgrade, after install to 5.1 with ChoiDujourNX?
     
  16. Sharinflan

    Sharinflan

    Member
    3
    Jan 2, 2016
    Portugal
    Yes, but it involves a complicated process where you have to mount the file system. Just update, apply autoRCM and forget.
     
  17. Bigjokker

    Bigjokker GBAtemp Regular

    Member
    3
    Jan 4, 2015
    United States
    You can try repacking game with hacpack. Was told would remove firmware requirement. I'm on 6.0 so haven't tested.
     
    Last edited by Bigjokker, Oct 7, 2018
    loler55 likes this.
  18. Bigjokker
    This message by Bigjokker has been removed from public view by Joe88, Oct 7, 2018.
    Oct 7, 2018
  19. Draxzelex

    Draxzelex GBAtemp Guru

    Member
    17
    Aug 6, 2017
    United States
    New York City
    It can remove the masterkey encryption on higher firmwares but not for other files such as the .NSO which is most likely hardcoded to run on higher firmwares. I tried rebuilding Freedom Planet for firmware 4.1 but was unable to run it because of the .NSO file requiring firmware 5.X
     
    loler55 likes this.
  20. Bigjokker

    Bigjokker GBAtemp Regular

    Member
    3
    Jan 4, 2015
    United States
    Talking to @The-4n he said the main file doesn't contain any firmware requirements but if the game uses a feature added to the new firmware it will crash.
     
  21. smf

    smf GBAtemp Addict

    Member
    8
    Feb 23, 2009
    Going into the manual on sonic wouldn't work until I updated to 6, but the game worked fine.

    I suspect it's more to do with it being a separate application and tinfoil doesn't change it, than encryption related though.
     
    loler55 likes this.
  22. loler55

    loler55 GBAtemp Advanced Fan

    Member
    5
    Jan 4, 2012
    Gambia, The
    Ohh eventually i can use this to play toad on 3.01;) since sx os 2.0 is broken
     
    Last edited by loler55, Oct 7, 2018
Loading...