Network problems regarding deleting

Discussion in 'Computer Games and General Discussion' started by Harsky, Jul 20, 2008.

Jul 20, 2008
  1. Harsky
    OP

    Member Harsky Madmin

    Joined:
    Aug 2, 2004
    Messages:
    5,262
    Country:
    United Kingdom
    My home PC uses XP and since it's connected to a wireless router, I can use my Vista Laptop to access some of the files on the home PC. The only problem is that when I try to delete, copy/paste certain files it gives me a "NEEDS PERMISSION" message. Is there a way to disable this?
     
  2. fischju

    Member fischju Rehabilitated Jaywalker

    Joined:
    Jan 11, 2008
    Messages:
    1,940
    Country:
    United States
    Yes, find the drive/folder you are sharing and change the properties to allow modification
     
  3. Harsky
    OP

    Member Harsky Madmin

    Joined:
    Aug 2, 2004
    Messages:
    5,262
    Country:
    United Kingdom
    I went to my PC with XP and enabled the "allow users to modify" option but it still comes up with the "need permission" message when I try to copy/paste or delete on my vista laptop
     
  4. Lee79

    Member Lee79 Hyper...Active...Team Fortress 2 Addict

    Joined:
    Jul 29, 2007
    Messages:
    920
    Location:
    ctf_2fort
    Country:
    United Kingdom
    I think if I remember correctly you have to take ownership of the files on the Vista machine. Navigate to the Folder or Files you want to edit right click and select Properties. In the properties window, select Security Tab, Click the Advanced button in the Security tab. In the Advanced Security Settings, select Owner tab. Here you can view the current owner of the file and also the option to change owner. Click the Edit button at the bottom. Then you can select the new owner of the file which would be your Vista login and apply the settings. You get a security warning that you need to close the file and open it again for settings to take place. Now the ownership of file is changed to your vista user and you can edit them freely. Please note only users belonging the administrator group can take ownership on any windows file according to the default group policy on windows vista. So you need to be an administrator to take ownership.
     
  5. Harsky
    OP

    Member Harsky Madmin

    Joined:
    Aug 2, 2004
    Messages:
    5,262
    Country:
    United Kingdom
    '
    I get to the "Click the Edit button at the bottom. Then you can select the new owner of the file which would be your Vista login and apply the settings" but when I try to click okay, it gives me Access is denied message. I am the admin for the laptop so I don't know what else to do.
     
  6. fischju

    Member fischju Rehabilitated Jaywalker

    Joined:
    Jan 11, 2008
    Messages:
    1,940
    Country:
    United States
    Does your admin account have a password?
     
  7. Lee79

    Member Lee79 Hyper...Active...Team Fortress 2 Addict

    Joined:
    Jul 29, 2007
    Messages:
    920
    Location:
    ctf_2fort
    Country:
    United Kingdom
    You must have on both machines the same username with a matching password and admin rights. no blank password.
     
  8. Harsky
    OP

    Member Harsky Madmin

    Joined:
    Aug 2, 2004
    Messages:
    5,262
    Country:
    United Kingdom
    Yeah. Realised that the PC I'm using has a different account name than the one on my laptop. Is a password really that necessary since I never really use it to log onto my account.
     
  9. Lee79

    Member Lee79 Hyper...Active...Team Fortress 2 Addict

    Joined:
    Jul 29, 2007
    Messages:
    920
    Location:
    ctf_2fort
    Country:
    United Kingdom
    Not sure try it. I am just telling you what I have been told by my friend who is using vista. I only use XP as i did not like vista.
     
  10. Harsky
    OP

    Member Harsky Madmin

    Joined:
    Aug 2, 2004
    Messages:
    5,262
    Country:
    United Kingdom
    This is a really, really silly question but how do I change the account name? I went to Settings, User Account and then changed the username to the same one as my laptop but even after restarting the PC, it still shows my old account name.
     
  11. Lee79

    Member Lee79 Hyper...Active...Team Fortress 2 Addict

    Joined:
    Jul 29, 2007
    Messages:
    920
    Location:
    ctf_2fort
    Country:
    United Kingdom
    On XP Pro (not sure about Home). Control Panel, Administrative Tools, Computer Management, Local Users and Groups, Users, Right Click the Account to change then Properties then edit "Full Name".
     
  12. Harsky
    OP

    Member Harsky Madmin

    Joined:
    Aug 2, 2004
    Messages:
    5,262
    Country:
    United Kingdom
    Crap. I'm on Home XPand I can't see Local Users and Groups
     
  13. Lee79

    Member Lee79 Hyper...Active...Team Fortress 2 Addict

    Joined:
    Jul 29, 2007
    Messages:
    920
    Location:
    ctf_2fort
    Country:
    United Kingdom

Share This Page