NES emulator working with R4

Discussion in 'R4 DS' started by Modrak, Feb 25, 2007.

  1. Modrak
    OP

    Modrak GBAtemp Regular

    Member
    158
    0
    Dec 14, 2006
    There are 2 as I recall...

    NesterDS and nesDS. Or do you know any more ?

    When I had my SuperCard Lite, nesDS was working OK for me, listing ROMs, sound worked fine. But neither of those support DLDI so I think we're screwed here.
    Haven't tried NesterDS before, but if it uses old fatlib, someone could recompile it with new fatlib interface that supports DLDI ?
    And placing the ROMs into the nesDS .nds files isn't too convinient - even more complicated on a mac.
    edit: rom_inserter.exe makes me scared that it does not use fatlib at all :'(
     
  2. XeroRestraint

    XeroRestraint GBAtemp Regular

    Member
    111
    0
    Jan 29, 2007
    United States
    nesDS works fine with DLDI on the R4 for me (just patch the .nds file of the compiled NES roms). Haven't found a way around using windows to compile the NES roms but I always use the simple elegance of DLDI Drop on the Mac to patch homebrew.

    As for compatibility - it works pretty well. I've only rested it with a handful of games but most run well with an occasional glitchy game. AFAIK save states are not supported for Slot-1/DLDI.


    Also, it appears nesDS appears to have ceased development as a new version hasn't been released since 2005.
     
  3. Slippy

    Slippy Advanced Member

    Newcomer
    75
    0
    Dec 9, 2005
    United States
    NE USA
    There is no need to patch nesds with DLDI. DLDI patching doesn't add anything to nesds since nesds wasn't written to support it.
     
  4. Modrak
    OP

    Modrak GBAtemp Regular

    Member
    158
    0
    Dec 14, 2006

    Yup, I was confused about the nonsense he was talking about.
    So mac users are, as usual, screwed [​IMG]