RELEASE Nereba Exploit: Reboot to Fusée Gelée payload from stock firmware.

Discussion in 'Switch - Exploits, Custom Firmwares & Soft Mods' started by Deleted-442439, Apr 19, 2019.

  1. gnmmarechal

    gnmmarechal GBAtemp Guru

    Member
    14
    GBAtemp Patron
    gnmmarechal is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Jul 13, 2014
    Portugal
    https://gs2012.xyz
    Meh, not too interested in this.
     
  2. DarknessPlay3r

    DarknessPlay3r Member

    Newcomer
    3
    Jan 27, 2019
    Canada
    I'm glad I updated from 3.0 with out burning my fuses. Once emunand and this exploit are ready I'll be dongle less on one of my switches.
     
  3. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    19
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Mar 17, 2010
    Norway
    Alola
    Maybe because you spelled it wrong. It's Nereba.
     
    x65943 likes this.
  4. Nerdtendo

    Nerdtendo Your friendly neighborhood idiot

    Member
    8
    Sep 29, 2016
    United States
    I got an extra switch I keep updated but now that my sd card reader went beserk on my hacked switch, i regret that.
     
  5. Deathscreton

    Deathscreton GBAtemp Advanced Fan

    Member
    7
    Oct 1, 2009
    United States
    Couldn't I just downgrade from 7.0.1 to 1.0.0 and bypass the fuse checks with hekate, essentially allowing me to use this tool?
     
  6. Milenko

    Milenko GBAtemp Advanced Maniac

    Member
    10
    Oct 16, 2017
    Australia
    Ok it boots into atmosphere now

     
  7. Xandroz

    Xandroz GBAtemp Advanced Fan

    Member
    6
    Mar 19, 2018
    Egypt
    time to revive my 1.0
     
  8. sj33

    sj33 GBAtemp Psycho!

    Member
    13
    Oct 22, 2013
    Japan
    But what on earth would be the point? If you've got hekate loaded, you can already load CFW.
     
  9. Deathscreton

    Deathscreton GBAtemp Advanced Fan

    Member
    7
    Oct 1, 2009
    United States
    For those that don't want AutoRCM/A dongle to push RCM payloads. Cuts out a step. Same reason those who were on 1.0.0 upgraded without burning any fuses (Because initially, the step for bypassing fuse checks completely/downgrading wasn't available).
     
  10. deSSy2724

    deSSy2724 GBAtemp Fan

    Member
    4
    Sep 11, 2015
    Germany
    What do they mean exactly by "In addition support for 2.x and 3.x firmware is also planned in the future, opening up the exploit to significantly more consoles."?`Does it means that it wouldnt require any dongle/jig in the future for 2.x - 3.x firmwares as well or did I misunderstood something here because I remember they were saying its possible only on 1.0.

    My Switch is still between 2.x - 3.0.......
     
  11. snoofly

    snoofly GBAtemp Advanced Fan

    Member
    8
    Aug 18, 2015
    United Kingdom
    wait what?
    this sounds awesome.
    gonna try this a bit later on

    but let me be clear.
    so i don’t need a pc to run this, i can just boot stock 1.0 with a properly set sd then run album and i could reboot into sx os emunand?
     
  12. sj33

    sj33 GBAtemp Psycho!

    Member
    13
    Oct 22, 2013
    Japan
    But you would still need a dongle or USB connection to send hekate every time in order to skip the fuse check and actually load 1.0. Without that, you'll just get black screen at boot.
     
  13. Xandroz

    Xandroz GBAtemp Advanced Fan

    Member
    6
    Mar 19, 2018
    Egypt
    so untill i fix my 1.0 as it needs a replacement screen socket, anyway i can install pegaswitch without puyo.
    or can i just use a dongol and jig to install it as nsp and install pega from there
     
  14. sj33

    sj33 GBAtemp Psycho!

    Member
    13
    Oct 22, 2013
    Japan
    Yes and no. You won't be able to downgrade unless you prevented burning fuses in the first place.
     
  15. Deathscreton

    Deathscreton GBAtemp Advanced Fan

    Member
    7
    Oct 1, 2009
    United States
    So push Hekate instead?

    EDIT: I see what you mean now. I misunderstood. Can't boot into 1.0.0 with burnt fuses meaning loading into 1.0.0 just to boot CFW doesn't make sense. My bad.

    — Posts automatically merged - Please don't double post! —

    You can downgrade with burnt fuses so long as you use hekate.

    Either you or I have a terrible understanding of how this works.

    EDIT: This still stands though. You can move between firmwares using Choi and Hekate, but it doesn't make much sense to move downwards past burnt fuses since you'd have to use Hekate anyways (as you explained to me earlier).
     
    Last edited by Deathscreton, Apr 19, 2019 - Reason: Conceding.
  16. Milenko

    Milenko GBAtemp Advanced Maniac

    Member
    10
    Oct 16, 2017
    Australia
    Yeah but you need a usb to even load 1.0.0 in the first place so it's pointless
     
  17. sj33

    sj33 GBAtemp Psycho!

    Member
    13
    Oct 22, 2013
    Japan
    But if you're going to be pushing hekate anyway, why do you need Nereba?
     
    Milenko likes this.
  18. Milenko

    Milenko GBAtemp Advanced Maniac

    Member
    10
    Oct 16, 2017
    Australia
    It sounds like it works, downgrade to 1.0.0 and use Nereba but if your fuses don't match you need to push a payload through USB to even load 1.0.0 so you may as well just use the current RCM way
     
  19. seanp2500

    seanp2500 GBAtemp Advanced Fan

    Member
    6
    Jun 2, 2010
    United States
    I think this is really cool in the sense it finally was released but here is my take.

    We were made aware to hold off on updating that there would be new developments. But aside from piracy the draw to modding my switch was homebrew. If i had waited in this case i would have missed out on all the fun i had playing the various homebrew. I would have also had to do a lot of catching up in terms of config and bios files etc. At this point i have a very impressive system and that would not have happened if I had waited for this. Frankly i feel the people who did wait missed out and continue to miss out. This is similar to someone on ps4 scene waiting for cfw. “Gotta learn when to hold them learn when to fold them...”
     
    peteruk and Zaybokk like this.
  20. sj33

    sj33 GBAtemp Psycho!

    Member
    13
    Oct 22, 2013
    Japan
    Well, this release is clearly aimed at devs or other people who specifically need a 1.0 device but don't possess the exploit themselves. This presumably arrived now because the final part of the exploit chain was patched in 1.0. Presumably those same parts will be in Deja Vu.
     
Quick Reply
OP
Draft saved Draft deleted
Loading...