need udisk version 1.45!

Discussion in 'Other Flashing Hardware & Software' started by madelinelew, Oct 13, 2007.

  1. madelinelew
    OP

    madelinelew Newbie

    Newcomer
    3
    0
    Oct 13, 2007
    Senegal
    While transferring new games into the device, i accidentally deleted the xmenu.dat icon. So later, when I tried running the whole device again, it said that its needs an xmenu.dat format.

    So I downloaded one from the net and the next problem was that it required a version 1.45 udisk. I tried downloading it from the net and transferring it into the dslinker several times.

    But the system keep saying "need udisk version 1.45!" after a white screen appears, any suggestion on how to solve this problem?
     
  2. paul1991

    paul1991 Banned

    Banned
    680
    0
    May 5, 2007
    United States
    Not to be patronizing, but are you getting the xmenu.dat from the 1.45 upgrade file?
    Heres a link: http://gbatemp.net/index.php?download=825
    You just need the xmenu out of that file. Ignore everything else.
     
  3. madelinelew
    OP

    madelinelew Newbie

    Newcomer
    3
    0
    Oct 13, 2007
    Senegal
    ya i am getting the xmenu from that file cause i dont know where else i can get that file. sorry kinda noob here. but how do i xmenu out ot it?
     
  4. zombielove

    zombielove GBAtemp Regular

    Member
    270
    0
    Jun 3, 2007
    Did you put xmenu.dat in the DSYSTEM folder?
     
  5. madelinelew
    OP

    madelinelew Newbie

    Newcomer
    3
    0
    Oct 13, 2007
    Senegal
    hmm..if i put the xmenu.dat into the Dsystem folder, switch on and try everything again, the system will say that there is no xmenu.dat format. so i transferred it out into the main USB folder again, and the device tells me that I need udisk version 1.45. hows?
     
  6. monkey_banana17

    monkey_banana17 Newbie

    Newcomer
    2
    0
    Apr 9, 2008
    hi! im new here.. anyway, i have the same problem. at first when i accidentally deleted the xmenu.dat file, i downloaded a new one (like the ones suggested in this website) but then when i pasted it into my ncard and open it in my ds the "need udisk version 1.45!" message appears! i'm really frustrated now:( please i need help.. i'm not really good at this so please kindly give me a step by step instruction.. thanks! [​IMG]
     
  7. glowy

    glowy Advanced Member

    Newcomer
    97
    0
    May 18, 2007
    Netherlands
    The "need udisk 1.45" message means you have the wrong firmware version, you need to upgrade your card to the 1.45 version.
     
  8. leinad

    leinad GBAtemp Fan

    Member
    409
    3
    Apr 30, 2007
    Gambia, The
    The xmenu.dat's are only compatible with a specific udisk version.
    Go into USB Mode, you will get displayed your installed udisk version.
    Now go to the Download database, search for the firmware with that UDisk Vers.
    Download the archive and then copy the xmenu.dat of that archive to your card.

    Or else you can upgrade to the newest firmware, but if your satisfield with the card I wouldn't recomment it, since there is always a small risk of bricking your card.