Question Need to update Switch firmware to play Mario Kart 8 Deluxe ? And game to update to 2.0.0?

Discussion in 'Switch - Hacking & Homebrew' started by nicko, May 5, 2017.

  1. nicko
    OP

    nicko GBATemp Ha Do Ken

    Member
    558
    1
    Oct 24, 2002
    France
    France
    Hi all,

    I've just bought a Nintendo Switch in France with 1.0.0 out of the box.

    I'm planning to buy Mario Kart 8 Deluxe and first question is : will I have to update Switch firmware to play this game?

    Another thing I'd like to know is if there's a game that will update Switch to 2.0.0?
    If no, which is current Switch firmware? Then should I update to this firmware?

    Thanks for all your answers!
     
  2. badpix11

    badpix11 Member

    Newcomer
    12
    6
    Mar 14, 2017
    Serbia, Republic of
    Fairy World
    No
    No
    2.2.0
    Yes
     
    nicko likes this.
  3. nicko
    OP

    nicko GBATemp Ha Do Ken

    Member
    558
    1
    Oct 24, 2002
    France
    France
    But with 2.2.0, it seems I will not have access to the 2.0.0 hack.

    What are the advantages then please?:wacko:
     
  4. ut2k4master

    ut2k4master Lord Tourettes

    Member
    797
    353
    Feb 20, 2010
    Germany
    there is no 2.0.0 hack at the moment anyway and you cant do anything at 1.0.0. if youre still on 1.0.0, update to the latest firmware and stay on that one
     
    Alkéryn likes this.
  5. lefthandsword

    lefthandsword GBAtemp Fan

    Member
    337
    205
    Apr 6, 2015
    Hong Kong
    root
    Just update and enjoy your console as intended by Nintendo for now, the 2.0 exploit is useless for end users and we're probably months or years away from proper home-brew.

    I hope I could just hide this section of GBATemp until something comes out
     
    Last edited by lefthandsword, May 5, 2017
    McWhiters9511, MeAndHax and Alkéryn like this.
  6. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    12,087
    5,165
    Mar 17, 2010
    Norway
    Alola
    It might require a higher firmware, I don't know.
    But keep in mind that online isn't enabled on 1.0.0, so you won't be able to play online, and it has no browser, so it's completely useless for hacks.
     
  7. nicko
    OP

    nicko GBATemp Ha Do Ken

    Member
    558
    1
    Oct 24, 2002
    France
    France
    Thanks all for your answers.
    Update to 2.2.0 done :yayswitch:
     
  8. Alkéryn

    Alkéryn Moon Dweller ~

    Member
    1,521
    1,909
    Mar 15, 2015
    France
    Albategnius, Moon
    Months away

    And for the topic
    just update your switch and stay on 2.2
    because even when it will be hacked it will be on the latest version at the time of release
     
  9. lefthandsword

    lefthandsword GBAtemp Fan

    Member
    337
    205
    Apr 6, 2015
    Hong Kong
    root
    MK8D works on 1.0
    IMG_0349.PNG
     
  10. Noctosphere

    Noctosphere Moon furries | Official follower of Skiddon't-ism

    Member
    2,062
    1,984
    Dec 30, 2013
    Canada
    Between three furries women
    not really
    hackers dont release their exploit right when they find it.
    For exemple, they said : STAY ON 9.0 (on 3ds) WE HAVE AN EXPLOIT FOR IT
    thenj 9.1 gotr released, they said : YOU CAN UPDATE THE EXPLOIT HASNT BEEN FIXED
    same thing with 9.2
    then at 9.3 they said : DONT UPDATE THE EXPLOIT HAS BEEN FIXED
    but it still took few month before they release the exploit allowing hacks.
    theres a big difference between exploit and hacks and i think you meant exploit, not hack
     
  11. punderino

    punderino aka Big-Dick Swinger

    Member
    895
    487
    Jan 5, 2016
    United States
    Kansas City, Missouri
    If your system is on 1.0.0, you have to update to 2.2.0 to go online. I'm on 2.0.0 and am able to play online just fine.