Need some help setting up A9LHX and Luma3DS on old XL

Discussion in '3DS - Flashcards & Custom Firmwares' started by ChaosBoi, Oct 31, 2016.

  1. ChaosBoi
    OP

    ChaosBoi Ushiromiya Battler

    Member
    1,339
    60
    Feb 19, 2007
    United States
    California
    https://plailect.github.io/Guide/installing-arm9loaderhax

    So, I'm following the guide in the link above. I've gotten everything set up until step 6 of section III, where it says to update the system firmware through settings. Every time I try to update my 3DS, it tells me it can't update. I also tried restoring my NAND as the guide suggested (Hourglass9 tells me it's successfull), and it still gives me an error when I try to update (for the record I tried to update from my 4.2 backup after restoring sysNAND because the guide wasn't clear if I had to go back to 2.1 again).

    Is there another way to go about this? Do I need to go back to 2.1 before attempting the update again?
     
  2. proflayton123

    proflayton123 悲しみ

    Member
    5,604
    2,052
    Jan 11, 2016
    Japan
    日本
    Has you used Gateway DG Tool previously? That can cause the NAND to become fragmented
     
  3. ChaosBoi
    OP

    ChaosBoi Ushiromiya Battler

    Member
    1,339
    60
    Feb 19, 2007
    United States
    California
    If you mean the downgrader, yeah. My 3DS used to be on 9.2 before I downgraded it to 4.2
     
  4. ov3rkill

    ov3rkill GBAtemp Advanced Fan

    Member
    947
    330
    May 10, 2009
    Maybe you still have tubehax dns. Remove it.
    Or maybe you block nintendo updates from your firewall or something.
     
  5. ThisIsDaAccount

    ThisIsDaAccount GBAtemp Fan

    Member
    457
    175
    Apr 8, 2016
    United States
    Are you currently on 9.2?
     
  6. ChaosBoi
    OP

    ChaosBoi Ushiromiya Battler

    Member
    1,339
    60
    Feb 19, 2007
    United States
    California
    @ov3rkill I've never used tubehax. DNS was always on auto, and I've never used any methods to block Nintendo updates beforr (that I'm aware of).

    @ThisIsDaAccount I couldn't get it to update at all so I used a 9.2 crt transfer or whatever it was called (not at my computer so can't remember exact name). It's at least letting play some games I couldn't play before, but I'd still like it to be at the highest compatible firmware as possible.
     
  7. Ominous66521

    Ominous66521 GBAtemp Maniac

    Member
    1,046
    233
    Feb 7, 2016
    United States
    Seems like the only way to fix this is to mabe inject your previous emunand to the sysnand if you had the latest firmware on it.Some 3ds's can't update after the 2.1 downgrade so that's to be expected.
     
  8. ThisIsDaAccount

    ThisIsDaAccount GBAtemp Fan

    Member
    457
    175
    Apr 8, 2016
    United States
    The culprit for the problem was the gateway downgrade you've done in the past, because the method they use apparently tends to fragment NANDs. There's a way to fix it by reinstalling certain titles, I'm looking for it.

    Edit: Were you able to get FBI injected into health and safety?
     
    Last edited by ThisIsDaAccount, Nov 6, 2016
  9. ChaosBoi
    OP

    ChaosBoi Ushiromiya Battler

    Member
    1,339
    60
    Feb 19, 2007
    United States
    California
    @ThisIsDaAccount Apologies for the late reply because I've been pretty busy lately, but yeah, I can inject FBI and install cia files just fine. It's just updating the system firmware that seems to be the only problem I'm having.