Need help with vWii gc adapter for project M

Discussion in 'Wii U - Homebrew' started by ada010, Mar 7, 2018.

  1. JacobM

    JacobM GBAtemp Regular

    Member
    1
    Jun 16, 2017
    United States
    3 different versions have been confirmed working using GeckoOS+disc. GPF (original), gameconfig.txt (based on original), and GCT (latest)

    I won't have my disc until Monday, but GeckoOS has been tested by the developer and other users.
     
    Last edited by JacobM, Mar 14, 2018
  2. cruplezone

    cruplezone GBAtemp Fan

    Member
    2
    Feb 3, 2014
    Canada
    Wait so how do you want us to test this...? I thought we already established it works in gecko.
     
  3. JacobM

    JacobM GBAtemp Regular

    Member
    1
    Jun 16, 2017
    United States
    Random thought... what if the issues we are encountering are similar to those experienced with USB Peripheral Controllers such as Rock Band and Guitar Hero?

    Can somebody try one of the old school IOS 38 mods as detailed in this guide?
    https://wiki.gbatemp.net/wiki/Rock_Guide
     
  4. Karrotkonvoy

    Karrotkonvoy Newbie

    Newcomer
    1
    Dec 10, 2017
    United States
    First off, I'd just like to say, excellent work with this code. The .gct version works fine for me both in combination with PM and for VBrawl itself.

    In attempting to get a patched ISO to work through a WiiVC injection, I noticed that not only does the GCA code not work when patched in, but it also doesn't work on disc when launched through the PM launcher or MinimaLauncher. I had always assumed that all these launcher apps applied .gct files the same way as gecko. As far as I can tell, any other codes in the .gct load normally through all these methods. Not sure if that's any correlation, but at the moment, this code only seems to work through gecko + disc for me specifically.
     
  5. JacobM

    JacobM GBAtemp Regular

    Member
    1
    Jun 16, 2017
    United States
    Got the GCT working on my old Wii today with WiiLauncher. Placed the GCT in /codes/ and the gameconfig.txt at the root. The gameconfig.txt is critical for this to work since I get an error stating ~476 lines found and ~425 applied without it. With everything configured properly, the patch works beautifully including the hotplugging feature. Nice! The side GCN ports are disabled (as expected). This patch works with wired and Wavebirds.

    Prior to loading the game with WiiLauncher, the Wavebird receiver doesn't pick up any signals. However, even after quitting the game with patches applied, the light on the receiver still responds. Odd. Would this suggest some of the patches applied are affecting system memory? Maybe that is why ISO patching isnt possible? I tried USB loading the game after booting once from WiiLauncher, but no success.

    I tried installing Hermes (v5 and the modified version hosted at the USB Loader GX Google Code page) base 37/38 cios to 224, but I couldn't get the game to boot even without the patches applied. Any base ios36 cios out there?

    Why is it that disk loading games through a USB Loader requires a CIOS rather than the original IOS? Is it possible to install the original IOS36 into the range accepted by USB Loader GX (in my case 224)? If this is possible, this could once and for all prove if its the USB Loader backbone or the CIOS at fault, right?
     
    Last edited by JacobM, Mar 17, 2018
  6. cruplezone

    cruplezone GBAtemp Fan

    Member
    2
    Feb 3, 2014
    Canada
    Nice tests :)

    Pretty sure you need the CIOs to load from usb in the first place fyi so don't think that second part would work

    Mind posting the game config and gct you're using?
     
    Last edited by cruplezone, Mar 17, 2018
  7. JacobM

    JacobM GBAtemp Regular

    Member
    1
    Jun 16, 2017
    United States
    But I wouldn't be loading from USB... I'm referring to USB Loader GX's disk loading/mounting feature.
     
  8. cruplezone

    cruplezone GBAtemp Fan

    Member
    2
    Feb 3, 2014
    Canada
  9. JacobM

    JacobM GBAtemp Regular

    Member
    1
    Jun 16, 2017
    United States
    1. Use @wilm0x42 code posted below and place it in RSEB01.txt in /txtcodes/
    https://gbatemp.net/threads/need-help-with-vwii-gc-adapter-for-project-m.498236/page-6#post-7875438

    2. In USB Loader GX, generate the GCT file under the games Ocarina submenu

    3. Place the PM code posted below in gameconfig.txt at the root. I deleted the hooktype line so the default would be selected.
    https://gbatemp.net/threads/need-help-with-vwii-gc-adapter-for-project-m.498236/page-6#post-7875475

    4. Boot the game with Gecko OS or WiiLauncher


    I'd rather not muck up my installation if I don't have to, but I guess we can try that as a last resort.
     
  10. cruplezone

    cruplezone GBAtemp Fan

    Member
    2
    Feb 3, 2014
    Canada
    As long as it's an original Wii and you only touch 200 range youre fine. Have the d2x installer to be ready to reinstall anything
     
  11. JacobM

    JacobM GBAtemp Regular

    Member
    1
    Jun 16, 2017
    United States
    I personally don't think that solution will work since the default IOS is defined by the global settings which is fixed to the 200 range. I never understood what the IOS reload block option does. Would it reload from a stub/empty IOS?

    This page suggests d2x v6 can patch ios 36: http://gwht.wikidot.com/ioses-explained
     
    Last edited by JacobM, Mar 17, 2018
  12. JacobM

    JacobM GBAtemp Regular

    Member
    1
    Jun 16, 2017
    United States
    I finally tested with my Wii U with WiiLauncher + disc. The results are so confusing!!

    Official Wii U GCN Adapter in both fronts + vWii (UStealth) in back-top + WiiU in back-bottom = "Now Loading..." loop
    Official Wii U GCN Adapter in both fronts + vWii (UStealth) in back-top + NOTHING IN BACK-BOTTOM = Working GCN controls
    Official Wii U GCN Adapter in both fronts + NOTHING IN BACK-TOP + vWii (UStealth) in back-bottom = Working GCN controls
    NOTHING IN FRONTS + vWii (UStealth) in back-top + Official Wii U GCN Adapter in back-bottom = "Now Loading..." loop

    There doesn't seem to be any rhyme or reason to this, and my results differ from yours?

    I am thinking of giving cios 236 a shot with disc loading via USB Loader GX, but I need to look into if it has the following patches already applied.

    It seems the Gecko OS patches needed are:
    IOS 36 + AHBPROT + ISFS_Permissions + ES_Identify
     
  13. JacobM

    JacobM GBAtemp Regular

    Member
    1
    Jun 16, 2017
    United States
    FINALLY SOME PROGRESS! IOS236_Installer_MOD_v8_for_vWii by @FIX94 (http://www.mediafire.com/file/4y7vebckurr2m9c/IOS236_Installer_MOD_v8_for_vWii_FIX94_dmm.zip) allows disc loading of @wilm0x42 patch from inside USB Loader GX! Its got to be the 249 cIOS at fault and not the actual loader, right?

    At least there is no more need for GeckoOS or WiiLauncher! IOS236 takes a bit longer to boot the game w/ slightly prolonged bluetooth pairing times, but as far as I can tell everything else works perfectly!

    I'll keep looking for a IOS36 based d2x patcher for vWii. I can't find any official proof that d2x v6 or newer can patch ios36. Anybody have a clue?
     
  14. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    20
    Oct 27, 2002
    France
    Engine room, learning
    don't uninstall a cIOS. if you want something else, just overwrite it.
    You can install an IOS into a lot > 200 by editing its slot number with a program (dump IOS to wad > edit slot number > install edited wad)

    But I wasn't sure the "clean IOS" would boot the game fine. I tried to use official IOS to launch NAND channels and failed. I wasn't sure it would work for disc.
    I didn't thought about using cIOS 236 (which is just IOS36 with trucha bug patched), thanks for testing that :)

    so now we can confirm the problem is not the patch, not the loader, but the IOS itself.
    d2x is probably not working with your patch. using IOS(2)36 is a good alternative.
    I don't remember which official IOS slot that game is using.

    I need to add the option to use "requested IOS" to channels and discs for a long time, sorry that I couldn't do it before. I don't know when I'll get the time to fix it.
    until then, installing cIOS 236 (or installing the requested IOS in a slot above 200) is a solution.
    another solution is to remove the IOS slot restriction and allow the use of lower slots (it's cleaner than messing with wad and slot install).


    DO NOT TRY anything relating to patching 36 or whatever using d2x or waninkoko patchers.
    "base 36" is not the solution, the solution is to not use d2x/waninkoko IOS.

    maybe Hermes IOS would work, I don't know why you couldn't launch the game. Try to use v4 or v5 base57 instead of 37+38
     
    Last edited by Cyan, Mar 19, 2018
  15. JacobM

    JacobM GBAtemp Regular

    Member
    1
    Jun 16, 2017
    United States
    I'll look into editing the slot number, that was one of my original plans, but I couldn't find the hex address I needed to change. I THINK 236 includes AHBPROT + ES_Identify, but I'm not sure if it patches ISFS_Permissions. It would be nice to know if those IOS patches are needed or not so I'll get working on getting IOS36 in slot 236. I would think at a minimum, we would need trucha for the unsigned code run by gecko engine and/or the patch, but that is just a wild guess.

    Doesn't d2x include those 3 patches with many additional modifications? Brawl + MKWii use IOS 36 (http://wiibrew.org/wiki/IOS36) which tells me we will likely have the same issue if/when MKWii support is added.

    "Requested IOS" or freedom to select any slot would have been nice to have, but may not be worth the time if I can't get vanilla IOS 36 to load the disc.

    Based on what I can tell, CIOSs need to be custom made for vWii. Fix94 created the 236/80/d2xv10 patchers for vWii, and nothing else exists in the realm of vWii CIOS.

    Somewhere mentioned that IOS 37 was compatible with SSBB, but I haven't tested anything beyond hermes v5 37+38 in 224. I'll revisit hermes IOS on my original Wii sometime next week. Thank you (as always) for the wise words!
     
    Last edited by JacobM, Mar 19, 2018
  16. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    20
    Oct 27, 2002
    France
    Engine room, learning
    For the patch, you don't need any patches at all, no trucha, ES nor ISFS. it relies on one of the virtual /dev
    The fact that cIOS has these patches has nothing to do with the compatibility of GPF or gameconfig or cheats. these are used to access NAND content. the ProjectM patch doesn't care if you have access to NAND or not.


    so, you can do that :
    use WiiBackupManager + your SSBB disc, look which IOS is requested. (apparently, IOS36)
    extract that IOS wad using ... Wiiscrubber for example ! or dump your IOS36 with BlueDump Mod.
    Open that WAD into ShowMiiWad, right click and select edit the slot > 200 (don't set it to 236! that would be confusing. anything from 237 to 248).
    now you can install it with your preferred wad manager.

    But, Like I said, I wouldn't mess with my IOS slots if I was you. I'd just edit the loader's source to accept any slot number, at least as beta for the test !
     
    JacobM likes this.
  17. cruplezone

    cruplezone GBAtemp Fan

    Member
    2
    Feb 3, 2014
    Canada
    Yeah that's a best practice, good point. Think we could get a usbloader build with user defined ios slot, at least for disc loading?

    — Posts automatically merged - Please don't double post! —

    Just a question, by launching from usb loadergx, did you test that it loads the patch + disc correctly AND it loads patch + 'from usb hdd' properly? Or does it only work when launched from disc?
     
    Last edited by cruplezone, Mar 19, 2018
  18. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    20
    Oct 27, 2002
    France
    Engine room, learning
    yes, here it is :)
    *removed*

    I didn't add the sources or patch file because I don't want it to be publicly used (it's going backward to remove protections).
    But it's based on 1269_mod03, with these changes :
    - updated custom banner url
    - updated nintendont cfg version to 8
    - removed protection to select IOS <200 in global settings.

    edit:
    Annnnnnd I made a mistake ahaha
    I removed protection to Loader's IOS instead of Game's IOS.
    My fault for not reading.
    I'll reupload a new version.

    http://www.mediafire.com/file/bsmksdaca0t66kf/USBLoaderGX r1269_mod03++.7z (New one, re-download if you have the "+" version)
     
    Last edited by Cyan, Mar 19, 2018
    JacobM likes this.
  19. JacobM

    JacobM GBAtemp Regular

    Member
    1
    Jun 16, 2017
    United States
    I did disc alone, disc+gct+gameconfig.txt
    I did not try disc+gameconfig.txt or any iteration of PM

    This would not be compatible with USB loading, but it beats having to us an additional homebrew. USB Loader GX is my one-stop-shop for everything vWii related :D

    YAY!! Thank you Cyan! I'll get started, but I have a meeting soon!

    EDIT: redownloaded, you only removed the restriction to global game IOS (I think global should be fixed to 200+), not the game specific one. Regardless, the restriction you removed doesn't work. While the global game IOS setting doesn't block "saving" IOS36, it doesn't actually change from 249 in the UI. A game with "use global" seems to still load using the displayed IOS249. Editing the config file manually in either global or game specific cfg loads IOS36! I can't believe I never thought of that before. I would have saved myself installing 236!

    Vanilla IOS 36 works with the GCN adapter when disc loading! You were right that the patches weren't needed for gecko codes!
    Even with Vanilla IOS 36, having the WiiU USB plugged into the back-bottom port causes the "Now Loading..." loop. I am assuming that can be fixed in a future iteration of @wilm0x42 patch.

    Is there a way to define different settings for disc vs. usb loaded games with the same game ID?

    WiiBackupManager lists IOS36

    New banner URL works!

    Gonna try loading SSBB with vanilla 37, 38, 56, 57, 58

    Good point! I forget you don't need to be homebrew'd to run PM.
     
    Last edited by JacobM, Mar 19, 2018
  20. JacobM

    JacobM GBAtemp Regular

    Member
    1
    Jun 16, 2017
    United States
    Some additional testing....

    ios 36 -> works
    ios 36 + patch -> works

    ios 37 -> works
    ios 37 + patch -> now loading...
    ios 38 -> works
    ios 38 + patch -> works

    ios 53 -> works
    ios 53 + patch -> loads but no GCN adapter response
    ios 55 -> works
    ios 55 + patch -> now loading...
    ios 56 -> works
    ios 56 + patch -> loads but no GCN adapter response
    ios 57 -> works
    ios 57 + patch -> loads but no GCN adapter response
    ios 58 -> works
    ios 58 + patch -> loads but no GCN adapter response
    ios 236 -> works
    ios 236 + patch -> works


    Looks like IOS38 might do the trick! Does anybody have a CIOS of IOS38 for USB Loading in vWii?

    Edit: Might be easier to test on an Original Wii since we can do d2x 52 & 53 based on IOS38. I don't think hermes was ever ported to vWii Cyan.
     
    Last edited by JacobM, Mar 19, 2018
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice