Need help with Swap Magic

Discussion in 'Sony PlayStation 1 & 2' started by Sorakun, Nov 5, 2011.

  1. Sorakun
    OP

    Sorakun Advanced Member

    Newcomer
    52
    1
    Oct 19, 2007
    Gambia, The
    After a failed attempt at softmodding my PS2, due to me accidentally getting my hands on an ARmax EVO without Max Media Player (and possibly due to my PS2 being unmoddable), I'm considering buying a Swap Magic.
    My problem is that I have no idea which Swap Magic+Tool package I'm supposed to buy.
    My PS2 is a slim black SCPH-90004, date code 8C.
    DiscoAzul offers the packages Swap Magic Coder 3.8 + Magic Keys 2, 3 or 4. Which one of those do I need?
    And then there's the 3.8 vs. 3.6 issue. I don't care about being able to use codes, as long as I have maximum compatibility. Should I try looking for a Swap Magic 3.6 instead?

    I would appreciate your help.

    P.S.: Before I get any cries of "Return your PS2 and get an older model." or anything along those lines, the PS2 and the ARmax were presents. Return impossible.
     
  2. Centrix

    Centrix Stop Poking the Moogle!

    Member
    888
    77
    Aug 28, 2008
    United States
    Seattle,WA
    I've used both 3.6 and the recently released (by recently I mean a few years ago) Swap Magic 3.8, I personally prefer 3.8 as it seems to have faster load times, ablity to load dual-layer'ed games (can't confirm that though) and Action Replay built into it! So I'd recommend buying Swap 3.8 instead of 3.6 you'll like better at least I think!
     
  3. jimmyemunoz

    jimmyemunoz GBAtemp Advanced Maniac

    Member
    1,958
    226
    Feb 23, 2009
    United States
    Louisiana
    You have a version 18 PS2 and 3.8 is better (it offers more features like booting Elfs from USB, ESR and of course a cheat engine) but both models will work with your PS2. If your gaming is going to be off of DVD-R discs and you don't need cheats just buy the 3.6 version of Swap Magic. Oh, by the way, you need magic keys 4. Have fun! :D