1. SuperChris

    OP SuperChris Newbie
    Newcomer

    Joined:
    Jul 16, 2020
    Messages:
    1
    Country:
    United Kingdom
    The PSP in question is a black 1000 model. I first noticed an issue in that playing Cave Story, the down input stopped working (it works in the XMB) and after pausing it, it wouldn't let you go back to the game. I tried replacing all of Cave Story's files but the issue persisted, which led me to believe that something with the PSP's firmware was the problem. After trying to troubleshoot a little, I found that pressing select on the XMB does not bring up the VSH.

    When I bought it, it was already running a perma flashed 6.60 Pro-B9. So I thought I'd try reinstalling ofw, then installing a new cfw, C2. For this I'm trying to use HellCat's recovery flasher, but now as soon as I run it, it freezes, and I can't do anything; not even go back to the XMB, and I can only restart the PSP.

    Does anyone know what the issue could be here or can offer any help with my situation? Thanks in advance
     
  2. Acid_Snake

    Acid_Snake GBAtemp Regular
    Member

    Joined:
    Aug 20, 2019
    Messages:
    149
    Country:
    Spain
    The first thing that comes to mind is the connection of the lower buttons (start, select, home, etc) to the motherboard. This usually wears out and doesn't work correctly (some buttons don't work, others appear as if they are always being pressed, etc). So one option would be to open the console and clean that port with a qtip and alcohol.
     
    alexander1970 likes this.
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - faulty,