Need help with a ROM issue -

Discussion in 'GBA - Flashing Hardware and Software' started by Sterling, Jun 4, 2010.

Jun 4, 2010
  1. Sterling
    OP

    Member Sterling GBAtemp's Silver Hero

    Joined:
    Jan 22, 2009
    Messages:
    4,023
    Location:
    Texas
    Country:
    United States
    Not sure if it's my Flash Kit or what (G6 Lite), but on this particular game after I select new and my names. The game never progresses past that point. The funny thing is I was able to get it to work on my M3 DS Real with an GBA expansion pack. I was able to use a emulator save work around for a rom that had a similar problem: 1646 - Dragon Ball Z - Buu's Fury (U). This ROM however does not have a save function. All it does when I use the end game function (when I assume it should save), and close the emulator, and write the save file to my card is not recognizing that I saved and proceeds to do the same thing if I start with just the raw blank save. I decide to check if the emulator will see that it had saved, and it did.

    I would appreciate it if someone could help me fix it, or better yet provide me with a working .sav file at the very beginning! Thanks to those that reply and help!
     
  2. Coto

    Member Coto GBAtemp Addict

    Joined:
    Jun 4, 2010
    Messages:
    2,276
    Country:
    Chile
    There are some programs that allow you to convert GBA saves between RAW (pure/true GBA save file format) and NO&GBA/VBA or whatever you could be using to play for.

    However, if HAMTARO (U) can save, and you can´t save with your actual flashcard, i´d recommend patching GBA ROM with GBATA, and using GBA Exploader (1.59?) if my memory doesn´t fail, and being SURE about what kind of save the games uses by itself (64KB EEPROM,128KB flash, etc) this way, you´ll be able to succesfully transfer save files between EMUS and REAL GBA , even if it´s flashcart) (of course you own the game legally :3)
     
  3. Sterling
    OP

    Member Sterling GBAtemp's Silver Hero

    Joined:
    Jan 22, 2009
    Messages:
    4,023
    Location:
    Texas
    Country:
    United States
    Whoo! Got it to work! Used the auto detect feature in VBA. It told me to set to SRAM, and it uses 128KB sav.
     

Share This Page