Need help! Psp go downgrade 6.60 to 6.20 so I can run a CfW

Discussion in 'PSP - Hacking & Homebrew' started by Retroguy007, Oct 11, 2018.

  1. Retroguy007
    OP

    Retroguy007 Member

    Newcomer
    1
    Oct 11, 2018
    Canada
    I'm trying to downgrade to 6.20 from 6.60 so I can run a CFW and I'm new to this
    A guy by the name pickle Rick said this was the best firmware for psp go so
     
  2. SonicMC

    SonicMC GBAtemp Fan

    Member
    5
    Dec 6, 2007
    United States
  3. silvershadow

    silvershadow GBAtemp Regular

    Member
    5
    May 16, 2006
    Canada
    Last edited by silvershadow, Oct 11, 2018
    zfreeman likes this.
  4. Retroguy007
    OP

    Retroguy007 Member

    Newcomer
    1
    Oct 11, 2018
    Canada
    — Posts automatically merged - Please don't double post! —

     
  5. SonicMC

    SonicMC GBAtemp Fan

    Member
    5
    Dec 6, 2007
    United States
    Honestly there are pros and cons to whatever choice you make.

    If you want to try downgrading go ahead. https://wololo.net/talk/viewtopic.php?t=12053

    As for homebrew breaking... Well nothing new there. I have a launch psp 1000 and different cfws always broke something and often new homebrew didn't work on old cfw and same in reverse... And some Homebrew only worked on certain cfws.

    The pause feature is a glorified save state with only 1 state. Can you live without it? Up to you :)
    Themes are really just a bonus... But if they are important to you then that is great too!

    Suggestion;
    Make a list of what you want:
    Then google what cfw supports each of those. Then try out the ones that look best to your needs.

    As with most cfw and device hacks. Know the risks that sometimes one small file or button press can break it and it may not be fixable after.

    Edit: cipl I believe is for psp 1000 and some psp 2000. So not for psp go. So don't worry about that.
     
    Last edited by SonicMC, Oct 11, 2018
    Retroguy007 and silvershadow like this.
  6. Retroguy007
    OP

    Retroguy007 Member

    Newcomer
    1
    Oct 11, 2018
    Canada
    — Posts automatically merged - Please don't double post! —

    Sorry didnt know how to reply anyway-


    Ok thanks first I don't know how to do much of the actual modding but yea firstly I was trying to decide "ok this is which one I'm going for" and I thought it would be 6.20 but now I don't know so back to the drawing board
     
  7. SCOTT0852

    SCOTT0852 Kid now, squid now

    Member
    5
    Jan 20, 2018
    United States
    I use Infinity, if you want to keep your Pause feature with it then just use PSPStates, which has 9 slots instead of 1.
     
  8. Retroguy007
    OP

    Retroguy007 Member

    Newcomer
    1
    Oct 11, 2018
    Canada
    What is pspstates? Is that a plugin?
     
  9. SCOTT0852

    SCOTT0852 Kid now, squid now

    Member
    5
    Jan 20, 2018
    United States
    Yep.
     
  10. Casey-Strange

    Casey-Strange Member

    Newcomer
    1
    Jan 12, 2019
    United States
    It's 2019. People should be able to downgrade their PSPs if they want to. Right now, you can downgrade to 6.20 if you've got some know how. But getting down to 5.20 right now is a challenge as Sony has a license/activation certificate on the Patapon 2 demo.

    There is a mediafire folder out there with links to download every OFW for PS4/3/PSP so people have these on hand for those who want to make use of them.

    I have launch PSP1000. In the US they came out at Version 1.50 so it'd be cool to conveniently downgrade or upgrade your PSP to whatever you wish at your own expense of possibly bricking it.

    Yeah I want to do some homebrewing, but I also want to dink around and update my firmware through my UMD games just to see the evolution of firmwares through just the game updates rather than the sites. Yeah its the same but how often can you say you updated your PSP through the games in your collection and than downgraded it to an earlier point for shits and giggles?

    — Posts automatically merged - Please don't double post! —

    How do I get beneath 6.20 right now? I want to downgrade to either 1.50, 2.00 or 3.50. I hear if you go too far down it gets really difficult to update or utilize certain homebrews.
     
Loading...