Need help playing wii roms from USB device via USB Loader GX

Discussion in 'Wii - Emulation and Homebrew' started by Yoshisaur, Feb 24, 2016.

  1. Yoshisaur
    OP

    Yoshisaur Newbie

    Newcomer
    1
    0
    Feb 24, 2016
    Gambia, The
    Hello,
    im quite new to using softmods on Wii. I want to play games with USB Loader GX and got the problem that some games work, bot most of them don't, which means that I either get a black screen or the game game returns to the Wii system screen.
    Warning: Spoilers inside!
    Honestly i don't know much about the whole softmodding topic so I'll try to write all information about the problem that might be relevant from the beginning.

    I first installed the homebrew channel after the instructions I found on smashboards, in order to be able to play Project M (a Super Smash Bros Brawl mod). Plus the necessary IOS. Then I simply formatted my 16 GB Kingston USB 3.0 flash drive to WBFS and transfered the Brawl.iso to it (using Wii Backup Manager). (meanwhile I've read that using this format is outdated...) Everything went fine and i could play, even without updating USB Loader.

    The problems started when I bought a cheap no name 128 GB USB 2.0 flash drive from china (128gb for 10€ sounded nice to me). At first the usb device wasn't even working with Usb Loader, so i used it's update function and got it working. Then I realised that only a few games are working, and strangely even games, that worked on my 16 GB Kingston flash drive before. So the evidence suggests that it could be the no name flash drive, that causes a problem. But I'm still not quite sure. I found similiar problems on this board, and followed the advice to update cIOS rev 20 to cIOS rev21 d2x v10-alt beta 53. Unfortunately it hasn't solved my problem. So i did a system check, in the hope that someone could tell me whether everything is right about my Wii (updated to 4.3E) or if i did anything wrong.

    System check:
    Warning: Spoilers inside!


    Offtopic:
    How can I get the usb flash drive working in FAT32 format? I tried using the recommended software "FAT32 Format", then tranfering the ISOs via Wii Backup Manager (it asked to create a wbfs folder and I clicked "yes"). But Usb Loader GX says "usb device not initialised" or somethign like that. That's why im using WBFS format at the moment.

    Thanks in advance!
     
    Last edited by Yoshisaur, Feb 24, 2016
  2. Duckie1992

    Duckie1992 Newbie

    Newcomer
    4
    0
    Apr 6, 2016
    United States
    Well i don't know if this will be much help but i have a 1TB hard drive and to make it have enough power to run on the Wii i have a wire thats has two USB connections on it. Also using USB Loader i use WBFS and download games with UTorrent which then you browse for your game under download and highlight all parts of the game like it'll say MarioKart1-25 and it'll load those up and put them on your hard drive you have for the wii.
     
  3. Xuman

    Xuman GBAtemp Fan

    Member
    395
    245
    Jan 26, 2012
    United States
    If you are using USB Loader GX then iirc usb flash drives have issues that were unable to be fixed.

    Also using the wbfs format is what i personally use and i have no issues whatsoever.

    Its highly recommended that you get a hard drive for usbloader