Need help after updating to Luma 8

Discussion in '3DS - Flashcards & Custom Firmwares' started by Tom77_no, Jun 5, 2017.

  1. Tom77_no
    OP

    Tom77_no Newbie

    Newcomer
    9
    1
    Jun 5, 2017
    Norway
    I just updatet my O3DS to Luma 8. When pressing powerbutton the blue light flashes and the console just turns off again. While updating I was asked if I wanted to write to nand or something by holding A+B, and I did. Is there a way to fix this please?
     


  2. W4T4R1

    W4T4R1 GBAtemp Fan

    Member
    414
    211
    Aug 20, 2014
    Italy
  3. Tom77_no
    OP

    Tom77_no Newbie

    Newcomer
    9
    1
    Jun 5, 2017
    Norway
    I did follow abguide like that to install boot9strap, but if it was version 1 or 1.2 I dont know.
     
  4. W4T4R1

    W4T4R1 GBAtemp Fan

    Member
    414
    211
    Aug 20, 2014
    Italy
    The 1.2 version of boot9strap has been released less than 12 hours ago, if that guide has been created/modified more than 12 hours ago you have an older version of boot9strap.
    Try following the (only) guide (you should follow) I linked above
     
  5. Tom77_no
    OP

    Tom77_no Newbie

    Newcomer
    9
    1
    Jun 5, 2017
    Norway
    Started from the beginning of the guide you linked to, copied all the files to the correct folders. When powwering on the 3ds and holding start the same thing happens. The blue light flashes and the screen is all black
     
  6. SignZ

    SignZ Timelord

    Member
    2,110
    786
    Jul 16, 2008
    Germany
    Put Luma 7.1 back on your SD, update b9s via SafeB9SInstaller, then put Luma 8.0 on your SD.
     
  7. W4T4R1

    W4T4R1 GBAtemp Fan

    Member
    414
    211
    Aug 20, 2014
    Italy
    Maybe you are missing boot.firm file? The blue light turnin on for just a few moments usually means that
     
  8. Tom77_no
    OP

    Tom77_no Newbie

    Newcomer
    9
    1
    Jun 5, 2017
    Norway
    Thank you, put luma 7.1 back and did as you said. It now boots and when entering luma updater it says ver. 8 installed. Appreciate all your help very much :D
     
    SignZ likes this.
  9. rafael93fn

    rafael93fn Member

    Newcomer
    10
    2
    May 22, 2017
    Brazil
    Belo Horizonte
    I'm sorry if I'm posting this in the wrong thread. I've updated to b9s 1.2 and luma 8.0, and it's working just fine...except for InputRedirection. I've never used this before. I'm getting errors 0x09401bfe on first try and 0xffffffff on the following. Does anyone know what it is?
     
  10. digr8one

    digr8one Member

    Newcomer
    48
    6
    Sep 23, 2016
    I tried following the 3dsguide and I replaced all the new files where they should go and when it says hold start while booting
    thats where I am having troubles. it won't let me go anywhere than straight into the 2ds home screen where all the icons are
    and on 20/5 I updated my 2ds to boot9strap without problems but now all of a sudden this won't work??
    I currently have luma 7.1 installed (thats what it says when I open up luma) any ideas whats wrong or am I screwed?
     
  11. DjoeN

    DjoeN Captain Haddock!

    Member
    5,136
    1,478
    Oct 21, 2005
    Belgium
    Somewhere in this potatoland!
    7.1 doesn't work with b9s 1.2, you need Luma v8 for that
     
  12. digr8one

    digr8one Member

    Newcomer
    48
    6
    Sep 23, 2016
    Okay but all I have done so far from the 3dsguide page is
    Section I - Prep Work

    nothing else.. what do you suggest me to do?

    at this step :
    Section II - Installing boot9strap
    1. Reboot holding (Start) during boot to launch the Luma3DS chainloader menu

    i am stuck. any ideas?
     
    Last edited by digr8one, Jun 5, 2017
  13. DjoeN

    DjoeN Captain Haddock!

    Member
    5,136
    1,478
    Oct 21, 2005
    Belgium
    Somewhere in this potatoland!
    follow the guide :)

    What i did: (Updated from B9S v1.0)

    - Power off N3DS(XL)
    - Insert SD card into computer
    - Copy boot.3dsx to the root of the SD card (Overwriting any older existing version)
    - Keep boot.firm from Luma 7.1 on SD
    - Copy lumaupdater.cia to my /cias/ folder on the SD card (Overwriting any older existing version)
    - Copy GodMode9.firm from the GodMode9 .zip to the /luma/payloads/ folder on the SD card (Overwriting any older existing version)
    - Copy SafeB9SInstaller.firm from the SafeB9SInstaller .zip to the /luma/payloads/ folder on the SD card
    - Wiped everything inside previous /boot9strap/ folder
    - Copy boot9strap.firm and boot9strap.firm.sha from the boot9strap .zip to the /boot9strap/ folder on the SD card
    - Copy secret_sector.bin to the /boot9strap/ folder on the SD card
    - Copy aeskeydb.bin to the /boot9strap/ folder on the SD card
    - Removed the SD 'safe' from the PC
    - Reinsert the SD card into the N3DS
    - Boot the system while holding (Start) to launch the Luma3DS v7.1 chainloader menu
    - Start SafeB9SInstaller.firm
    - The system will reboot and give an error because B9S v1.2 is not compatible with Luma3DS v7.1 (An error has occured: Unsupported launcher (argc = 0) Press any button to shutdown)
    - Press any button to power down your system
    - Insert SD card into computer
    - Copy boot.firm from the Luma3DS .7z (v8.0) to the root of the SD card
    - Removed the SD 'safe' from the PC
    - Reinsert the SD card into the N3DS(XL)

    Now follow this section of the guide:
    - Section IV - CTRNAND Luma3DS
     
    Last edited by DjoeN, Jun 5, 2017
    digr8one likes this.
  14. digr8one

    digr8one Member

    Newcomer
    48
    6
    Sep 23, 2016
    Hey thanks it now says on luma current version 8.0 does that mean that it now works? how do I know If I have the b9s 1.2 ?
     
  15. blujay

    blujay GBATemp's Official Warthog

    Member
    2,092
    1,852
    Nov 2, 2015
    United States
    Gilbert, Arizona
    If it boots to Luma 8.0 (most likely the Config menu, if you don't see it then press select on boot), it will say Luma 8.0 on top. If you can boot Luma 8.0, you have B9S 1.2 installed.
     
  16. digr8one

    digr8one Member

    Newcomer
    48
    6
    Sep 23, 2016
    thank you so much. it says luma 8.0 at the top. but at the luma icon on the home screen it says current version installed 8.0 but it is in red text? does it mean something went wrong?
    it was never in red text before? also my homebrew launcher is still at version 1.1.1 so no change there. any ideas?
     
  17. blujay

    blujay GBATemp's Official Warthog

    Member
    2,092
    1,852
    Nov 2, 2015
    United States
    Gilbert, Arizona
    Not sure about Luma Updater. Haven't used it yet because it seems pointless when you had to manually install to Boot9Strap. Make sure you have the right boot.3dsx

    Get the new Boot.3dsx here: https://github.com/fincs/new-hbmenu/releases
     
    digr8one likes this.
  18. digr8one

    digr8one Member

    Newcomer
    48
    6
    Sep 23, 2016
    I am sorry im stupid xD I had to redo everything and forgot to put in the new boot.3dsx so I got all confused and now it is of course working with the new Rosalina homebrew also.Thank you!
     
    DjoeN likes this.
  19. blujay

    blujay GBATemp's Official Warthog

    Member
    2,092
    1,852
    Nov 2, 2015
    United States
    Gilbert, Arizona
    No problem.
     
    digr8one likes this.
  20. DjoeN

    DjoeN Captain Haddock!

    Member
    5,136
    1,478
    Oct 21, 2005
    Belgium
    Somewhere in this potatoland!
    Happy i could help and it all works out for you :)

    The guide is nice if you do a fresh install or update from A9LH to B9S, but it is a bit confusing when you just update from B9S v1.0/1.1 to B9S v1.2
     
    digr8one likes this.