Need FBI on sysNAND or no?

Discussion in '3DS - Flashcards & Custom Firmwares' started by Eddypikachu, Jan 24, 2016.

  1. Eddypikachu
    OP

    Eddypikachu GBAtemp Fan

    Member
    387
    147
    Mar 25, 2015
    United States
    I'm trying to get gba virtual console games to work and I already installed them on emuNAND, both my emuNAND an sysnand are unlinked so I need to install the gba cias onto the sysnand but when I launch FBI from ninjhax it wont let me install the cias onto sysnand. So do I need to install FBI onto sysnand so I can install the gba cias onto the sysnand? If I do how do I go upon doing that?
     
    Last edited by Eddypikachu, Jan 24, 2016
  2. squee666

    squee666 Advanced Tech Pleb

    Member
    1,587
    890
    Sep 17, 2010
    Belfast
    you need to run CFW like sysnandmode of rxtools or minipasta for FBI to successfully install files
     
    Eddypikachu likes this.
  3. Eddypikachu
    OP

    Eddypikachu GBAtemp Fan

    Member
    387
    147
    Mar 25, 2015
    United States
    So I run mini pasta before I start to install from FBI?
     
    Last edited by Eddypikachu, Jan 24, 2016
  4. Eddypikachu
    OP

    Eddypikachu GBAtemp Fan

    Member
    387
    147
    Mar 25, 2015
    United States
    When I run mini pasta and boot up FBI it gives me an error of:
    Install Failed!
    Mother 3(English).cia
    Source:Source_FSFILE_WRITE (0x1c)
    Module: MODULE_NN_FS (0x1b)
    Summary:SUMMARY_WRONG_ARGUMENT (0x8)
    Description: DESCRIPTION_INVALID_DATABASE (0x198)
    Press start to continue

    Any idea whats going on?
     
  5. olec04

    olec04 Working on Project Heaven!

    Banned
    851
    142
    Apr 10, 2015
    United States
    Trying to downgrade on 11.0 via AM services
    yeah
     
    Eddypikachu likes this.
  6. James310

    James310 GBAtemp Advanced Fan

    Member
    879
    319
    Oct 4, 2015
    United States
    Somewhere in California
    Rebuild the database files in sysnand
     
    Eddypikachu likes this.
  7. Eddypikachu
    OP

    Eddypikachu GBAtemp Fan

    Member
    387
    147
    Mar 25, 2015
    United States
    I got it, I just had to repair the import and title .db files in system settings and now I can install the gba virtual console cias! Thank you guys! :yay3ds:
     
  8. olec04

    olec04 Working on Project Heaven!

    Banned
    851
    142
    Apr 10, 2015
    United States
    Trying to downgrade on 11.0 via AM services