Naruto - Akatsuki Rising not working on Prometheus 5.03 v3

Discussion in 'PSP - Games & Content' started by TheOtakuOverlord, Nov 15, 2010.

  1. TheOtakuOverlord
    OP

    TheOtakuOverlord Member

    Newcomer
    1
    Mar 14, 2009
    Liverpool, UK
    Hi, I'm trying to get Akatsuki Rising to work on my psp, but whenever i start the game, it just loads a black screen with no errors or other messages and it stays like this until i go back to the home menu. I'm on 5.03 Prometheus V3 and I'm using a PSP 2000. Whats up with it?
     
  2. xist

    xist ΚΑΤΑ ΤΟΝ ΔΑΙΜΟΝΑ ΕΑΥΤΟΥ

    Member
    6
    Jul 14, 2008
    Did you get a Clean or a Pre-patched/Fixed ISO? You may need to use eDecrypt/Yoshiro's Game Patcher on the eboot.bin if it was clean, or it may just be an issue with the Prometheus firmware.
     
  3. TheOtakuOverlord
    OP

    TheOtakuOverlord Member

    Newcomer
    1
    Mar 14, 2009
    Liverpool, UK
    It was a clean cso as far as i know, how do i go about decrypting it?
     
  4. xist

    xist ΚΑΤΑ ΤΟΝ ΔΑΙΜΟΝΑ ΕΑΥΤΟΥ

    Member
    6
    Jul 14, 2008
    Decompress it to an ISO, extract the eboot.bin with UMDGEN patch it with eDecrypt and rebuild the ISO with the decrypted eboot.bin.
     
  5. DarkDusk

    DarkDusk Member

    Newcomer
    1
    Mar 14, 2010
    United States
    Iso tool will work just as well, I believe.
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice