N3DS XL on 9.4 need opinions!

Discussion in '3DS - Flashcards & Custom Firmwares' started by Neru, Aug 8, 2015.

  1. Neru
    OP

    Neru GBAtemp Fan

    Member
    355
    135
    Feb 11, 2015
    United States
    So i've had this N3DS XL for awhile on 9.4U and today I got an SKY3DS which so far is fantastic but the only downfall is that I can only play games online that has no updates(Which eshop is block). So idk if I should update to 9.9 or should I wait for a 9.3+ support for CFW later in the future. Even tho I have an O3DS with 9.2U on it but is not as great as the N3DS XL.
     
  2. LinkmstrYT

    LinkmstrYT ( ͡° ͜ʖ ͡°)

    Member
    1,462
    802
    Dec 16, 2013
    United States
    You wanted to see where I live? You stalker...
    Um, your Old3DS can use rxTools CFW for free so you don't have to use or buy a Sky3DS to play roms. :P

    Also, Sky3DS works on the latest firmware, so you're fine to update your New3DS to 9.9.
     
  3. LameNobody

    LameNobody Weighted Companion Cube Enthusiast

    Member
    455
    232
    Jan 23, 2015
    Canada
    127.0.0.1
    Honest opinion?
    Get a hard mod, Make a backup of 9.4... Then you'll be able to update until an exploit for 9.4 exists... at which point you can downgrade back with the nand backup you made
     
  4. Neru
    OP

    Neru GBAtemp Fan

    Member
    355
    135
    Feb 11, 2015
    United States
    Sorry, forgot to mention that I have gateway as well and I'm kinda afraid to update it to the latest because what if a 9.4 support comes out soon? I've been through this already with 4.5 :O and don't wanna go through that again.
     
  5. funnystory

    funnystory Banned

    Banned
    1,472
    479
    Sep 20, 2008
    United States
    What makes you think theirs going to be a 9.4 exploit?
     
  6. Neru
    OP

    Neru GBAtemp Fan

    Member
    355
    135
    Feb 11, 2015
    United States
    I was thinking of that but don't really have the budget for that.
     
  7. LinkmstrYT

    LinkmstrYT ( ͡° ͜ʖ ͡°)

    Member
    1,462
    802
    Dec 16, 2013
    United States
    You wanted to see where I live? You stalker...
    Then, just use your Old3DS that's on 9.2 to play roms. It can have EmuNAND up to 9.9 and you can install game updates and dlc without going into the eShop.
     
  8. Neru
    OP

    Neru GBAtemp Fan

    Member
    355
    135
    Feb 11, 2015
    United States
    Have already done that on the O3ds, got emuNAND on 9.9. I'll probably just update the New 3ds xl or hard mod it to backup my nand just in case.
     
  9. Jao Chu

    Jao Chu GBAtemp Advanced Maniac

    Member
    1,921
    1,211
    Aug 20, 2013
    straya m8
    Wind back to 2014 and we also said the same thing about 5.0-9.2.

    It really is upto you, OP. I don't online game at all and held my original small 3DS on 4.5 the day 3Dbrew said "The latest safe firmware is 4.5" and the waiting eventually paid off in August 2013 when i recieved my Gateway cart.
     
  10. Psi-hate

    Psi-hate GBATemp's Official Psi-Hater

    Member
    1,648
    1,046
    Dec 14, 2014
    United States
    Houston
    9.4 actually patched memchunkhax, so without arm11 kernel, we wouldn't even be able to have kernel on 9.3
    Basically, it wouldn't matter if you updated because if there's another Kernel entrypoint, it'd work on 9.3 and up anyway.
     
    Zidapi likes this.
  11. LameNobody

    LameNobody Weighted Companion Cube Enthusiast

    Member
    455
    232
    Jan 23, 2015
    Canada
    127.0.0.1
    Even though memchunkhax is patched, firmlaunch-hax isn't patched until 9.5.0.... So 9.4.0 users still have that
     
  12. Psi-hate

    Psi-hate GBATemp's Official Psi-Hater

    Member
    1,648
    1,046
    Dec 14, 2014
    United States
    Houston
    You're right, actually.. Well, at least 9.4 will only need arm11 kernel now.
     
    LameNobody likes this.