N3DS on 9.6, eshop access through hax 2.5?

Discussion in '3DS - Homebrew Development and Emulators' started by thebatdadd, Nov 26, 2015.

  1. thebatdadd
    OP

    thebatdadd GBAtemp Regular

    Member
    154
    14
    Jun 26, 2013
    United States
    I have hax 2.5 running on my brand new N3DS, but if I try to access the eshop through the homebrew channel I get this message:

    "to use nintendo eshop, you must accept the latest version of the Nintendo 3DS service user agreement. Press home to return to the home menu"

    Any idea how to get around this? There is no NNID set on the system yet.

    Also, is there any way to use menuhax without having to turn off the system and then turn it on again? On my old 3DSXL if I press the power button and then hold the L button while going back to the home menu I can load the homebrew channel. For some reason this method won't work on my N3DS and the only way I can access the homebrew channel on my N3DS is to hold L while powering on the system. Any help?
     
  2. Ericjwg

    Ericjwg GBAtemp Psycho!

    Member
    3,076
    815
    Jul 2, 2015
    Canada
    no.... not anymore...
     
  3. OctopusRift

    OctopusRift GBATemp's Local Octopus, Open 9am-2am. "Not Yet"

    Member
    1,460
    832
    Nov 19, 2014
    Saint Kitts and Nevis
    OOH. NO NNID. GO FOR IT. DO THE ESHOP SPOOF.
     
  4. Phanton

    Phanton GBAtemp's Nui lover

    Member
    305
    152
    Sep 9, 2015
    Argentina
    Go to system settings and then close it, pressing L while doing so.
     
  5. thebatdadd
    OP

    thebatdadd GBAtemp Regular

    Member
    154
    14
    Jun 26, 2013
    United States
    Thanks, that worked!

    So for the eshop I'm basically screwed? Did I mess up by trying to access the eshop or is it basically impossible nowadays on 9.6? I looked up the eshop spoof but apparently that is only for 9.0-9.2 firmwares?
     
  6. Phanton

    Phanton GBAtemp's Nui lover

    Member
    305
    152
    Sep 9, 2015
    Argentina
    There was a spoofer available not to long ago for 9.3+users but it got patched real quick. Source code was released though, so it may be fixed in the future, so if you are not in a hurry just wait.
     
  7. thebatdadd
    OP

    thebatdadd GBAtemp Regular

    Member
    154
    14
    Jun 26, 2013
    United States
    Got it, I just wanted to update Pokemon but it can wait. Thanks again!
     
  8. shinyquagsire23

    shinyquagsire23 SALT/Sm4sh Leak Guy

    Member
    1,966
    3,249
    Nov 18, 2012
    United States
    Las Vegas
    If you have no NNID you should actually be just fine I believe. Not sure if you can download anything though.
     
  9. daxtsu

    daxtsu GBAtemp Guru

    Member
    5,546
    3,955
    Jun 9, 2007
    Antarctica
    I think you can download game updates without an NNID, can't you? Just not demos or much of anything else.
     
  10. ihaveamac

    ihaveamac GBAtemp Guru

    Member
    5,494
    6,074
    Apr 20, 2015
    United States
    Tigard, OR
    you can still purchase things, but free software and demos require an ID. I should go check updates right now... game updates do not require an ID. I went and set up one of my systems and went straight to the eShop.
     
    Last edited by ihaveamac, Nov 26, 2015
    daxtsu likes this.
  11. thebatdadd
    OP

    thebatdadd GBAtemp Regular

    Member
    154
    14
    Jun 26, 2013
    United States
    Hmm well I think it's asking me to accept the user agreement since I've never actually accessed the eshop before. I'm just afraid to go into the eshop since I don't want to get that "you need to update your system" message and then be completely screwed.

    So you guys think I should just try going into the eshop normally and accepting the terms if given the option, but don't actually make a NNID? All I'm interested in are game updates for online play basically
     
    Last edited by thebatdadd, Nov 26, 2015
  12. ihaveamac

    ihaveamac GBAtemp Guru

    Member
    5,494
    6,074
    Apr 20, 2015
    United States
    Tigard, OR
    you should try it out.

    it sounds like you're worried about the "system update" message becoming permanent, which is only for the browser I think.
     
  13. Bowl0l

    Bowl0l GBAtemp Regular

    Member
    114
    24
    Oct 28, 2015
    Malaysia
    Hi. Excuse me for being a jerk.

    Is there a thread to follow for 3DS eshop spoofing?

    I am on 10.1, with NNID and i really want to buy games from eshop.

    MHU4 and Rune Factory 4
     
  14. MsMidnight

    MsMidnight part time fe modder

    Member
    1,753
    1,308
    Oct 12, 2015
    kys
    If you have nnid you cannot spoof
     
  15. Izual Urashima

    Izual Urashima Advanced Member

    Newcomer
    99
    16
    Sep 23, 2009
    Belgium
    Between here and there
    I second that question. It's gonna become interesting to have next week, as I want to grab Pokémon Picross when it'll be released.
     
  16. Phanton

    Phanton GBAtemp's Nui lover

    Member
    305
    152
    Sep 9, 2015
    Argentina
    Is anyone even trying to fix the spoofer?
     
    Pandaxclone2 likes this.
  17. kprovost7314

    kprovost7314 GBAtemp's Official Bara Master

    Member
    1,716
    932
    Dec 24, 2014
    United States
    In that bara manga ( ͡° ͜ʖ ͡°)
    I have access to the eShop on 9.6.0-24U. I'm not sure which exploit it is. I see menuhax-manager on it so I'm guessing it's that or *hax, I really have no clue, but can I download apps (my nnid isn't linked yet)?
     
  18. shinyquagsire23

    shinyquagsire23 SALT/Sm4sh Leak Guy

    Member
    1,966
    3,249
    Nov 18, 2012
    United States
    Las Vegas
    Only NNID logins are restricted with older versions so that would be it.
     
  19. kprovost7314

    kprovost7314 GBAtemp's Official Bara Master

    Member
    1,716
    932
    Dec 24, 2014
    United States
    In that bara manga ( ͡° ͜ʖ ͡°)
    But what's this I hear about a spoof?