N3DS 11.3, A9LH and Luma installed - Webbrowser not working

Discussion in '3DS - Flashcards & Custom Firmwares' started by aut0mat3d, Apr 21, 2017.

  1. aut0mat3d
    OP

    aut0mat3d GBAtemp Regular

    Member
    116
    60
    Mar 15, 2017
    Australia
    Please forgive me, if this was already answered, did not find the Problem here due searching:

    I hava a N3DS XL with Firmware 11.3.0-36E, did Soundhax, installed A9LH and Luma following the 3ds.guide. The Only step i did not follow was the update part as i want to stay on 11.3.
    After Jailbreak i installed some homebrews, many VC injects and some Games (which we do own here as carts) via Freeshop

    I do use Update Blocking via my Firewalls DNS.
    All is working fine except the Webbrowser which stops after URL input.

    Original Error Message (german):
    "Der Internetbrowser kann zurzeit nicht verwendet werden. Versuche es später erneut oder verwende eine andere Netzwerkumgebung)"
    Roughly translated:
    "The Webbrowser can not be used at the Moment Try again later or use another Network connection"

    I also tried to input the URL of my local Webserver which causes the same error message.
    Luma is 7.01, also tried the latest houly (yesterday)
    Now i am wondering what happened to break the Webbrowser as it worked on arm9loaderhax install - or is it something like proxying over Nintendo Servers?
    Freeshop is working, no other device is struggling over internet access problems.

    Perhaps it could be fixed by manually installing some of the firmware files? - already downloaded full update files for 11.3 via NUSgrabber but i do not want to shoot random .cia to my system.

    Thx for your Time and Help ;)
     
  2. SKGleba

    SKGleba O ja pierdole!

    Member
    285
    147
    Nov 11, 2016
    Poland
    Warsaw
    3ds automatically check for nintendo servers-maybe an app blocks acces (dns etc)
    Just uninstall recently installed apps
     
    aut0mat3d likes this.
  3. aut0mat3d
    OP

    aut0mat3d GBAtemp Regular

    Member
    116
    60
    Mar 15, 2017
    Australia
    Thanks, as i ivested many hours with installing/theming/doing backups i dont want to loose my current setup.

    Would this be a possible way?:
    • Doing a Backup of the installed tickets
    • Doing a Backup of the Home Menu layout
    • Safectrtransfer of my backed up 11.3
    • Restoring tickets and Home Meu layout
     
  4. SKGleba

    SKGleba O ja pierdole!

    Member
    285
    147
    Nov 11, 2016
    Poland
    Warsaw
    Ok i see.
    Maybe its a conflict between latest luma and non-latest firmware.
    Edit:Its possible to backup everything (and recommended) and after backup ,update firmware and if it wont work just go back to 11.3 .
    If it work it means that you must reinstall 11.3 with (nonlatest) luma
     
    Last edited by SKGleba, Apr 21, 2017
    aut0mat3d likes this.
  5. aut0mat3d
    OP

    aut0mat3d GBAtemp Regular

    Member
    116
    60
    Mar 15, 2017
    Australia
    Thanks again!

    ATM i am doing a backup of my SD card in prior to updating to 11.4:
    • Booting with Luma and without SD card (Luma is injected to SysNAND) works fine
    • Accessing the Browser gave me the same error as in first Post
    • Changed DNS to my Modem (no Blocking), Browser works
    • Browsed to Google and another Page
    • Changed DNS back to my Firewall (blocking)
    • Rebooted the System and Browsing works - weird
    Perhaps the Webbrowser needs a one time Access to Nintendo on his first start? (i did only use it for arm9loaderhax on 2.x and the System was setted to factory defaults when i purchased it)
    After restoring 11.3 via safectrtransfer the webbrowser must have been in "mint condition"
    So, if anyone is struggling over the same Problem, this could probably help.
     
    Last edited by aut0mat3d, Apr 21, 2017
  6. John_Kirky

    John_Kirky Advanced Member

    Newcomer
    55
    33
    Jan 12, 2017
    Gambia, The
    browser checks internet connection at start by contacting nintendo

    you blocked updates in router by blocking nintendo servers in dns

    see the connection (or the lack thereof)?

    Regards,
    Kirky
     
    HyperT and aut0mat3d like this.
  7. aut0mat3d
    OP

    aut0mat3d GBAtemp Regular

    Member
    116
    60
    Mar 15, 2017
    Australia
    These are the DNS rewrites (pointing to my firewall) i use:
    (should block updates for 3DS, WiiU, Switch) - we have here 2x N3DS, 2x3DS, 1x2DS, 2xWiiU, 1xSwitch @home)
    Code:
    nus.wup.shop.nintendo.net
    cbvc.nintendo.net
    atumn.hac.lp1.d4c.nintendo.net
    nus.cdn.c.shop.nintendowifi.net
    c.shop.nintendowifi.net
    nus.c.shop.nintendowifi.net
    cbvc.cdn.nintendo.net
    nus.cdn.wup.shop.nintendo.net
    nus.cdn.shop.wii.com
    
     
  8. John_Kirky

    John_Kirky Advanced Member

    Newcomer
    55
    33
    Jan 12, 2017
    Gambia, The
    and it‘s only one that can't use the browser?

    Friend of mine just chimed in: He had the same problem when connecting to a public Hotspot after an update.
    He then connected to the nintendo zone at gamestop and suddently it was working again.

    So I conclude, that a newly updated System (mint like you said) needs to connect a least onece to a free wifi, possibly connecting to one of the sites you blocked to check, if the update was good. Since the updates from carts are not updating the webbrowser it makes sense for the browser to check.

    Sadly as soon as you are doing that you might get the update nag (I'm not sure about that one, perhaps someone can englighten me here?)

    Regards,
    John
     
    Last edited by John_Kirky, Apr 21, 2017
    aut0mat3d likes this.
  9. aut0mat3d
    OP

    aut0mat3d GBAtemp Regular

    Member
    116
    60
    Mar 15, 2017
    Australia
    Thanks!
    I reproduced it on a Old 3DS with 11.3 - no update nag so far, perhaps i had luck due changing dns, launching browser, changed dns back.