My X-Rom 512MB won't save! Please help me!

Discussion in 'GBA - Flashing Hardware and Software' started by Pyro2Z, Aug 27, 2006.

Aug 27, 2006
  1. Pyro2Z
    OP

    Newcomer Pyro2Z Member

    Joined:
    Aug 27, 2006
    Messages:
    18
    Country:
    United States
    Hello! I have myself an X-Rom 512 right now. I would say "I recently got an X-rom 512..." but that isn't the case. The fact of the matter is, I've been trying to get this thing to work for roughly 8 months, give or take a couple weeks. I've qwent to forums, I've read every guide avalible, and I just can't get it to work. I come here out of desperation, and as my last resort, however I definetly would of came here first if only I knew this awesome site existed.... ANYWAY....

    My X-Rom has 2 problems, 1 more annoying then the other. First, the more annoying. I can't save my games. I can get them onto my cart just fine, but the actual saving data, is impossible. I've tried everything to get it to work: I used Littlewriter, I auto patched them, I didn't auto patch them, I patched them seperatly with GBATA, I use X-Rom Flasher, and yet... the results remain the same. Is there something HORRIBLY obvious that I'm missing? I'lll gladly post a screen shot of my littlewriter screen or my X-Rom flasher screen if you think this will help.

    The second annoying (yet not nearly AS annoying problem) is that I can only put 1 file on at a time. I don't know if these 2 problems are related, but it's possible I guess. The roms get on there fine, no problems there, it's the actual SELECTING of the roms... I can make my selection, find the game I want, hit A... then it freezes, nothing happens. Preeeetty much sucks. [​IMG]

    You truly are my last hope guys, I really really hope you can help me... It would do me a great service, and even greater favor. Thank you.
     
  2. lagman

    Former Staff lagman I wish I was green.

    Joined:
    Nov 5, 2003
    Messages:
    4,071
    Location:
    Me, To You
    Country:
    Mexico
    Well, i have a X-Rom 512, an I have never ever have those problems.
    I guess it could be a battery problem, try to change it, that may solve the 1st problem, the second...well it would help if you specify with wich roms are you having those problems, maybe the Camelot ones.

    Some roms need to be loaded in Single Rom Mode.

    hmm [​IMG] Are you selecting Multiple GBA Rom right?

    Here are my settings if you think that it can help:

    Code:
    Trim Patch     ÂAuto ON
    No Trainer     ÂAuto ON
    SRAM Patch    ÂAuto ON
    
    Multi Rom and everything else  OFF
    
    Actual priority order
     
  3. Pyro2Z
    OP

    Newcomer Pyro2Z Member

    Joined:
    Aug 27, 2006
    Messages:
    18
    Country:
    United States
    Saddly, I am selecting MultiRom, still nothing. And I have all those settings already...set. I turned off the SRAM Patch, but only when I used GBATA to patch it beforehand. I have since turned it back on, and still no luck. (I had that on before anyway, before I turned it off and tried it manually with GBATA). [​IMG] And the battery idea, while possible to change, isn't particualrly easy from my understanding, I've heard it to be prtty hard a matter of fact so that is something I'm definetly trying to avoid, especially since it SHOULD NOT be dead as I never used it much in the first place, because it never even WORKED in the first place haha saddly...

    Edit: Oh yes! The rom. While the rom in question here is Mario Kart Super Circut do to the fact it speficically tells you that the data can't be saved, instead of other games I tried like mega man zero where it doesn't give you any indication one way or another, until AFTER you turned off yoursystem and have to start all over. I've tried several others, no matter the game, no saving ever takes place.
     
  4. Dirtie

    Former Staff Dirtie :'D

    Joined:
    Sep 9, 2003
    Messages:
    3,705
    Location:
    Zealer
    Country:
    New Zealand
    Sounds faulty in some way, you should have returned it not long after you got it, but I guess it's too late for that now [​IMG]
     
  5. ShadowXP

    Member ShadowXP ¯\_(ツ)_/¯

    Joined:
    Dec 20, 2002
    Messages:
    3,430
    Country:
    United Kingdom
    Personally I'd never use GBATA for patching, use LittleWriter. I've used GBATA before and it's only caused me problems, and I've also had no problem setting autopatches etc.. Like Dirtie said, it's most likely you've got a defective cart, or, perhaps the battery's died?
     
  6. Pyro2Z
    OP

    Newcomer Pyro2Z Member

    Joined:
    Aug 27, 2006
    Messages:
    18
    Country:
    United States
    I sure hope that isn't the case... well anyway, here's what my LW screen looks like right after I finished flashing TNMT on there (a game I have yet to flash, so I wanted to try my luck maybe I've just been using bad roms... all 14 of them.)

    [​IMG]

    Still no luck, as my little character sprite demonstrates ( I figured I needed to lighten up my otherwise grim issue.)

    I hope this will add some extra insight, I am really thankful for all the help thus far.
     
  7. lagman

    Former Staff lagman I wish I was green.

    Joined:
    Nov 5, 2003
    Messages:
    4,071
    Location:
    Me, To You
    Country:
    Mexico
    [​IMG]

    Do you notice the main diference? [​IMG]

    It looks as if you have selected Sinlge Rom Mode, and any patch on.
     
  8. dOoBiX

    Banned dOoBiX Banned

    Joined:
    Jul 8, 2006
    Messages:
    72
    Country:
    United States
    When I first got my X-rom, the save files kept getting cleared. So I returned it back and they sent me a new one and it works great! [​IMG] The problem that it couldn't save was because of the battery... You should have returned yours too when you found out it didn't save.
     
  9. Hero-Link

    Member Hero-Link Hero of Derrr

    Joined:
    Nov 6, 2002
    Messages:
    1,185
    Location:
    Portugal
    Country:
    Portugal
    cant it be the battery that is already dead? (inside the X-Rom)
     
  10. Pyro2Z
    OP

    Newcomer Pyro2Z Member

    Joined:
    Aug 27, 2006
    Messages:
    18
    Country:
    United States
    Yeah, I did select single rom... Multirom never worked, so I'm settling for single, don't wanna get greedy haha...

    But what do you mean by any patch on? Could that be my problem?
     
  11. lagman

    Former Staff lagman I wish I was green.

    Joined:
    Nov 5, 2003
    Messages:
    4,071
    Location:
    Me, To You
    Country:
    Mexico
    You´re using an old version of Little Writer.

    I mean that the TMNT GBA must say: EEPROM PATCHED and it doesn´t.
    X-ROM only works with SRAM saves, so any EEPROM or FLASH save type must be patched in order to work.
     
  12. Bullshirt

    Newcomer Bullshirt Member

    Joined:
    Jan 25, 2006
    Messages:
    40
    Country:
    Canada
    ^

    That shouldn't be problem at all... I use 1.0.8.3 and mine works fine.
     
  13. lagman

    Former Staff lagman I wish I was green.

    Joined:
    Nov 5, 2003
    Messages:
    4,071
    Location:
    Me, To You
    Country:
    Mexico
    Then it´s the battery.
    Just look for someone who can change it, mine still working but I already know someone who can replace the battery.

    BTW, if you´re using single rom mode, there MUST NOT be a rom selection screen [​IMG]
    maybe I get it wrong [​IMG]
     
  14. Pyro2Z
    OP

    Newcomer Pyro2Z Member

    Joined:
    Aug 27, 2006
    Messages:
    18
    Country:
    United States
    Nuts... Luckily I have a place by my house called "The Mod Shop" which sells flash carts, so maybe they can replace the battery? I hope so. If not, or if it's simply too expensive, what's your opinions on the EFA Linker? Or a comparable flash cart? Thanks a bunch fellas, you've been a great help so far.
     

Share This Page