My wii is a mess, help to fix IOS bugs please

Discussion in 'Wii - Hacking' started by gpt1plon, Aug 14, 2010.

Aug 14, 2010
  1. gpt1plon
    OP

    Newcomer gpt1plon Member

    Joined:
    Nov 23, 2008
    Messages:
    13
    Country:
    United States
    Hello,

    I have been using my wii for several years now, it was one of the first model.
    I have installed plenty of things on it. and so far everything works fine with USB loader GX.

    Recently I tried to upgrade the homebrew channel as my revision is quite old.
    I followed the user guide and even try the online upgrade:

    - Manuel upgrade using the boot.elf from the homebrew channel, wii is stuck on the scam page
    - automatic using upgrade menu, wii is stuck on the scam page

    So basically I can't upgrade the homebrew channel

    I did an audit with Pimp my wii, and it returns plenty of error, see pics attached, pics
    Tests of several IOS is failing, downgrades are not working

    I tried DOP-Mii also, and it is not very conclusive.

    So, I have a working system, however I reckon there is something dodgy.

    Are you able to help me to fix of the bugs I have so I have a "clean" cutomized system ?

    Thanks

    pics

    [​IMG]

    [​IMG]

    [​IMG]
     
  2. nIxx

    Member nIxx GBAtemp Maniac

    Joined:
    Sep 30, 2007
    Messages:
    1,459
    Location:
    Germany
    Country:
    Germany
    Get rid of PimpmyWii and any other fail cIOS installation. Replacing every IOS with a custom one just isn´t good and not needed as it leads to problems with HBC.
    If you pelace a IOS keep in mind that you whatever you do don´t delete the IOS that is used for the Sysmenu or at least directly reinstall that IOS after uninstalling it.
     
  3. gpt1plon
    OP

    Newcomer gpt1plon Member

    Joined:
    Nov 23, 2008
    Messages:
    13
    Country:
    United States
    Ok, How to get rid of them?

    Posts merged

    Should I upgrade to 4.2 ?
     
  4. Slowking

    Member Slowking GBAtemp Maniac

    Joined:
    Dec 31, 2006
    Messages:
    1,396
    Country:
    Germany
    Nah get dop-mii and install a lean version of every IOS.

    Only IOS60 you should trucha patch...
     
  5. smf

    Member smf GBAtemp Advanced Fan

    Joined:
    Feb 23, 2009
    Messages:
    839
    Country:
    United Kingdom
    You should only trucha patch an IOS if you know why you are patching it. Otherwise you should leave well alone.
    I've only ever updated via nintendo, though I haven't bothered with 4.3 yet.

    If all you want to do is use a usb loader and triiforce then patching standard IOS is pointless.

    If you want to run DVD-r's then buy a chip, darkcorp is rubbish in comparison.
     
  6. Slowking

    Member Slowking GBAtemp Maniac

    Joined:
    Dec 31, 2006
    Messages:
    1,396
    Country:
    Germany
    Andd everyboy knows why you would trucha patch IOS60. So that fakesigned VC and Wiiware games work from SD... -.-
     
  7. gpt1plon
    OP

    Newcomer gpt1plon Member

    Joined:
    Nov 23, 2008
    Messages:
    13
    Country:
    United States
    Hmmmm, in simple term, what's the best way to do that? I am not expert as you guys [​IMG]
     
  8. toejam316

    Member toejam316 GBAtemp Regular

    Joined:
    Apr 20, 2007
    Messages:
    259
    Country:
    New Zealand
    You could try running the DarkCORP uninstaller - it should theoretically install a clean version of all Nintendo IOSes.
    Then you can install the latest version of the Homebrew Channel, update to 4.2 or 4.3, Trucha Patch IOS 70 or 80 (depending on the system menu you upgraded to), and install both Waninkoko's and Hermes' cIOSes.
     
  9. FIX94

    Global Moderator FIX94 Global Moderator

    Joined:
    Dec 3, 2009
    Messages:
    6,556
    Location:
    ???
    Country:
    Germany
    Do you mean how to patch the system IOS? That's easy. You will need DOP-Mii for this. Start DOP-Mii, select IOS36 to install other IOSes, got to IOS, BC, MIOS and select your system IOS (IOS60=firmware 4.0 and 4.1, IOS70=firmware 4.2, IOS80=firmware 4.3) and press plus to install it and answer all four questions with Yes (A).
     
  10. Sao Mortel

    Member Sao Mortel GBAtemp Advanced Fan

    Joined:
    Jul 23, 2008
    Messages:
    533
    Location:
    Montreal
    Country:
    Canada
    Just start by following this guide and upgrade to 4.2 even if youre on 4.2 and make a nand backup even if your nand is all f up. After that step come back to us well fix what is still wrong.
     
  11. gpt1plon
    OP

    Newcomer gpt1plon Member

    Joined:
    Nov 23, 2008
    Messages:
    13
    Country:
    United States
    Hello,

    I tried a few things, not very successful:

    FIrst, I am on 4.3 Wan. (from System menu)
    and when I launch the USB loader I can see IOS 249 Rev 19

    On the HBC, if I click on bootmi , then I get a black screen, somthing I guess if dodgy here.
    The HBC version is 1.0.6 and everytime it asks to upgrade to 1.0.8, however it get stucks on the scam page.

    Knowing that according to wii menu I am on 4.3 Wan, is there a way to rebuilt my wii on 4.2, clean install and then hack it again.

    I have the priiloader install and that works fine.
    So, should I leave my wii as it is or should I try to fix the bugs? like the upgrade of the HBC

    Thanks
     
  12. burritoboy9984

    Member burritoboy9984 GBAtemp Advanced Fan

    Joined:
    Jan 24, 2009
    Messages:
    845
    Country:
    United States
    Go to the modify any wii post. Grab the up42 file for YOUR REGION. And FOLLOW THE GUIDE to update (in this case downgrade) to 4.2. Make sure you FOLLOW THE GUIDE in the correct steps or you risk bricking! After you have done the update portion, continue onto the modify portion.

    -Erik
     
  13. gpt1plon
    OP

    Newcomer gpt1plon Member

    Joined:
    Nov 23, 2008
    Messages:
    13
    Country:
    United States
    Hello,

    I did grab the up42 file and tried to follow the guide.
    Problem starts at the begining as bannerbomb is not working. I go on the channel menu and look inside the SD, the wii found the file but there is no way to launch it.
    I am wondering is there is any point of runing the exploit knowing that I have the HBC already installed.

    Anyway, so I tried the next step with is to run Yet Another WAD Manager Mod from the Homebrew Channel . That one is not working, just gets an error code and crash.

    Thanks.
     

Share This Page