My trajetory of safe-upgrading + HELP ME!

Discussion in 'Wii - Hacking' started by bluebluewolf, Apr 6, 2009.

Apr 6, 2009
  1. bluebluewolf
    OP

    Newcomer bluebluewolf Newbie

    Joined:
    Apr 6, 2009
    Messages:
    7
    Country:
    Brazil
    So, hello everyone. I'm glad to have joined a forum with so many knowledgeable friends.

    I remember when I bought my Wii last year, in August. It is hardmodded, with a D2CPro or a D2CKey, I can't remember which. I also remember that, back then, I could use full SD features of WAD-installed VC games or WiiWare. I could move them over to the SD card, move them back to the Wii... It was awesome. This could mean that I was using v3.2U... but I think I have used 3.3U since the day I bought it. Or at least I thought... Yeah, I guess I was on 3.2U if that kind of thing still worked.

    But then, something happened. About two weeks after I got the console , if I recall correctly, I upgraded using a Mario Kart Wii disc. I was such a noob. I wish I could send a clone to the past. But no big deal... anyway, I was oficially on 3.3U. My Wii Menu Config used to say I was on 3.3U since then, so maybe that was what has led me to believe that I had always used it. Anyway, everything was still working fine. The Mario Kart Wii worked, all the discs I had worked, HBC was already installed, it could still install Wads...

    I noticed something cwappy though. The inability for the Disc Channel to boot some of my games (I thought it was pure chance, but then I figured all of those discs were whether edited games or region changed - you all know what this means... trucha). No problem, used Gecko OS. I still use it.

    And something even more cwappy. The SD features. Couldn't copy anymore. Couldn't move it anymore.

    But it was no big deal back at the day. I started using Wad Installer for every single VC/WW I wanted to play, instead of copying straight from the SD card like I used to do on 3.2 (yeah, I installed them all, then just moved them over to the SD card back on the day).

    Then the 23th of October came in, and I used the IOS51+Shop installer. Ok.
    Also, I used the Mii Channel Updater along with it. So it was more like late November, not October.

    Now 4.0 is here... So what I did was installing the cIOS249 rev. 9, that I found out I had never had (checked it using AnyTitleDeleter). I also deleted the VC games I had installed, and Nintendo Channel and Internet Channel (never liked them anyway). I was told that I needed to install the custom IOS before upgrading, so I could still use Wad Manager on 4.0. So that was what I did; because, if I can't use Wad Manager, it's just like a bricked Wii for me. It would break my heart completely.

    Installed cIOS249, I ran Waninkoko's Firmware 4.0 Updater. OK, downloaded eveything, installed everything, took about half an hour. Okay, I'm on 4.0 now.

    Original games from Disc Channel still works.
    Backups from Disc Channel still works.
    Trucha disks freezes my Wii, but works using GeckOS.
    WAD Manager works.
    Install wads. They work fine.
    Didn't check the Shop Channel, don't care enough.

    But... I moved some channels to the SD card. Namely, My Pokémon Ranch and Excitebike. Excitebike I had just installed, testing the Wad Manager. My Pokémon Ranch was with me all along since Wii Day One. THEY DON'T COPY BACK, just like they did on 3.3U. Even tested it on a formated SD.

    What can we conclude from that? That the Wii is exactly the same as it were before 4.0-upgrading, which is a VERY good thing. It did exactly what it says that it does. But, that's not good enough for me - it doesn't solve my problem! I shouldn't have upgraded to 3.3U back when I was a newbie. Today, I could still be enjoying trucha-discs straight from Disc Channel, and I could be copying channels to SD like a mad man - which also means using the SD Card Menu to boot them straight from it. But I threw it all away. There is no hope for me.... or is it!?

    I've heard of a Downgrader. Well, I should have used it after installing cIOS249, and before lauching 4.0 Updater. Did I mention that I wish to send a clone to the past?

    So now, I need a few answers. I am determined to make up for the past, fix my errors, and get that SD Card Menu working! Of coursing, telling my story along with it [​IMG]

    If anyone wants to help, feed me with answers for these questions:

    1) Is there a easy-to-use installer I could boot RIGHT AT THE STAGE I'M AT that overwrites some specific IOS's, and installs ones with those two very useful features that everyone loves? (Trucha and SD, it is). That would be useful as hell.

    2) If not, I guess the hard way means Downgrading. Is it possible at the stage I'm at?

    3) If yes, please give me some tips, advice, things I need to be sure to have, etc. Help me build this successful, interesting and useful story.

    Looking forward to it!
     
  2. drmarvin

    Member drmarvin GBAtemp Fan

    Joined:
    Jan 2, 2009
    Messages:
    309
    Location:
    Canada
    Country:
    Canada
    I believe your issue is the IOS61 situation. With the update, the Wii will block trucha signed wads to be copied to the SD card. If you get the IOS60/61 and shop updater, and only do the IOS61 update, it should allow you to copy things around again.

    Other than that, I wouldn't know because I did the things you did (without a modchip) and it all works great for me.
     
  3. bluebluewolf
    OP

    Newcomer bluebluewolf Newbie

    Joined:
    Apr 6, 2009
    Messages:
    7
    Country:
    Brazil
    When I upgraded to 4.0, I wasn't asked if I wanted to install some thing or the other. It just did everything... And I wouldn't be so sure that enforcing the non-upgrading of IOS61 would have helped. It would still use the version I had, from 3.3U, which already blocked trucha signed wads to be copied to the SD card, right? That's what I understand from it, anyway.
     
  4. bluebluewolf
    OP

    Newcomer bluebluewolf Newbie

    Joined:
    Apr 6, 2009
    Messages:
    7
    Country:
    Brazil
    I've heard somewhere that downgrading from 4.0 is hard. I am scared.
     
  5. bluebluewolf
    OP

    Newcomer bluebluewolf Newbie

    Joined:
    Apr 6, 2009
    Messages:
    7
    Country:
    Brazil
    Now I've heard it's impossible for the moment. I really really really should have downgraded before updating.
     
  6. bluebluewolf
    OP

    Newcomer bluebluewolf Newbie

    Joined:
    Apr 6, 2009
    Messages:
    7
    Country:
    Brazil
    I will now do as drmarvin said, and find the IOS 60/61 + Shop installer, and only install IOS61. I can't find it anywhere though...
     
  7. xyourmomx

    Newcomer xyourmomx Member

    Joined:
    Apr 2, 2009
    Messages:
    33
    Country:
    United States
    If you have cIOS36 rev9 installed already then you're fine. Just download cIOS Downgrader (its also called Custom IOS Downgrader too) and you can downgrade to 3.2 with no problems. Theres also an IOS Downgrader that just reverts the affected IOS' back to their pre-trucha fix days. So use the IOS Downgrader and an IOS60 patch and you should be set. I've got trucha discs running with no problems from the disc channel and I can copy SD games back and forth with no problems.
     
  8. bluebluewolf
    OP

    Newcomer bluebluewolf Newbie

    Joined:
    Apr 6, 2009
    Messages:
    7
    Country:
    Brazil
    Yeah yeah, I used the 60+61+Shop installer, but I was told to only download, install and patch the IOS60. That's what I did. Works great now, trucha *AND* SD [​IMG]
     
  9. robman62

    Member robman62 GBAtemp Regular

    Joined:
    Nov 23, 2008
    Messages:
    275
    Country:
    United States
    wtf is a trajetory....please LEARN 2 ENGLISH
     
  10. bluebluewolf
    OP

    Newcomer bluebluewolf Newbie

    Joined:
    Apr 6, 2009
    Messages:
    7
    Country:
    Brazil
    It was a typo... please LEARN 2 RESPECT
     

Share This Page