My Passport Ultra Isn't Being Detected... (vWii)

Discussion in 'Wii - Backup Loaders' started by Lordsble, Sep 12, 2018.

  1. Lordsble
    OP

    Lordsble GBAtemp Fan

    Member
    3
    Feb 12, 2016
    United States
    behind you
    ISSUE FIXED
    I'm having trouble with usbloadergx. I've been searching for two days on Google but nothing! I hear many people say that it's compatible but how?! It always says waiting for HDD, but my 8gb Sandisk works fine?? I tried my 32gb Sandisk Glide but the games never appear on the menu. I formatted my Passport so many times and in different formats but always the same result. Please...some help or guidance will GREATLY be appreciated. Thank you.
     
    Last edited by Lordsble, Sep 14, 2018
  2. DarkDengar

    DarkDengar Member

    Newcomer
    3
    Dec 5, 2015
    United States
    Are you using a USB Y-cable? If I'm not remembering wrong, the Passport is powered through USB only and does not have a separate power supply. I had this same issue with USB-only powered portable drives and Y-cables fixed the issue.
    If Google can't tell you what USB Y-cables are I'm sure I can find a link somewhere...
     
    Lordsble and Ericthegreat like this.
  3. Lordsble
    OP

    Lordsble GBAtemp Fan

    Member
    3
    Feb 12, 2016
    United States
    behind you
    Yeah I've heard a thing or two about Y-cables but my main suspicion was that my Passport Ultra is a 3.0 USB and the Wii U is a 2.0. But thinking about it now, I believe that 3.0 is backwards compatible right?
     
  4. DarkDengar

    DarkDengar Member

    Newcomer
    3
    Dec 5, 2015
    United States
    Correct; once again, I wondered the same thing, and my portable USB 3.0 drive enclosures worked just fine once I got more power to them. I firmly believe finding a Y-cable and using it should solve your problem.
     
    Lordsble likes this.
  5. Lordsble
    OP

    Lordsble GBAtemp Fan

    Member
    3
    Feb 12, 2016
    United States
    behind you
    Cool! I'll pick one up tomorrow or by the end of the week and update on the situation. Thanks for the reply!
     
    DarkDengar likes this.
  6. Lordsble
    OP

    Lordsble GBAtemp Fan

    Member
    3
    Feb 12, 2016
    United States
    behind you
    So I just ordered one and it comes in tomorrow but I have a question about format. What shroud I format my HDD to? And do you happen to know if GPT or MBR matter?
     
  7. Captain_N

    Captain_N GBAtemp Maniac

    Member
    5
    Mar 29, 2010
    United States
    If its 2 tb or less then mbr. i think gpt is not supported, but i could be wrong.
     
    Lordsble likes this.
  8. Lordsble
    OP

    Lordsble GBAtemp Fan

    Member
    3
    Feb 12, 2016
    United States
    behind you
    It still says waiting for HDD...is there a specific way to put it in the Wii U ports?

    EDIT: Just reformatted it using BOOTICE and it seems to work fine. Thanks for the help!
     
    Last edited by Lordsble, Sep 13, 2018
    CallmeBerto likes this.
  9. Lordsble
    OP

    Lordsble GBAtemp Fan

    Member
    3
    Feb 12, 2016
    United States
    behind you
    Nevermind...it went back to the waiting for HDD error...
    Idk what to do anymore...
     
    CallmeBerto likes this.
  10. Dionicio3

    Dionicio3 AyyMDionicio3

    Member
    10
    Feb 26, 2017
    United States
    Hollister, CA
    Is your drive beeping by any chance?
     
  11. Lordsble
    OP

    Lordsble GBAtemp Fan

    Member
    3
    Feb 12, 2016
    United States
    behind you
    It beeps only when one USB is connected to the console.
     
  12. Dionicio3

    Dionicio3 AyyMDionicio3

    Member
    10
    Feb 26, 2017
    United States
    Hollister, CA
    Yep, that 100% means the drive isnt getting enough power

    You need a Y-cable as stated above
     
  13. Lordsble
    OP

    Lordsble GBAtemp Fan

    Member
    3
    Feb 12, 2016
    United States
    behind you
    Sorry, I forgot to mentioned that I am using a Y cable.
    When I only insert one usb it beeps but when I insert both the beeps go away.
     
  14. Dionicio3

    Dionicio3 AyyMDionicio3

    Member
    10
    Feb 26, 2017
    United States
    Hollister, CA
    That's normal, once you use the Y-Cable it should have enough power
     
  15. Lordsble
    OP

    Lordsble GBAtemp Fan

    Member
    3
    Feb 12, 2016
    United States
    behind you
    I am using it but it still says waiting.
     
  16. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    21
    Oct 27, 2002
    France
    Engine room, learning
    the y-cable is meant to be used by inserted both usb plugs at the same time, to prevent drives clicking. that's the reason you bought it : to use it the way it's meant to be used.

    if your drive is still not detected even with the all the y-cable's ends plugged, then try editing USBLoaderGX settings > loader's settings > Loader's IOS : replace 249 with 58.
    you can also try latest beta from my signature, replace the boot.dol from the folder on your SD card with the one from the "mod" package you download from my signature. don't care about .patch and .elf file.
    it's not guarantee it'll fix your issue, it's beta !

    if you use both 58 AND the beta, the loader will load faster now.
    don't forget, it's a beta, not a stable release. think to update it one day (when 1269 or newer will be released).
     
    Last edited by Cyan, Sep 13, 2018
  17. Lordsble
    OP

    Lordsble GBAtemp Fan

    Member
    3
    Feb 12, 2016
    United States
    behind you
    Well the Loader IOS thing works!...but for some reason I feel like it's gonna go back to the Waiting for HDD eventually so I'm not saying it's 100% fixed yet. :rofl:
    But thanks for the help!
     
  18. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    21
    Oct 27, 2002
    France
    Engine room, learning
    it was funny (It was irritating, or sad) seeing everyone trying to find the solution, while I'm saying for two years in all Wii and vWii threads about HDD detection issue to use IOS58 and nobody even mentioned it once !
    seems like nobody read other user's problem and solution, and try to help without knowing what they are talking about.

    At least, the y-cable was a real help :)
    it's mandatory for WiiU. it shouldn't even be a reason to ask in the forum because all guides tells you to use a yCable. it's as simple as following a softmod guide.
    Maybe that's like the NAND and IOS backup, it's there in the guide but everybody think it's useless and a stupid suggestion.

    the IOS58 option is not in guides, because it used to work fine with cIOS. it's just a result of new manufactured drives needing that IOS.


    vWii softmod is easy :
    NO FLASH DRIVE (I guess I'll never stop repeating that because nobody read or try a simple forum's search, or even a simple click and read on existing threads on the first page)
    y-Cable, always
    IOS58 (which is now default on USBGX beta, because nobody seems to know about that requirement)
    done :)


    As for the HDD partition table format : both MBR and GPT are working with a lot of homebrew, but not all.
    if you want the best compatibility, go with MBR.
    GPT is compatible with USB loaders and nintendont.

    USBLoaderGX has a bug with GPT if you have mixed partitions format (fat32+ntfs for example). It works fine with single partition, or multiple same format (fat32+fat32).
    one day I'll fix it... or someone else with more free time.


    if you want even more compatibility, don't by a drive bigger than 2TB, and preferably old models. New models are using 4096bytes/sectors, it's not working with few homebrew (emuNAND, neek).
     
    Last edited by Cyan, Sep 13, 2018
    Lordsble likes this.
  19. Lordsble
    OP

    Lordsble GBAtemp Fan

    Member
    3
    Feb 12, 2016
    United States
    behind you
    Sorry I was watching the Nintendo Direct :rofl: but after running a few tests it seems that my "Waiting for HDD' problem comes from installing and launching USBGX as a channel. I'm using the "fix" .wad.
     
  20. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    17
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Mar 17, 2010
    Norway
    Alola
    USB Loader GX-UNEO_Forwarder_5_1_AHBPROT_vWii (Fix).wad
    This one? That should be the latest.
    FAT32, 32k or 64k clusters. Must be MBR, so double check that it's actually MBR and convert it if not.
     
Loading...